Topaz Photo AI v1.1.3


This release has several improvements and fixes including saving mask strokes while using the Photoshop plugin, several masking related fixes, and fixing a long-time error on Windows where images with non-ASCII characters (Ø, Ü, 日本語, 한국어, etc) would prevent the external editor from loading the image. We’ve also improved some UI related things like the batch tooltips when hovering images, right click menu interactions, and other general polish.

Please give us any feedback or report issues with this release. We’ll be updating TPAI regularly to address those pieces of feedback and issue reports. If there’s a specific image you’d like us to see, you can send it us at this dropbox link.

Released December 22, 2022
Mac: Download
Windows: Download

Changes since 1.1.2:

  • Photoshop plugin can now save masking strokes between runs on the same image
  • Current image should now be removed from the background when loading another image
  • Added formatting support based on current locale (e.g., 2.87 will be 2,87 for locales that use comma as the decimal separator)
  • Improved batch tooltip UI
  • Improved error messages when model fails to load or run
  • Modified error messages coming from the image reader to hopefully be more clear
  • Added an unfocused color to the titlebar


  • Fixed issue where certain characters would cause issues with external editors (e.g., Japanese, Norwegian, some German characters, etc)
  • Fixed an issue where only the preview area of the image would be saved if saving at the exact right moment during processing
  • Fixed mask not rendering when subject mask was set to “None”
  • Fixed some masking related crashes
  • Fixed turning off subject mask not updating preview until panned
  • Fixed crash reporter not running in plugin mode
  • Fixed some RAW files loading with incorrect colors due to floating-point black level values
  • Fixed several RAW files using incorrect camera profiles
  • Fixed right clicking preview showing original image
  • Fixed some cases where the current image would process while switching to another image
  • Fixed interaction with Apply Settings to All and Face Refinement
  • Fixed Linear RAW interaction with Apply Settings to All

Known Issues:

  • We are investigating some issues with images sometimes not being imported back to LR
  • “Apply Settings to All” may not work if the batch includes Linear RAW images
  • Pixel shift in some cases

We’re working on many more exciting improvements! Instead of a couple bullet points at the end of the changelog, we’re transitioning to regular roadmap updates that go more in detail on what’s coming up next, where people can give feedback on the direction we’re going. Check out the first of these here:


Crashes when I try to use it as a plugin from Affinity Photo version 2.
Windows 11.

1 Like

You need to provide more information such as the version of AP and your operating system.

When you did the update did you exit from AP?

Installed to Win 11 Pro desktop PC. Tried Standalone. Auto Processor Pref.

JPG image. Masked a portion of image & used Sharpen Subj. Only.

I don’t see any sharpening b/wn the ORIG view & the processed PREVIEW view. See attached, labelled snips of Before, Mask, After below.

Can someone pls remind me the Hotkey combo (since it’s not noted on the keys in the UI) for Add & Subtract in the Masking Brush so I don’t have to keep going to the buttons in the righthand panel? Thank you. I’ve recapped my (& others) wishes for the masking brush several times since alpha & have also posted them as a request/wishlist in the product roadmap forum. My wishes still hold. Others have endorsed with their :hearts:

Did you mean Affinity?

1 Like

Please add ‘image shifts when moving slider in split compare preview’ to known issues…and hopefully it gets fixed in the next release, as this buggy behaviour was only introduced about 3 releases ago…thanks


I’m experiencing the same thing & have for a while.

1 Like

It’s uber annoying! :joy:

V1.1.3 Instanly crashes when called from Affinity Photo 2.0.3. Log is attached.

The file being passed is a TIFF file. It is the same file that I use to check each new release.

I did this multiple times. It appears only one file in the Logs folder. Every time Affinity Photo is complete shut down. There was no editing to the TIFF file before sending to Photo AI.

This happened in v1.1.1 but did not happen to me in v1.1.2. Log is attached.

Runs fine stand alone.

Mac mini M1 (2020) 16GB Monterey 12.6.2

2022-12-22-19-55-46.tzlog (9.9 KB)

Fixed: Copied TopazPhotoAI.plugin from Library/Affinity Photo 2/Plugins to Library/Affinity Photo 2 Beta/Plugins

Although the error was coming up while running Affinity Photo 2 it appears that Photo AI was looking for the plugin in Library/Affinity Photo 2 Beta/Plugins. As soon as I copy the file to that folder it started to work again.


It just makes me seasick b/c it looks like ocean waves rippling. :ocean: :rowing_man:t3: :ring_buoy:

1 Like

When I save an image, the exif information is lost.

I’m getting a crash every time I try to apply the same style of my current image to many different images that I have loaded. I extracted frames from a video and I tried 2000 at a time all the way down to 250 and the software can’t even handle that. Even at 250 images, it just crashes when I click the apply same settings button. I’m trying to keep the scale at 1x + face enhancement. No other enhancements.

EDIT: Turns out I was on the previous version, not 1.1.3. I updated and now I was able to apply my settings (didn’t try face enhancement) to all images and it seemed to work without crashing. It did take a very long time though. If it’s going to take this long 60 seconds+, it would be nice to have some type of progress bar so I know that the program is still working and so that I could see how much longer it will take. I will have to test images with face refinement later to see if that works.

If you place plugins in any directories please, please delete them when the application is deleted. For example the Beta plugin is left over in the Affinity Photo plugins folder.


Luckily processing protocol in AP 2 can recover:

Same here. Three versions in a row now.
Windows 11 Pro, Affinity Photo 2.0 Ryzen/NVIDIA

(repost due to appearing in wrong part of the thread)

Since I don’t see most of these mentioned in the known issues, I’ll link to my post from 1.1.2:

Ok, the pixel shift has been acknowledged but only mentions preview

It’s not only in the preview, upon sharpening the subjects (or whole image) is shifted in the saved/exported image as well.
This has an interaction with face recovery which undoes the shift, displacing heads relative to the (sharpened) body it’s attached to.
I’ve found mentions of this issue going back to version 1.0.4.

The (denoise) strength slider having no impact on the strength has been reported at least since v0.10

Delighted to note that crash of app on some of my photos (but every time on these) when using the Refine brush appears to have been resolved in this version. Thanks ever so!

1 Like

I have always used it from AP 1 and now AP 2 and have not had any crashes (Win 11, NVIDIA GTX1050). The only thing I can think of is that you may have had Affinity open when updating Photo AI which would mean that the plugin file wont be updated.

Open APs default plugin location, you can find it in preferences and click on the link to open it, and replace the PhotoAI plugin there by copying the TopazPhotoAI.8bf file from where PhotoAI is installed on your PC.

Hi! Can you please send me the original image through Dropbox? Thank you!

1 Like

Hi - can you please send me the log from the same timestamp as the crash session from Help > Open Log Folder? Thank you.

Hi - If you can send me the original image through Dropbox, it’d be very much appreciated. Please let me know if you’ve sent it. Thank you!