Topaz Photo AI v1.1.2

Howdy!

This release implements a long requested feature - applying your current image settings to all the open images! This release also has a new model and a good number of bug fixes and general polishing.


Please give us any feedback or report issues with this release. We’ll be updating TPAI regularly to address those pieces of feedback and issue reports. If there’s a specific image you’d like us to see, you can send it us at this dropbox link.


v1.1.2
Released December 15, 2022
Mac: Download
Windows: Download

Changes since 1.1.1:

  • Added “Apply current settings to all” in image menu
  • New model for suggested strength parameter for RAW Denoise Strong
  • Updated camera profiles
  • Improved error handling in LrC Plug-In Extras flow
  • Added filename validation to prefix and suffix text fields
  • App updates dialog opens faster, update indicator is hidden while login dialog is open
  • Fixed some images having incorrect image cropping applied
  • Fixed prompt for sending RAW images as TIFFs from LrC appearing when it shouldn’t
  • Fixed preview snapping when changing zoom
  • Fixed “Subject Only” toggle not working
  • Fixed GPS data being stripped when saving images
  • Fixed some images loading with vertical stripes
  • Fixed users with expired licenses not being able to use an owned version of the app while offline

Known Issues:

  • Apply Settings sets the incorrect number of faces in Face Recovery
  • Apply Settings to or from linear raw files will cause a model loading failure from other formats
  • When subject is set to “None”, mask strokes disappear after you lift your mouse. As a workaround, you can select a different subject setting and erase it.

We’re working on many more exciting improvements! Instead of a couple bullet points at the end of the changelog, we’re transitioning to regular roadmap updates that go more in detail on what’s coming up next, where people can give feedback on the direction we’re going. Check out the first of these here:

7 Likes

According to the filename, this update is 1.1.1, and the number of bytes is exactly the same as last week’s update. It would appear that the link is to the wrong file.

4 Likes

Thanks for the heads up, we just updated the link to the correct one.

3 Likes

Photo AI v1…1.2 does not crash when loaded from Affinity Photo 2. I had reported in V1.1.1 that it did. Really glad to see that fixed.

2 Likes

On most software, I’m able to click on “about” and get version info, but I don’t see any version info on my “version”? Can this be added on future releases, so we know what version we’re using, or is version info located or displayed somewhere else and I’m missing it?

New version (1.1.2) still fails to process grass when Remove Noise is enabled I’ve reported this issue in the two prior versions and uploaded the image file for dev use in the immediately prior version. No joy so far.

The first screen shot shows the distortion/artifacts to the left of the face. The second screen shot shows the same image, with Remove Noise disabled. Remove Noise is the only thing that affects these artifacts, no other control does anything about them.

5 Likes

@walter.benn I am on a Mac and the version shows at the top of the screen right in the middle. I don’t know if it is different on Windows.

1 Like

Hi Walter - on both Mac & Win the version number shows up on the top just in the middle. We will also be adding an About section to the app in future updates :slight_smile:

Just downloaded the latest update. Tried it on a photo of a 70 year old wedding photo of my Mother and Bridesmaid. My mind is totally blown!!! Absolutely unbelievable recovery of their faces! Thanks for a wonderful product.

1 Like

New version (1.1.2) fails to process grass when Remove Noise is enabled

2 Likes

Same old problem back again, PAI works fine as a stand alone, but crashes every time I try to use it as a Photoshop plug-in. Had this problem in version 1.1.0, worked fine in version 1.1.1. Now with version 1.1.2, causes Photoshop to crash.

Can confirm fixed:

  • Vertical lines seen in 200%+ zoom are gone.
  • Sharpen subject only, only sharpens the subject.

Issues still present* :

  • Sharpening shifts the whole image or sharpened subject (depending on ‘subject only’ setting) down+right.
    When only the subject is sharpened its alignment relative to the rest of the image is changed, stretching the top/left and squishing the bottom/right.
    [visible in saved output]
    –Recover face undoes its sharpening shift, now misaligning the face from the rest of the image or subject (often the person who the face belongs to).
    [visible in saved output]
  • Remove noise (normal/strong models) strength slider has no influence over the amount of noise reduction applied. The default is successful at removing noise, but a bit too strong creating an artificially smooth look.
  • The actual before/after transition does not line up with the before/after slider at zoom levels of 50% or lower. On the left it’s further left, on the right further right.
  • In zoom levels other than 100% the before preview has a slight crop compared to the denoised/after preview. Toggling visibility or sliding the slider back and forth show this as an apparent shift. Most clearly visible towards edges of the photo.
    [not visible in saved output]

Nice to have:

  • Zooming with scroll wheel to pan the image so that the area under the cursor remains in view.
    Now it ignores the cursor and zooms on the current centre of the viewport.
  • An indication if any lens correction profile was found/applied at all other than having to toggle “apply lens correction” on/off.

Fun fact:

  • Face recovery gives sand-lime stone statues blond hair and brown eyes.

*:all of these found while doing “edit with>process with Topaz Photo AI” from Capture One using zip compressed 16bit TIFF AdobeRGB as export format. Not zip compressing makes no difference.
PC has CPU Intel i5 6600K, RAM 16GB DDR4, GPU AMD RX480 8GB

4 Likes

There is a problem with not being able to handle wide-gamut images.

Pro Photo RGB TIFF (16-bit SDR) original is displayed with incorrect colors (difficult to assess results) and exported without embedded profile (which seems to be correctable after the fact by attaching the correct profile, at least).

As I am tending to move to 32-bit HDR wide gamut images (ACEScg, BT.2020), it seems I am going to be stretching my tools to their limits (already found a few bugs to report in my photo-editor HDR feature set, but that’s another story).

Still crashing when called from Affinity Photo 2.0 as well.

Still crashing for me.

Are there any unsupported characters in the filename or file path? I’ve learn’t that can be an issue and cause unexpected results.

PAI 1.1.2 (didn’t check it with 1.1.1) introduces strange color and halo to my original NEF. The original is the 2nd blue one. The 1st shows more lila and big halo. It only happens when using PAI plugin RAW workflow (LRc) when a DNG is generated. “Edit with” and using TIF does not generate the color shift and halo.

MacBook M1 pro Ventura.


I am using a Mac mini M1 (2020) with Monterey 12.6.2. Are you also on a Mac? I tested with both Affinity Photo 2.0.0 and the Affinity Photo Beta 2.0.3.316.

is there any reason why you all still respond to my reply? i get email ongoing notifications because of this that do not count towards my reply …

My reply is marked as being for Paul_Coddington. I didn’t select to reply to you so I can’t say why you got a notification.