Topaz Photo AI v1.1.2

Oh i selected watching instead of tracking that s why. :slight_smile:

1 Like

When do you think we have RAW support for the new camera models f.i. Sony A7R5?


Photo Ai’s noise model is still far too aggressive, it simply just removes all texture detail.

Denoise AI retains all the texture detail on the cardigan whilst removing any noise.
I am hoping that Denoise Ai gets the raw image profile upgrade as it still rocks for raw images. I won’t be processing any raw images in Photo Ai anytime soon

3 Likes

I have for a long time used DxO PureRaw and PureRaw2. I tried the latest version of AI and I think the latest version of AI brings out more details than DxO is capable of. Now I am thinking of buying Photo AI and my question is (this question might be biased within this forum), are there any users of DxO PureRaw here who have switched? Attached is sample photos, original raw, DxO PureRaw and Topaz PhotoAI. The photogear is Sony A1 and Sony FE 400mm prime with 1.4 TC.



The updates are great. I would like to see the ability to run multiple copies of the software so that I can process at least 2 simultaneous batches at a time.

Would it run any faster? On my machine it uses most of the available horsepower to do a single image.

1 Like

I am using a custom (self) built machine for photo/video editing. I currently run multiple copies of the other products, including Video AI, at the same time. Intel i7-gen10, 32G, RTX 2060, all SSD. Running over night or while at work in multiple batches would be slower, but overall, more efficient.

1 Like

Tested with 160 36M NEF images from a Star Trails shoot… Worked great and processed all images without fault… Good job…

1 Like

Have you tried PL6 “DeepPRIME XD” ( XD stands for “extra detail” ) ? :thinking:
“DeepPRIME XD” retain lots more detail than the old outdated DeepPRIME in PureRAW. :partying_face:

Here is a review from Photography Life.

Not sure if this is a longstanding bug as this is the first time I’ve tried Photo AI on a HEIC file. If it’s a portrait photo, it is shown in landscape orientation, i.e. rotated 90 degrees clockwise. The thumbnail is the right way up. The exported photo is fine. I guess it’s ignoring the metadata. (photo was taken on an iPhone)

Update: Actually, on another photo, it exports in the wrong orientation (i.e. 90 degrees clockwise).

New version is working really well so far! :slight_smile:
I’ve noticed when I change the parameters, the preview is A LOT quicker (after the initial software computation which also seems quicker than before). Changes are almost instant to preview.

Thumbs up!

i personally find that the current version of Photo ai is far to aggressive with texture detail, i have posted examples. Denoise AI is far better with texture detail retention, such as clothing textures. I would not pay for the current version for this reason alone.

2 Likes

I use dxo for raw, save dng file, editing and final denoise/gygapixel in case of cropping
i use denoiseAI for TIFF/JPG, save TIFF, editing and with gygapixel in case of cropping
photoai is still in beta-like version, i use for test and waiting it is near the quality of other topaz products

Thx, I will give it a try :slight_smile:

Processing several images is now much faster with “Apply current settings to all” , it doesn’t run autopilot before saving the files and directly will apply the setting given.

If we just want to upscale this is perfect as the autopilot “denoise” could ruin a lot of images in a batch process.

I have some older images that were processed with Topaz I just wish I could tell what process was used when I review them later. Denoise? Sharpen? etc Becoming more of an issue now with Photo AI as I am going back to older images to reprocess in Photo AI and can’t tell if they were already processed in Photo AI or if another process.

What is it about version 1.1.2 that causes all these background processes to be affected?

PhotoAI_1.1.2_reboots

1 Like

Crashes for me when I go to refine the automatically selected subject area. This has not happened before. I’m calling Topaz AI as an external editor from Apple Photos.

I saw this in V1.1.1; am seeing it again in 1.1.2. A shame, because one image that it did process successfully came out very well.

As soon as I want to use a brush, TPAI crashes on my MAC . “Edit in” from LR classic 1.2