DeNoise AI v2 doesn't denoise unless I run it as administrator

Hi,

Very strange problem that I haven’t encountered before. DeNoise AI v2 doesn’t want to denoise my images unless I run the program as administrator. It opens fine but using any denoise setting doesn’t do anything. I tried both GPU and CPU. It only denoises if I run the software as administrator. I’ve never had to do this before with any version of any Topaz software. All of my other Topaz AI products work perfectly fine without running them as administrator.

One thing to try is to shut it down and reboot it again. I had a similar experience but when I tried it the second time everything worked fine and I didn’t have to sign in as Administrator the second time. It’s worth a try.

Thanks for the suggestion, but I already tried that before posting the thread with no luck. Not even reinstalling fixed this.

New user and new here.

I just up graded to a newer Mac Book and I now having almost the same problem. DeNoise does not work as an administrator or not.

Reboot did not help. I am still running V 1.3.3

Sounds like you don’t have sufficient permissions to either the image if you are updating it or to the folder you are saving the output to.

I have all permissions to both the folders the images reside in and also to the images themselves. I can access and edit them freely in any other software, including the rest of the Topaz AI apps, without running them as administrator. So I’m pretty sure that’s not the problem.

Did you install the app using an administrator user?

Yes, I did. If I don’t, it gives me an error that says that I don’t have sufficient rights to create the program folder in Program Files.

Firstly go to Help-> Graphics info, press copy and post the information here along with a screenshot of your preferences.

Please see below the information you requested plus a screenshot of preferences:

Application & Version: Topaz DeNoise AI Version 2.0.0
Operating System: Windows 10 (10.0)
Graphics Hardware: GeForce GTX 1080 Ti/PCIe/SSE2
OpenGL Driver: 3.3.0 NVIDIA 441.66
CPU RAM: 32647 MB
Video RAM: 11264 MB Total, 6144 MB In Use
Preview Limit: 8000 Pixels

0_preferences

I would raise a support request as they can login remotely to your computer and check your hardware as with that configuration you should have no issues.

Ok, thanks.

I had the same problem.
In my case the installer created the directories that should go to “%LOCALAPPDATA%\Topaz Labs LLC\Topaz Denoise AI” (i.e. inside your user’s local app data folder “C:\users\ YOUR USERNAME\AppData\Local”) in the Administrator users folder “C:\users\ Administrator\AppData\Local\Topaz Labs LLC\Topaz Denoise AI” instead.
Also some registry keys get created in the wrong place.

To fix this I had to

  1. Copy the folder “C:\users\ Administrator\AppData\Local\Topaz Labs LLC\Topaz Denoise AI” with all subdirectories and their content to my own user’s %LOCALAPPDATA% folder.

  2. Fix registry entries.
    In my case the installer created the registry keys correctly for the Administrator user but not for my normal user account. Specifically the key where the path to the folder where Denoise AI finds its resources was plain empty. I had to manually enter the correct path in the registry key HKEY_CURRENT_USER\Software\Topaz Labs LLC\Topaz DeNoise AI\appMain\tgrcFolderLocation. One thing to pay attention to when doing that ist that you need to use forward slashes instead of backslashes.
    Because a picture tells more than a thousand words I attach two screen shots where you can see the correct location for these keys and the values needed for the most important ones.

Keep in mind that modifying the registry can potentially damage your system. So always be sure to make a backup before using the registry editor (type “regedit” on the command line)!

This information comes with no warranty that it will work for you. But maybe some Topaz guys will eventually read it and hopefully will fix the installer so that it creates directories and registry keys in the right place from the start. No user should need to fix what they broke.

1 Like

Interesting. I’ll give it a go, thanks!

Success! I reinstalled it again, but this time I didn’t run the installer as administrator and for installation path I used C:\users<my user name>\AppData\Local. Now everything works perfectly without having to run the software as administrator! Thanks so much for the help, @digit42 :smiley:

Same installer problem seems to be valid both for Mac and Windows: incorrect location of resources, naturally differently on different systems.

I hope that Topaz will fix this ASAP.

As a side note: It is interesting to note that so many people are reporting this to work ok both in Mac and Windows platforms. They must be running the system with full admin privileges all the time, which is really not that good thing to do.

1 Like

I have exactly the same problem. Run windows 10, latest patch. Installed as admin and I can open Denoise but no manipulation on the image takes place… I paid 50+ bucks for a program that seems t be in a prerelease version…
Could the developer fix that so I dont have to dig into my computer and try to fix obvious things?

Also, a zoom with mouse wheel would be nice…

Hi Przemko,

Did you see my latest post about how I managed to fix this? You may try and see if it works for you too. Here it is: DeNoise AI v2 doesn't denoise unless I run it as administrator

The problem is that when I run as admin, I do not see half of my directories, nor pics in them… It sucks… So what do you suggest, just uninstall and reinstall? I must do it as admin, the installation. But then I run as a regular user (no admin privileges- to thwart viruses). I am a bit exasperated here…

Yes, you should uninstall the program and then install it again, but this time as a regular user, not as admin. Can you try this and see if it works? It worked for me.