Video Enhance v2.4.0

Download: Windows | Mac
Released August 5, 2021.

Major Features

  • Chronos v2 - Further training to fix model artifacts and to make the result more natural
  • Proteus v2 - Further training to make the result more natural
  • Model Manager - Under the “File” menu, allows you to download / delete / move your AI models, as well as view information about them
  • New trial flow - when not logged into the application, a watermark will be applied to the output
  • Beta model support - application will now display when new beta models are ready to try. Go to File -> Manage AI Models -> Preferences, and tick “Enable beta models” to get early access to our models in development
  • Model updates can now be downloaded separately from application updates

Improvements

  • Application will now tell user that a model file is being downloaded, if one is being downloaded when trying to process
  • Login flow has been improved, and now displays correct error information when login was not successful

Note that for this version, the command-line interface has been removed. We had to make the tough decision to remove it, since the number of users using it doesn’t justify maintaining it in its current form. We’ll be rewriting it soon in a way that’ll allow it to be more fully-functioning and less error prone, as well as act for a springboard for further improvements we’d like to make (plugin support, namely).

This version also does away with JSON metadata support for models. Models are now sent to the application from our server, which allows us to deploy model versions separately from the application. This has the unfortunate by-product of removing editable JSON metadata from outside of the application.

13 Likes

So we changed from MOV - ProRes 422 to ProRes 4444 XQ now? Or is it a typo?

Anyway, if it is ProRes 4444 XQ, then the description is incorrect. Just a small error, no big deal.

And I also want ask if ProRes is 8bit or 10bit? Or it depends on the source input?!
error%20mov%20422

Also, the amount of model’s versions is incorrect as well.

error

Proteus v2 AUTO doesn’t work, nothing happens when I click AUTO,
it should be adjusted manually.

1 Like

I can confirm having the same issue with Proteus v2. Spamming auto button crashed VEAI. We need a hotfix asap.

4 Likes

@HiroK and @viktorz3008 Can you both try Proteus again? I’ve pushed a change to our model metadata that should fix the issue. I’ve verified it on my side but want to make sure.

2 Likes

Awesome! Proteus has been fixed. Thank you.

1 Like

What does that mean?

It works. Thanks for your prompt fix.

1 Like

The model manager displays wrong amount of specific model’s versions. Like Artemis A&M only has v9 version, but it displays 2. Same with some models. Some are affected, some are not.

@taylor.bishop:
The new version is mostly great and please don’t be offended by what follows: You really need to fix the update system on the models - I experienced the same freezes as in the Beta; not as frequently and not with every model, but when it happened, the effected model had to be manually deinstalled and then reinstalled with the freezing happening again sometimes. It took me nearly two hours two get all the performance models I wanted.
Please fix that if you can.

Otherwise: Great work and thanks!

3 Likes

Hey Code,

No worries and thanks for the report! What do you mean by “freeze”? As in when you go to download the model from the Model Manager it doesn’t download? Or it gets to the end and the progress bar freezes?

Couldn’t that mean there is a beta version you can’t see?

I don’t know. Maybe.

Thanks for the new version. Can you fix the bug I have reported about Proteus having issues when you don’t upscale? If the video is noisy and there is a person with hair, it works for a few frames and the hair goes crazy for a few frames and then it works fine again and so on. I don’t want to upscale because I think the 100% looks just perfect on the frames that work.

It’s more like how auto color grading works. It’s more like a sample of that frame, and you have to make a few personal adjustments then.

Hello taylor.bishop,
Have I missed something in downloading and installing the Video Enhance AI v2.4.0 update? After doing this and rebooting my Mac your app opens with a turquoise icon on the UI asking I buy the app. I already own the app. Isn’t this a free update?

Moreover, it appears the before and after view is a bit slow, and some of the models available in your last iteration now appear to have gone.

Please help, I am now unable to render as your app is watermarked and doesn’t believe I own it.

Regards, Peter
Peter Solomon
Asmodeus Films
Melbourne Australia

1 Like

I don’t know on the Mac but on Windows there is a drop down menu at the top for Account and then Login. With this update I had to login with my Topaz login that I established when I purchased the software. This has happened sometimes with some updates.

Thank you MikeF I will try that.

To date I’ve tried updating / downloading from the app itself, and Topaz Labs’ web page. Both produce the same error.

Excellent, that worked. Thank you MikeF, I will remember that for next time.

1 Like

The download starts but once it gets close to the end, it freezes.

Also, I found another bug: If I load a videofile and try to navigate through it by frames, the program crashes. It happens both with Studio and Game Ready Drivers.
Please forget what I said about the video navigation - turns out the file has a small error that I didn’t notice before, all other files work great. So only the update issue remains. Apologies for the false alarm.