Topaz Video AI v3.1.9

On my side, I downloaded 1h ago and it was like previous update, slow but working.
TOPAZ Photo AI update is done WAY faster. I do have a 1.5G connection so I can say what server is slow and what other is fast and the one for Video AI is slow to medium.

Thanks for the info. I guess this sort of issue can be solved if we could manually download all the models and keep offline. Maybe that is in the future plans. I’ve never had this issue before so never thought of keeping previously downloaded models. I always deleted previous models when installing an update.

1 Like

try !!

i don’t know. depend if the V9 encoding used is compatible with AAC (something i don’t know). that’s maybe why they use vorbis. It’s something i’m not aware of.
so yes, try to switch the line and see if it work (and do a backup of the file before).

Hey there!
I’m getting a watermark on my videos. Never had that happen before.
My subscription is current, so this shouldn’t be happening.
Any suggestions on what to do?

It worked

However the PAUSE option have been requested many times before…
Here :point_right: Pause Processing - ability to pause processing and resume between app sessions
Or here :point_right: Pause/Resume processing

You can Pause when using the command line interface

1 Like

Update: Back to normal now, download speeds at my connections full speed and models are downloading and running with no more issues.

Thank you.

Hi, I’m still running version 2.6.4 and would like to know if I would see an improvement in quality or processing time by upgrading to this version.

I’m currently running a Nvidia 1650 with 8GB of ram so it takes a while to process stuff. I’d love to be able run things quicker and better but without being sure of a significant imnprovement in both quality and processing time I can’t justify the cost of renewing for another year’s worth of upgrades at this time.


1 Like

If you open the preference screen it can somehow end up with only one half of it showing and I can’t see a way to move the window or close the preferences since the right side of the preferences window is off the screen on the right.

I can’t see a way to move the main topaz screen without closing the preferences box and there’s no close icon on the preferences box since it’s off the edge of the desktop on the right.

It’s not a new problem, I’ve reported it many times, and it happens at the transition of any video.

The input source is Samsung’s demo video (4K 24fps), Apollo only 60fps. Uploaded.


Or, with GUI (and I’ve been saying this many times), you can use a tool like Process Lasso to easily suspend the ffmpeg process (to effectively create a pause). Alsso ideal for 12th and 13th gen CPU owners, so you can (consistently) bind ffmpeg to the P-Cores, and the GUI to the E-Cores, for much improved performance,

None of this detracts one iota from the fact that something as simple as a Pause button should have been present since day 1.


The flickering artifacts from noise reduction in Proteus are still present with no change. I reported that in around 3.1.7 along with dropbox upload to reproduce - let me know if missed or you need me to submit again.


I’m not upgrading at this point, because what I continue to read in this discussion forum are comments about troubleshooting the same old problems. The few positive comments I read about video quality isn’t worth the upgrade cost in my view. From what I can see, the current version simply recreates a bigger version of the same thing, which can be achieved with version 2.6.4. When the day comes that AI can accurately upscale the source video, as if it were filmed in native 4K or higher, will be the day I fork out the dough. I don’t see that day coming anytime soon for Topaz or any other company for that matter. As of right now, it’s more gimmick than technology.

  • Error message from AI engine: model failed.

  • Error message from AI engine: download failed.

1 Like

Progress is being made, here and there. Especially in the area of performance improvements. I agree with you, though, that some ‘real’ progress is warranted, like new and improved A.i. models. Most notable: better facial reconstruction. Now, whenever I mention the latter, 10 people hastily jump on you, telling you your local machine does not have the computational power to pull that off. And I agree. Doesn’t mean they can’t better train their models on their own, big machines And even if proper reconstruction is too difficult, then, at least, add sanity checks, to forego on a restoration attempt when the face is too small (as it’s so small anyway, skipping the face is far less harmful than deforming it).

Also, scene change detection is much needed. In fact, I don’t get how you can profess to do serious frame interpolation without it. Even the pubic VapourSynth community has free filters for that. And it’s built-in into tools like the x265 encoder – simply because scene change detection is something you can’t really go without.

Tl;dr: some material progress is required.


Forum look different… was making the forum look different a higher priority than neural training updates and upscaling improvements? :face_with_diagonal_mouth:


‘ Downloading model’ taking forever. Chronos Fast preview ‘unknown error’. Just what is happening here??

Agreed! And you already know my thoughts on faces, lol.

1 Like

I can’t answer your questions on 3.1.9 quality as I don’t have it but on pricing they’ve just lowered the upgrade price by 20% again, in case that affects your decision.

I thought they did that around September, iirc, once per year?