Topaz Video AI v3.0.12

Hello Everyone!

A new release of Topaz Video AI is now available.

v3.0.12
Released January 10th, 2023.

Download: Windows, Mac.

Changes from v3.0.11:

  • Fixes crashing at 99%
  • Fixes auth issues for users who run the installer using a different user than used for running TVAI
  • Fixes output resolution not showing correctly when some non-square pixel videos are converted to square pixel
  • Preset name is limited to max 20 characters
  • Misc. bug fixes and improvements

Known Issues

  • If you are logged in and receiving a watermark on Windows, try deleting the %PROGRAMDATA%\Topaz Labs LLC\Topaz Video AI\models\auth.tpz file while the app is closed.
  • If all models fail, please try deleting the .tz files in your model folder. The location of this folder may be found in the preferences menu.

Submit files here: Dropbox


Please take a look at the Video Roadmap Update for more context on what we’re focusing on right now. Thanks in advance for your feedback!

5 Likes

No changes with this problem:

Here is a part to test on:

1 Like

Even with the 3.0.12 update, I can not install the Video AI on my Windows 10.

The error message: "The installer has insufficient privileges to access this directory: C:\ProgramData \Topaz Labs LLC \Topaz Video AI. The installation cannot continue. Log on as administrator or contact your system administrator. "

I’m running the installer as Admin, there is enough space and all other Topaz tools can be installed and have been running for several months… (Just re-installed 2.6.4 without problems)

I tried to install to another folder, but it always mentions the same error with this default path, not using the new drive/folder! Seems the directory for the models is hard-coded and cause some problems writing.

I even created a new Admin account, but it does not work as well…

Hi,

Can you please try removing any currently installed version, and then deleting the folder mentioned in the error message (it may be hidden) before installing 3.0.12.

If you still have issues afterwards, please contact our support team.

2 Likes

@ salva00786

Hi… I’m experimenting a little with the software in prompt command, but on a one file, this error appear:

no ICC profile found, will write nclx/nclc colour info instead.

This is a file I processed with ALQ-8.

The upscaling start, but I don’t know if this alert can create problems on the final upscaling or not, and if I want to correct this, what can I do?

ALQ8 is the model I have used most extensively as it still produces better upscale results in a lot of cases over the current models - but its last version it works properly in is 2.3, which incidentally is one of the reasons I still tend to use 2.3 for the bulk of my work.

There was a change in the way model loading worked in 2.4 which made it basically impossible to import into additional versions, and whether by technically limitation or choice (I am not sure which) they have not included it in the newer model loaders since.

There is something odd with that source file, assuming the source file is original. It is not like any standard interlaced format I have seen. There is no temporal information between the fields and the fields are duplicated, meaning that the vehicle moves forward every pair of fields in one motion like its progressive.

I don’t know if that will make sense to you, but essentially you could throw away half the frames and not lose any information. Is that mkv file actually from the source or has it had processing done to it? It looks like something has done something to it, or at the very least is not a normal interlaced file.

I didn’t do my full bundle of tests, but I’m pretty confident that Theia is still mostly broken.

Proteus, Artemis, Gaia, Theia, all AI models process again. Performance is same as 3.0.11.

Compared to 3.1.0.0.b Gaia is less performing (0.54spf, was 0.27 spf) while GPU load is @ 70%, was 99%.

(upscaling 1280x720 50fps to 4k on AMD Ryzen 7 5800X with RTX 3600)

7900 xtx user here, still no av1 support for encoding.

Yeah, that is progressive video that just has an interlaced flag set (originally from a dvd probably).

Yes its just a cut from dvd using staxrip. For cartoons its often so that one frame is duplicated for scenes. There are scenes in this anime where each field supposed to be separate frame (not pull up). That’s why Dione 2x needed and not Robust.
Anyway Dione should not make such artifact lines. Even if progressive source is given.

Here is an example from scene that is seen as interlaced:
armitage interlace
And in this scene each frame is different (camera moving).

1 Like

Oh, the irony.
Topaz1Percent

5 Likes

I have the same problem and went back to the previous version which does not crash.

2 Likes

Duplication in cartoons is generally because a lot of animated content has variable frame rates - most typically slow - meaning trying to squash it into a a set framerate often means having to add missing frames to extend it. Its also why VFR content is a pain the butt to make properly progressive.

Its also one of the causes of Topaz Interlaced models not working properly, because these models don’t handle it well - and they probably won’t ever.

Having said that, just from the clip you gave, its not obvious if the clip contains different framerates as it appears to be hard telecined (or similar) with a very rough interlacing. I see no way that this clip could be imported into Topaz and have the output be good without attempting to correct the input source first.

There is vertical judder being caused by bad field matching, and - at least from the clip you gave - given there is no visible interlacing in the fields, you are probably better off deinterlacing outside of Topaz first.

As an example, this is your clip, processed to remove as much of that crappy interlacing and vertical judder as I can without spending a lot of time on it (and the entire file in case there is issues) with a general upscale and IVTC to 23.976. It is not perfect, I didn’t spend a lot of time on it and I certainly didn’t run model comparisons - it is more as an example.

3 Likes

Hello Nipun.

AI v3.0.12 all correct. I left it overnight processing.

It works a bit faster than v3.0.11.

It has problems with the audio when the sound is not heard in windows 11.

The final interlace quality is not bad but it can be improved by 10%.

.This statement can be demonstrated in practice by expanding with Adobe Sensei.el 2x.

Thank you very much for the prompt reaction to the mismatches of version v3.1

Saludos

1 Like

It didn’t get to 99% so it’s fine. Har har.
All kidding aside, hopefully they can get all those UI crashes fixed.

Reminds me of the REDDIT group “Tecnically the Truth”.

1 Like

What are you using as a GPU?

Not sure if I’m missing anything obvious, but is it normal to have infinitely-loading (stuck) previews / comparison while processing a video? I swear you used to be able to watch an in-progress upscale, either frame by frame (2.6.4) or every X seconds lol.

Using a 3070Ti, NV 522.25 drivers, 3.0.12 Topaz (used beta v3 and 3.0.2, might have worked then).
Doing a x264 1080p vid to 1080P Proteus manual + H265 NVenc 10bit encode (MP4 format).

Otherwise, speed is the same, things seem to be running fine, getting improved quality in the 3D rendering upscale/ re-encode.