Topaz Video AI v3.0.11

I see the colour-shift-problem is back…

I’m certain that no matter what GPU you’re using, a big piece of TVAI runs on the CPU. It uses various components of the GPUs to perform some of the AI work and the actual rendering. (Whether it does some or all of this in the GPU depends on its capabilities.)

That is probably due to how much the application needs to make use of it. - Remember that TVAI 3.x was rewritten from the ground up and the application may use system resources differently.

I’d like to see the data to back that statement up. I upgraded from an Intel 6700K to an AMD 7950x and saw maybe a 5% difference. If the GPU is old (I have a RTX 1070) the CPU basically doesn’t matter.

Much faster than what? They aren’t comparing any generational Intel CPUs to each other. I would bet that a 10th gen and 13th gen Intel would be within 5% or less of each other.

Also, it depends on what model is being used. Some use the CPU more than others.

Yeah I noticed that too. There was a benchmark I saw a while ago that looked at PCIe generation differences in gaming then in production workloads. Gaming, there was no difference, but in production work, gen 4 was faster than gen 3. I couldn’t find it again when I wanted to refer to it later though.
Because of that, I suspect going from a CPU that has a lower PCIe generation to a higher one will gain you some speed in TVAI.

My upgrade from 6700K to 7950x was a complete disappointment - almost no noticeable difference, but my GPU is old so I guess you only get the improvements if you have a good GPU too.

Hello, first post here.

I am working on a studio project for a Blu-ray release. 3.0.11 is completely broken on my system. I am doing this all in rounds per each shot. So, I am trying to stabilize and it gives me an image of grids. I was able to get one shot done in 3.0.10 before upgrading it.

Because it did this fine in 3.0.10:

Tech support in the email told me to set it from “Full Frame” to “Auto Crop”. Auto Crop just makes the program do nothing. It says it’s done in 7 minutes or so and there’s nothing in the output folders.

So, I tried “Full Frame” again and I got this:

I had even went back to a previous video I did on a movie I shot and I even posted the output on Youtube. That same clip gives me the same grids. So, how did it work on 3.0.5 and I am able to post a clip of the output on YT, but, 3.0.11, it’s not working either?

This is very frustrating as I have now wasted two days and nothing is working.

Actually, the GPU doesn’t run application code. The CPU does that. The TVAI application runs as an application written in program code appropriate for that machine’s OS, (Windows or Mac,)

If TVAI needs to use the use the GPU for any kind of processing, it does so by using the drivers appropriate for that device. Bottom line: The GPU doesn’t do all the work. TVAI uses the CPU for the application itself. It uses the capabilities of the GPU for creating images and leverages any additional capabilities the GPU may provide, such as augmenting AI and decoding/encoding video.

They still have a few bugs in this beta. After reading some of the other comments in this thread, I’m surprised you got as far as you did.

I’m still playing catch-up after all the original TVAI 3.x betas.

Yes but it does most of the compute intensive work, on most models.

A lot of that depends on the GPU’s capabilities. If not, the application does it the ‘hard’ way using the CPU and its math coprocessor. - Depending on what operations you’re doing, they will do the job. -But it’s sort of like watching grass grow. :nerd_face:

Or, if slower than that: maybe not in your life time. :thinking:

And again about Dion 2x models and Armitage source:
Original frame:


As you can see bottom field (right one) is just sharpened and top field is different (artifact lines appears near steps).
So looks like top field is reconstructed by network. But it’s done wrong.

And strange thing is that next frame in output is same.
Top field with artifacts and bottom is just sharpened.

As I understand Dione should take original frame and in output make 2:

  1. Top field from original and bottom reconstructed.
  2. Bottom field from original and top field reconstructed.

But it is not so.
And my opinion is that Deinterlace networks should not denoise/sharpen/enlarge. Just deinterlace.
And we need ability to chain its processing with enlargement networks like artemis.


Hi… I’m experimenting a little with the software in prompt command, but on a one file, this error appear:

no ICC profile found, will write nclx/nclc colour info instead.

This is a file I processed with ALQ-8.

The upscaling start, but I don’t know if this alert can create problems on the final upscaling or not, and if I want to correct this, what can I do?

I and many others have had this problem where TVAI outputs variations on that grid pattern. Yes, very frustrating, as it won’t occur during Preview but will occur in the Export. Sometimes, I’ve seen it occur only in portions of an Export, where it will morph from a viewable video into a grid pattern for awhile, then return back to a viewable video. It’s made some video sources totally non processable in TVAI.

The documentation only mentions going back to ALQ-10. Maybe ALQ-8 is not possible?

I have been away from my video editing system for a while. After reading several or the reviews in this thread, I think I’ll pass on installing TVAI v3.0.11 until they fix a few problems. And that goes for the new v3.1.0.b beta, as well.

I can not install the Video AI 3.0.11 on my Windows 10. The error message: "The installer has insufficient privileges to access this directory: C:\ProgramData \Topaz Labs LLC \Topaz Video AI. The installation cannot continue. Log on as administrator or contact your system administrator. "

I’m the Admin, there is enough space and all other Topaz tools can be installed and have been running for several months…

I tried to install to another folder, but it always mentions the same error with this default path!

I even created a new Admin account, but it does not work to get Video AI installed…

Right click installer, run as admin?

A newer version is available.