Topaz Photo AI v1.2.4


This week sees the introduction a non-AI basic brush for masking which has been one of our most requested features since release! We’ve also updated libraw to use Adobe’s DNG SDK which allows us to start supporting true monochrome and HDR DNG files. There are currently issues re-saving these types as DNGs, but we look forward to better supporting DNGs in general in the future.

Of course there are several more changes and fixes which can be found in the change log below.

Please give us any feedback or report issues with this release. We’ll be updating TPAI regularly to address those pieces of feedback and issue reports. If there’s a specific image you’d like us to see, you can send it us at this dropbox link.

Released March 2, 2023
Mac: Download
Windows: Download

Changes since 1.2.3:

  • Added basic masking brush
    – Switch between AI brush and the basic brush while in refine mode with the “b” hotkey, or use the toggle on the right panel
  • Added opacity slider to mask overlay color selection
  • Added support for more DNG types (HDR, Monochrome)
  • Fixed scroll bar on right panel being too large in certain cases
  • Navigator will no longer hide the old mask when generating an updated mask
  • Fixed crop being able to go out of bounds when unlocked
  • Fixed issue where dragging crop boundaries against an edge quickly would extend opposite side’s bounds
  • JPEG quality value will reset to 95 on next save if left under 30
  • Windows installer should now handle symlink errors
  • Minor UI tweaks
    – Sliders can now be incremented with arrow keys when the text field is selected
    – Added app icon to the title bar area
    – Made icon smaller on activation screen
    – Added feedback button to title bar when no updates available
    – Added more links under the Help menu

Known issues:

  • HDR or Monochrome DNGs which previously did not open may have issues when saving as a DNG
    – To get around this you can save as JPEG, PNG, or TIFF which shouldn’t have the same color issues

I don’t even read the change log before I click like :heart:

Love the new masking brush - thank you! I will be eagerly waiting for Denoise and Sharpen new models.


Thank you so much for the masking brush add. Works great.

1 Like

Hi, using the masking brush I find I can only increase the brush size using the “]” but the “[” bracket for decreasing the brush size doesn’t work, in fact it isn’t even activated.


NOTE: Both Increase and Decrease brackets will work on the AI brush but it still shows the “[” as disabled.

Uploaded _F9I0752.CR3 because of the colors i get in Capture One.

With Denoise AI they fit, with PHAI 1.2.4 they are off.

2023-03-03-10-28-35.txt (530.9 KB)


Denoise AI


PHAI - Denoise

1 Like

I tried the new masking brush and initially it worked ok, adding and subtracting from the mask. As soon as I moved the subject the mask brush just stopped doing anything. I could use other functions in PhotoAI but the brush could not be used. I closed and reopened and it did the same, initially working and then not. Any advice please.

Might be a stupid question but where is the JPEG quality setting?

Kind Regards

1 Like

Hi Jason, you should see it when you click on the save button.

Thanks for another update. Still unresolved is the lost of the GPS coordinates (from LRC to TPAI), not there with the other pieces such as Sharpen AI. I do a lot of birds & animal, TPAI is doing a great job of Noise cleaning but 99% the sharpen is not active, when it does, it hits the top (eg over 50%). I am missing the too soft - normal of Sharpen AI or the STD (doing a great job in the bird eyes) , in birding no extreme sharpening is acceptable. So I must reduce to 10-10 the sharpening and clarity.

1 Like

Hi Don - You’re probably running into this because you have the AI Brush set to Tiny before switching to the basic brush. Same happens if the AI Brush is set to Large; the Increase shortcut will get deactivated. We’ll work on addressing this for next week. For now, you can either set the AI Brush to Small or Medium before changing to the basic brush, or use the sliders to adjust the basic brush size.


Thanks for sending the image! Looking into it.

Hi Steve - this isn’t reproducible on our end and hasn’t been reported by other users so far. Could you reinstall the software using the installer link on the top of this thread? If the issue continues, please let me know what hardware you’re on. You can also feel free to send me a recording and the log file from the same timestamp of a failure session from Help > Open Log Folder. You can send it here or send it to me privately. Thank you!

Yes I can use the sliders.

1 Like

Why does the process stop at the nose in the attached image?

Version 1.2.4 I’ve noticed this issue on all previous versions as well.

Using 50 megapixel images.

Hi Christian - there are some images where Face Recovery isn’t improving the entire face and that is something we’re investigating. Can you please send me the image through Dropbox?

Hi - are you referring to the Face Recovery issue? If you could also send me an image or some of the images through Dropbox, it’d be very much appreciated.

Thanks very much.