Topaz Photo AI v1.1.8

Hello!

This week brings a new subject masking model update and various crop changes. The new subject masking model should improve detection of subjects in various wildlife and portrait images. As for cropping, aspect ratio locking and flipping is now added. You can flip the aspect ratio with the x key, and you can use the lock icon to switch between unlocked custom aspect ratios and locked ratios.


Please give us any feedback or report issues with this release. We’ll be updating TPAI regularly to address those pieces of feedback and issue reports. If there’s a specific image you’d like us to see, you can send it us at this dropbox link.


v1.1.8
Released January 19, 2023
Mac: Download
Windows: Download

Changes since 1.1.7:

  • Updated subject mask model for improved wildlife and portrait masks from Autopilot
  • Updated styling around Enhance controls
  • Updated crop rectangle sides to be easier to click on
  • Updated crop rectangle drag threshold for more precise dragging
  • Added ability to type in aspect ratio when cropping
  • Added ability to flip aspect ratio when cropping
    – Hotkey x, or click the double arrow button between the W and H aspect ratio textboxes
  • Added ability to lock and unlock custom aspect ratios
  • Fixed crash when XMP crop data was already present
  • Fixed processing stopping on certain images in batch mode
  • Fixed various issues where state would be stuck Scanning or Idle when using crop
  • Fixed pressing tab instead of enter when setting scale not highlighting scale buttons

In case you didn’t see it last week, we have a new quarterly roadmap available! It’s a great place to voice your feedback not directly related to this specific update:

8 Likes

Can you please make an option to denoise only the subject (as it is with sharpening).
It would be very very useful. Thanks in advance.

1 Like

I just installed 1.1.8 on my M1 Mac Mini 16gb. I downloaded the install file from the link above. I already had 1.1.7 installed. My first photo I processed in 1.1.8 failed with an error at the bottom that said: Could not open model. First time to see that error from any version of Photo AI going back months.

Bug reported and log file sent to Topaz.

Installed from update within windows program, no issues.

Thought I would try a sketch I did years ago to see if it would do face detection.

It also worked well on this image

3 Likes

I got an automated reply from Topaz that said they are closed on 1/20. I suppose the earliest I may get a reply then would be Monday 1/23. Anyone have any ideas? I cannot use 1.1.8.

Hi Henry - could you send me a screenshot of the error and your log files, please? You can find the logs in Help > Open Log Folder. Thank you.

1 Like

Hi Yazi: I already sent a support request a few hours ago and I included the log file.

A few minutes ago I deleted 1.1.8 and then using the same 1.1.8 install file I downloaded earlier today I installed it again. Now the standalone is working. Both installs were reported to be successful though.

Ever since I installed Photo AI for the first time a couple of months ago I had merely downloaded the weekly update install file and run it. I have never deleted the previous version of Photo AI first though. I never had any problems, but maybe this is not the right way to do it? Should I uninstall each week before installing a new version?

I have an observation about Photo AI, and it’s not a new thing with this version. Recover Faces usually wants to give blue-eyed people brown eyes. On some portraits, it’s bad enough that I have to turn off Recover Faces because of it. That’s a shame, because it generally does a good job of adding more detail to faces than enhancing resolution on its own. Couldn’t it sample the eye color and use that, instead of assuming that all eyes are brown?

Win 11 Pro, desktop PC. Processor = Auto (AMD RX6800 XT, Intel i9 12th gen). Standalone version only (b/c wanted to see what was what w/added Cropping features).

Opened a .CR2 (Canon raw) image from Joshua Tree into the Standalone. Didn’t make any settings changes. Orig (BEFORE) & A.P. (AFTER a.p. preview processing) in Split Screen view snips follow:

Before -

After A.P. (preview) -

Then tried the new Cropping features. My experiences: (there may be some “issues” to sort out by the devs - unless my experience was unique):

  • I could initially use the “X” key to swap orientation of the Crop frame from its initial framing.
  • I then changed the Crop choice from it’s original aspect ratio to a 5 : 7. The Crop frame changed size to reflect my choice. I may have hit “X” again to flip that crop framing.
  • I started to pull the crop frame handles in from the edges to crop tighter with that ratio… Changed my mind (ie, decided to stress test the tool…). Switched to “Custom” to move the sides freely to my taste. PAI crop would not let me do that. It remained locked into 5 : 7. No cropping experimentation (ie, diff. crop ratios on the fly) seemed to be supported.
  • I hit the “Reset” button. Crop frame returned out to outer perimeter of my test image.
  • I then tried to use “Custom” to do a freeform crop. PAI crop would not let me do that. It took me back to the prior, aborted, supposedly Reset & abandoned 5 : 7. PAI crop would not let me do a Custom crop after having chosen 5 : 7 (then hitting Reset or not). I tried several runs at it using diff. approaches …
1 Like

Same PC specs as immediately above.

This time working with Ps 2023 Plugin (to ensure it launched, processed, returned processed image to Ps layer stack).

Am seeing the same thing as prior releases. When Sharpening is used in PAI (plugin) I see a significantly more noticeable ‘hop’ (aka, pixel shift) after the image is processed and returned to the Ps layer stack (and I turn off/on the layer Eye icon).

Also, PAI Plugin introduced all sorts of artifacts into the image (it’s as if it copied all the cross-hatched windows in this Miami (FL) apt building and shifted them all over so they were overlaid and repeated into the blank spaces on the glass, balcony slider doors throughout the image - click on the AFTER PAI & BEFORE to see what PAI intro’d… it also seemed to wash out the vibrant greens in the image (probably b/c it overlaid all those wht cross-hatches).

Before:

After:

Using the native RAW application vs importing a TIFF is changing the exposure. This is limiting in the workflow. When I take the DNG back into LR, using camera settings, it has Sharpen set to 40, thus apply more sharpen. At least the DNG file let’s me use camera settings

Order of each image - TPAI -Tiff from LR; Original NEF; TPAI processing RAW

Hi Henry - thanks for letting me know. You don’t need to uninstall the old version before updating to the new one. If you were on a fairly old version, it may haven’t had some update improvements we added to later versions. Please reach back out if you run into this again and we can dig around it further. Thank you!

Hi! Can you please send me an image or some of the images where you run into this? We constantly work on model improvements and having more samples of such issues would be of great help. Please let me know if you’ve sent the files through Dropbox. Thank you.

Hi Michael - what’s your Nikon camera model? Can you send me the images through Dropbox? We can look into this when we improve our camera support in the next cycle which we do fairly often. Thank you.

Z5 lossless compressed files. Will upload these files.

I will upload a Z9 batch as well. There are color shifts there; not so much exposure shifts.

I’d love to see an option in the preferences for automatic removal of photos after processing. It is a bit tedious in the workflow to close the pop-up, close all images, and then confirm.

Thanks for your consideration!

When you have custom selected, there’s a button to lock the aspect ratio so that you can resize while maintaining the custom aspect ratio you wanted. If you un-lock it, you should be able to change the crop rectangle free-form.

1 Like

There is an issue with the genrated DNG files. They can not be read by Lightroom or Photoshop. They indicate corrupt DNG file. Tiff files are ok. Photo AI can however itself read back and open the same DNG file .

Same problem with Photo AI 1.1.7 but it was fine in earlier versions.
I have fully updated Windows 10 Pro and Photoshop/Lightroom

When I generate a DNG file from the latest Gigapixel AI 6.3.2 that is working ok.

I’ll check that out today, Anthony.

I might have missed the “?” Tip that said to do that. I’m not exactly grasping what’s needed (but I just woke up & ‘tropical’ CA is freezing…so I’ll get a coffee, do my Covid era home workout circuit then try again when mentally functional). Thx!

Are we not allowed to change direction mid-stream, if we don’t like how a chosen crop is working out & want to try another option instead?