Topaz Photo AI v1.0.3-v1.0.4

Hello everyone!

This week’s update adds more control over the various filters, as well as a ton of bug fixes and performance improvements! There’s also new support for a command line interface, which can be used to process images without ever opening the application window - perfect for automation!

If you own DeNoise, Sharpen, and Gigapixel with up-to-date licenses then you already have access to Topaz Photo AI!

Please give us any feedback or report issues with this release. We’ll be updating TPAI regularly to address those pieces of feedback and issue reports. If there’s a specific image you’d like us to see, you can send it us at this dropbox link.


v1.0.4
Released October 7, 2022
Mac: Download
Windows: Download

Changes since 1.0.3:

  • Fixed a crash when working with RAW files whose lens correction was smaller than the original image size
  • Fixed black borders on RAW files whose lens correction was smaller than the original image size
  • Fixed CLI output on Windows being hidden due to it running as a GUI application
  • Fixed closing an image making it so it cannot be re-imported until restarting the app
  • Fixed issue with AI engine where an invalid minimum Mac OS version was listed
  • Fixed some issues when switching images when in refine mode

Known Issues:

  • Lens correction may still cause crashes when zooming in on certain images. As a workaround, disable lens correction from the preferences menu item.

v1.0.3
Released October 6, 2022
Mac: Download
Windows: Download

Changes since 1.0.2:

  • Added new model to Sharpen filter that better handles low amounts of blur without over-sharpening
  • Added sliders for more parameters on some filters
  • Added command line interface
    • There’s a lot to this one, but if you run the executable with --help you can see the different options it takes
  • Re-designed seats dialog
  • Re-designed updates available dialog
  • Improved performance and stability on some hardware
  • Improved accuracy of luma noise detection
  • Fixed rare crash when checking authentication
  • Fixed file paths not loading with certain characters
  • Fixed AP Preferences dialog not expanding properly
  • Fixed crash caused by lens correction
  • Fixed black border in corners when zoomed in with lens correction enabled
  • Fixed preview not stop processing when opening a refine mode
  • Fixed crashes when opening or exporting large amounts of images
  • Fixed certain cropping metadata on ORF photos not being handled
  • Fixed some visual artifacts with Face Refinement in certain circumstances
  • Fixed subject mask sometimes showing the mask of a previous image after switching
  • Fixed switching images while in a refine mode saving the changes rather than cancelling
  • Fixed horizontal lines visual artifact on some images
  • Potentially fixed crash on open on Mac

Known Issues

  • Face refinement may have visual artifacts when lens correction is enabled
  • Users behind some firewall products may need to allow “Multi-compressed ZIP/GZIP files” to be downloaded

We still have a lot more planned! Here’s the problem areas we’ve heard your feedback on and are actively working on improving:

  • Subject refinement is not precise enough
11 Likes

Unless you’re from the future i think you mean Released October 6, 2022

3 Likes

Lots of improvements, thanks! :+1:

Still missing :sob: but badly needed in autopilot configuration:

  • setting to choose what type of enhancement filter is applied when auto-upscaling is enabled: natural, graphics, low resolution, none or ‘auto’

  • a section for control over noise removal: normal, strong, none, or ‘auto’

  • allow custom scale factors other than the preset values of 2x 4x etc.

Once those AP options are there, it will be logical and useful to re-enable batch processing since we will finally be able to do what we want.

And lastly, not related to AP configuration, we need a manual subject masking brush/tool!

Thanks

6 Likes

Thanks for the update!

Unfortunately, I’m still unable to simply upscale an image without any other processing going on :frowning_face:.

The Enhance Resolution function does the opposite and blurs the image instead.

Try using graphics instead of natural, is that any better? Also, if they listen to what I have been saying for a while now, we should have control over this in the AP configuration. See my post above ↑

1 Like

Win 11. Processor = Auto (AMD RX6800 XT, Intel i9 12th gen). Installed over .2 rel.

  • Launched Standalone 1st. Launched w/no issues using Sony ARW raw image.

  • Ran AutoPilot. Test image (see street photo scene image below - no faces) retained photographic-quality with the AP processing. There are lots of small textural details in the image. Details did not get overly-smoothed, halo-d or converted to odd wavy shapes. Retained a photographic quality. Both zoomed in in the UI & pulled back to normal view. :+1:t3:

  • Because of the Changelog mention of new sliders I tried moving all the sliders under Denoise & Sharpen in different ways & combos to experiment & see how impacted the A.P. only result. With subtle slides, nothing went radically off - which is an improvement (at least for this image) from prior experiences. Very positive!

  • Also tried the Ps 2022 Plugin (I’m assuming there’ll be a Ps 2023 in the next wk or so from Adobe MAX…I usually wait until others with mult. test computers find the bugs - I don’t ever install immed.). Plugin launched with no issues. Functioned like the standalone. Able to save back to Ps layer. I used slightly different settings. But PAI still retained photo quality. Saved back to Ps layer okay - I reduced Opacity 5% as a tweak. To see what impact that might have.

ORIG. ARW in PAI 1.0.3 Standalone:

A.P. Look Only (Standalone):

1 Like

con’t… Using Standalone.

Just tried an ORF (Olympus) raw and DNG (created from ORF raw using Adobe dng Converter). Both opened and were processed by PAI A.P.

Picked a night photo for one test. AP did fine with that. Removed the color noise w/out over-smoothing.

In the DNG, AP selected the mural & center tree as Subject. I’m finding that - more often than not - I must turn off Sharpen Subject Only due to the positioning and coverage of the subject overlay.

NOTE: One odd UI bhvr - possibly needing a fix… I got in the habit of doing a CTRL + W to close images b/c there was no Close Image button or File menu option. With rel. 1.0.3 even when I do that, I see the supposedly closed image appear again when I launch a new image. I then tried a “Close All” but the same thing happened. When I did either of those closing procedures nothing appeared in the workspace of the UI. The previously closed image only flashed up there when I opened the next image.

DNG from ORF (using AP settings but Sharpen Subj Only Turned Off): Mural & center tree detected as Subj for kicks I activated Face Detect - it didn’t think the mural portrait was a face.

ORF Original:

After AP Processing: (No Subj Detected - night scene color noise removed)

I’ve tried all 3 and they don’t change the outcome at all. It always ends up blurry as soon as I upscale the image. I really hope they can go this one last step to give us the option to turn Enhance Resolution OFF.

Calling from Affinity Photo and V1.0.3 AutoPilot was extremely faster that previous releases. Like the additional sliders under Remove Noise and Sharpen. I do think they give a bit finer control.

The install procedure was faster for me and I was glad to see the preferences I set in the previous version were carried over to this version.

Using Mac mini M1 (2020) 16GB and 1TB, Monterey 12.6

1 Like

“Topaz Photo AI” --help

does nothing in a command line prompt

2 Likes

Seems odd, if you post a link to the original I can try it for you and see if I get different results

Experimenting with 4x enlargement, otherwise Auto Pilot. This is a screenshot from Instagram of one of the photos I posted there. Very nice cleanup! Gigapixel was always my favorite Topaz app, glad to see the legacy continues in Photo AI.

2 Likes

Checked 1.03

Win 11 32GB GPU RTX3060

When processing a RAW file I cannot save any result . Program exit without saving any file (checked tif and jpg)
While processing a TIF looks to save OK
I send my RAW file to Dropbox

Very similar results here. Tried processing 3 different jpgs. Processes nicely but will not save file to either tiff or jpeg. Get error message ‘cannot save file’ then program silent crashes. An unusable file is created. Autopilot changes only. Other settings in export: No prefix; Suffix is PhotoAI1.0.3; Location: Original Folder; Format either TIFF with no Compression; Bit Depth 16-bit. With JPEG I set quality to 100. Setting output to ‘preserve original format’ also led to silent crash. I tried a tif file to save as a tiff file and got message ‘cannot open output file’ but the program did not silent crash. I was able to press cancel process and go back into the program. Worked fine in v1.0.2.

Win 11. Standalone.

Tried this rel. earlier. Closed out PAI for several hours.

Tried new images. Still getting same odd bhvr noted in test earlier.

When I close an image I’ve worked on (either using Close Image, Close All Images or CTRL + W) so that no image appears in the UI workspace then I open another (diff.) image, the image I’d just closed before opening the new image flashes up before the new image opens.

BTW, I’ve been using raw images to test so far - a mix of ARW and ORF and raws from those sources converted to dng using Adobe dng Converter.

It’s happening every time in the Standalone. It isn’t a one off experience.

TPAI 1.0.3 may have problems creating output files after having optimized large TIF:s. I repeatedly get “Error creating output file” independent of to which file format I save. Saving to original location, lots of space, lots of memory, fast computer.

V1.03 is crashing randomly on me when processing a stack of images using autopilot. This happens when using folders on local SSD or on remote NAS drives. GPU is an Nvidia RTX 2080

OS Name Microsoft Windows 11 Pro
Version 10.0.22621 Build 22621
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Name DVH-DESKTOP
System Manufacturer Gigabyte Technology Co., Ltd.
System Model Z390 AORUS XTREME WATERFORCE
System Type x64-based PC
System SKU Default string
Processor Intel(R) Core™ i9-9900KF CPU @ 3.60GHz, 3600 Mhz, 8 Core(s), 16 Logical Processor(s)
BIOS Version/Date American Megatrends Inc. F7b, 12/18/2019
SMBIOS Version 3.1
Embedded Controller Version 255.255
BIOS Mode UEFI
BaseBoard Manufacturer Gigabyte Technology Co., Ltd.
BaseBoard Product Z390 AORUS XTREME WATERFORCE-CF
BaseBoard Version Default string
Platform Role Desktop
Secure Boot State Off
PCR7 Configuration Elevation Required to View
Windows Directory C:\WINDOWS
System Directory C:\WINDOWS\system32
Boot Device \Device\HarddiskVolume3
Locale United States
Hardware Abstraction Layer Version = 10.0.22621.1
Time Zone Mountain Daylight Time
Installed Physical Memory (RAM) 64.0 GB
Total Physical Memory 63.9 GB
Available Physical Memory 51.7 GB
Total Virtual Memory 121 GB
Available Virtual Memory 98.6 GB
Page File Space 56.6 GB
Page File C:\pagefile.sys
Kernel DMA Protection Off
Virtualization-based security Not enabled
Windows Defender Application Control policy Enforced
Windows Defender Application Control user mode policy Off
Device Encryption Support Elevation Required to View
Hyper-V - VM Monitor Mode Extensions Yes
Hyper-V - Second Level Address Translation Extensions Yes
Hyper-V - Virtualization Enabled in Firmware Yes
Hyper-V - Data Execution Protection Yes
1 Like

I too am having this problem. Win 10, i7 7th gen, Nvidia 1080, 64 GB ram.

I load up about 200 .nef files and let it go to work, it gets through about 30 or 40 files before it closes without warning. I have plenty of disk space.

I can simply open the program again, drag and drop the files where it left off, and it will start again, so it’s not dying on a bad file.

Would be nice if it would give off some kind of death rattle, any type of error to indicate what’s happening.

Also I noticed a bug where if I load some files up via drag and drop, then tell it to remove them all, I cannot just drag and drop the files into Photo AI again. I can manually tell P AI to open them by navigating to the folder through the interface, and that worked fine. But no more drag-and-drop until I closed and opened the program again.

1 Like

There is an ascii text log file, I’m running it again right now to hopefully catch something useful. It seemed to not like my display calibration last time, which completely confuses me… I use the Calibrite system, which should be pretty normal as such things go.

Something is wrong with the new Standard sharpening option. When it’s enabled in combination with Face Recovery, the backgrounds - along with the edges of some faces - get offset diagonally. This doesn’t happen with Lens Blur sharpening. The effect occurs on the display and in the exported results. Compare these examples to see the offset. (I’m working with JPGs in standalone mode.)


1 Like