PhotoAI adds faint grid pattern on exported images

I’m not seeing it in all of the images, but from some I spot it very easily. It’s much more recognizable on the actual image than these as attaching the image here seems to downgrade it a bit.

Topaz Photo AI [v1.2.8] on [Windows]

I think the issue is same as in here:

I am also getting this faint grid with latest update when using export as raw via the plug-in option.

This looks like an artifact that is appearing due to either Raw Remove Noise or Enhance Resolution. The grid pattern is especially significant if the two filters are used together.

We will be working on updating the models to prevent this artifact.

@waltteri.reunamo @mountainbikers-78738
Please upload the files to my Dropbox so I can try to reproduce this issue which should make it easier to fix. Please be sure to send me a note to let me know you sent something.
Dropbox File Request

1 Like

I uploaded the images to your dropbox.

Ditto. Interestingly, the first mention of this grid artefact issues that pops up on a Google search shows it being raised back in 2018! Have Topaz had enough time to fix it yet?

1 Like

I tested the images you uploaded and was able to see a very faint grid.

I shared this with my team so we can look into a fix. I do not have a workaround for this at the moment, although I noticed it happens particularly in backgrounds with a consistent color or very little change in color.


Hi, I have the most recent version (1.3.3) and you can see the grid on images in areas where there is no information so to speak. I have a photo of the moon where even in the preview the areas of the black sky are showing the grid. I can provide the RAW file and an export if needed.

Still seeing this in version 1.3.4. I have a photo where I brought in the Canon CR3 raw file into Photo AI. In Photo AI, noise reduction, sharpening, enhance, cropping and upscaling were all used. The grid pattern is quite prominent against a clear, blue sky. I did not see this happen in photos that I did not crop or upscale in Photo AI. Until this is fixed, if those features are needed, and you have them, use the older stand-alone tools.

Happy to provide the raw file and JPG output from Photo AI.

I have a deep learning researcher who is working on this grid issue right now. The AI models take time to fix but we are aiming to have this solved by the end of the quarter.

For now, a workaround would be to convert the RAW file to a non-RAW and process the non-RAW file as the non-RAW processing does not create the grid pattern.

I’m having the same problem, i.e. a grid appearing in the black background of a studio photo, using Topaz Photo AI. Contrary to what I may have read in the thread, this is not a Raw file (someone from the Topaz team said that this only happens for Raw files), but rather of a Tiff file. I regret that due to this bug I cannot correctly process my photos with Topaz Photo AI when I use remove noise and/or sharpen. I very much hope that the team finds an effective way to correct this problem. Unfortunately, until then, I will have to stop using this software.

Hello @Lingyu -

What is the status of this issue? I’ve been watching the release notes of the updates but haven’t seen it specifically mentioned. Has this been resolved?


Just updated my topaz today (July 7) and am still getting the grid pattern. Any chance that you might address this soon?


@Lingyu - Can we please get a response with the status of correcting this issue? I’m still seeing in in version 1.4.1. This should be a priority issue for Topaz to correct.

It’s one thing to have these kinds of issues in a product as new as Photo AI and I think the users understand that. But, not communicating with the users and beta testers who are taking the time to report these issues and provide photographs to get them fixed is just not cool.

@tbalzanto Thanks for checking in. We’re still working on fixing this artifact as a priority for this and next quarter. AI models take a long time to train and retrain and we really appreciate your understanding.

Hello all, I have a build for Topaz Photo AI which has a potential fix for the grid artifact when upscaling.

Please install the below Beta build and try upscaling some images to see if the grid artifact appears.
Mac build
Windows build

Please share any feedback regarding the grid artifact, if it’s still happening or if it seems to be fixed for you.

Not working. When I use High Fidelity this artifacts shows up in dark areas. Very disturbing. :frowning:

Thanks for letting me know. Could you share the original file so I can try to reproduce this?

You can securely submit your image(s) to my Dropbox using the link below. Please be sure to send me a note to let me know you sent something.
Dropbox File Request

i was having the same grid show when i used Upscale with sharpen/noise reduction. i just tried the beta Mac build and it seems to have cured the problem. (i didn’t try it with High Fidelity though.)

1 Like

Please update tomorrow to the production build and see if the conflict is still there.