Intel Arc A770 GPU not being utilized even when selected as the AI Processor

  1. Describe the bug / behavior you have encountered.
    Either due to the last Intel Arc Driver update, the latest build of Video AI or something else entirely, for some reason my PC system will now force the CPU as the AI processor despite selecting the ARC A770 GPU as the AI processor in the setting/preferences. I set this before importing any videos for upscaling and have even started over with a completely new install of windows (just in case it was some system setting I inadvertently changed).

Put simply, the GPU was working great with Topaz Video AI for the last few month and now the my system forces the CPU as the AI processor with near 100% CPU utilization and 0% GPU utilization.

  1. Your system profile

Operating System: Windows 11 Pro 64-bit (10.0, Build 22621) (22621.ni_release.220506-1250)
System Manufacturer: Micro-Star International Co., Ltd.
BIOS: 1.A0 (type: UEFI)
Processor: 13th Gen Intel(R) Core™ i7-13700K (24 CPUs), ~3.4GHz
Memory: 32768MB RAM
Available OS Memory: 32450MB RAM
GPU Card name: Intel(R) Arc™ A770 Graphics
GPU Manufacturer: Intel Corporation
GPU Chip type: Intel(R) Arc™ A770 Graphics Family
Display Memory: 32481 MB
Dedicated Memory: 16256 MB
Shared Memory: 16225 MB

1 Like

Have you checked the other posts about this GPU? And have you updated to the latest driver from the Intel website?

I’m on the latest driver that’s available and I didn’t see anyone with this exact issue - but I have a pretty unique setup, I think. Latest Motherboard BIOS on the MSI website, latest ARC Driver, latest intel chipset drivers, and latest Windows 11 update.


Encoding with the settings I use for a specific string of similar videos used to take 4-6 hours @ 1080p (very dialed in process that I’ve done dozens of times) when the GPU was being utilized. Now it’s saying it’ll take 4+ days because my system only seems to want to use the CPU even though the GPU is selected as the “AI PROCESSOR”. I’m not sure if this is an intel problem or a problem on a program level.

I believe, from other posts, there is a problem with the REBAR setting you may want to see this post on Reddit …

I think I tried to submit this same bug report, but it looks like it didn’t get submitted. Anyway, I’ve found the same behavior here. Driver version 4146 is causing Topaz VEAI to fall back to CPU processing even though the A770 is selected. See this post here:

Rolling back to Intel Arc driver 4125 is a good workaround for this, but then you miss out on the driver improvements in 4146.

Thanks for the insight, I’ll try rolling back the drivers and see what that does

@gargamel314 yep, that did it. Went back to the 4125 beta drivers and it works just like it used to. Same settings, back to 4-6 hours instead of +4 days.

In the above post that i linked, there’s a fix involving downloading the OpenVino runtime and copying it into the VEAI folder - it fixes performance with 4146 drivers (i just tried it). Actually improves VEAI performance a tad over 4125. It’s worth trying - it’s not hard.

1 Like

Also, don’t go by task manager performance, open up the Intel Arc Overlay and look at “render activity” - you’ll see that it’s at like 70-80%, while task manager shows like 10% or something. Task manager isn’t accurate with the A770. Meanwhile, CPU Activity sensor isn’t accurate in the Arc Overlay either, with that you go with Task Manager. Judging by your CPU usage, it looks like VEAI is working perfectly.

So I did performed the OpenVino runtime fix with the 4146 drivers, it does initially utilize the GPU faster than with the 4125, but then crashes about 10-15minutes into the upscaling process.

Did a clean install of the drivers, and same thing happens. Hmmmm…

The solution listed has resolved this issue for other users which leads me to believe that something else may be occurring here.

Please reach out to our support team directly using the support beacon at with this behavior. Please also be sure to include your log files for the app (Help > Logging > Get Logs for Support) as well as your complete system profile (Instructions for Windows/Instructions for Mac).

I think the combination of the recent Video AI program update (posted today it seems) + new intel drivers + the OpenVino overwrite solution seems to have fixed my issue for now.

1 Like

That is fantastic!! Thank you so much for updating me. This is extremely helpful to know.

Ya ok, so suddenly now, every render I start fails within 10 minutes using Drivers 4146. Also, the screen goes blank momentarily when it fails.

Same, just realized this as well.
I thought it was working, but similarly it just fails after about 10min into the render. Tried the same process of uninstall, reinstall no OpenVino fix - fails. Then uninstall, reinstall with the OpenVino fix - still failed.

Not sure what is happening after the 10mins of render, but it previews just fine for an up-to 15 second clip - anything longer and it fails.

I’ve tried uninstalling, reinstalling w/ OpenVINO fix, I totally uninstalled the Intel ARC 770, ran DDU, reinstalled everything, and it’s the same. 10 minutes into the render, the render fails wtih an unknown error. Just when the render fails, the screen freezes for a moment, then turns back, and then when it comes back again, the render has failed.

I think I figured it out.

  • The same thread above that gave us the OpenVINO fix, it was said that you have to rename openvino_tensorflow_frontend.dll to openvino_tensorflow_fe.dll - then when you copy it over it will replace what’s in the VEAI folder.

  • Go into Preferences/Output and turn Video Export to Without Preview

  • Go into Preferences/Interface and set Auto-Play Preview to Disabled

The previews seem to be causing a major problema and end the export early with an “Unknown Error” I am testing now, but so far I am 40 minutes into an upscale render with Proteus/Apollo and it’s still going, on Driver 4146 and VEAI 3.1.8.

EDIT: Nevermind, it didn’t work. I have since dropped back to version 3.1.6 and driver version 4125. I am beyond frustrated.

1 Like

Hi there! Please reach out to Support Directly and we will look into this further with you.