Photo Ai appears to not utilize Intel Arc A770 GPU

I have just installed Photo AI on my PC (Intel I9-12900K CPU and Intel Arc A770 GPU, setting the processor to Intel Arc A770 graphics appears to ignore the A770 and run the app on the CPU. Setting the processor to Intel UHD graphics 770 (integrated GPU) uses the integrated graphics on the CPU.

Why is the A770 being ignored in favor of the CPU?

Topaz Photo AI [v1.2.4] on [Windows 11]

Hey @mike.a.p, I believe @gorp from the other thread tagged here was able to find a solution for this;

Another thing that worked for me was just to replace the OpenVino runtime in Topaz photo/video AI by:

  1. Download the archive from: Intel® Distribution of OpenVINO™ Toolkit
  2. Copy the files from runtime/bin/intel64/Release into the root directory of Topaz. (e.g.: C:\Program Files\Topaz Photo AI)

It should ask you to confirm whether or not you’d like to replace the files. After that everything should work as expected. I still find it strange that benchmark software passmark still works.

Can you let me know if this also works for you?

I tried that archive from (Intel® Distribution of OpenVINO™ Toolkit). It does now use the Arc A770

1 Like