Gigapixel v6.3.3


The issue with the clearly defined squares of either blurred areas or grainy areas doesn’t only come up with extremely grainy or noise images. It crops up with all kinds of images.

FYI: Using an AMD R7 430 graphics adapter (as recommended by HP to beef up the built-in Intel UHD 630 onboard graphics on a HP ProDesk 600 G4 SFF) not only makes processing slower but it produces banding artefacts in Standard and HQ mode. No big deal for me as the onboard thing is faster anyway, but maybe another valid entry into the “Hardware GPAI does not work with” list.

I wonder that it does run aniway.

A 3080 is 2455% faster akording to techpowerup.

It is not even so bad, a 2 Megapixel photo blown up to about 8 to 9 MP takes about 30 seconds to process with the Prodesk 6000/UHD 630, a tad longer with the Radeon. I have even used versions up to 5.7.1 that ran under Windows 7 on a machine 10 years old that had a Radeon 5450 (or so) of the same age, and while it was not much fun (especially the build-up of the previews took ages), the combo still was able to produce said 9 MP outputs without crashing. Oddly enough, on that Windows 7 machine, CPU and GPU produced results that were grossly different (with GPAI 5.7.1, that was) which does no longer occur on the ProDesk 600, neither on my laptop running Win10 as well.

1 Like

Thanks for the great software!

Not sure if this has been mentioned previously. In Mac OS, in either Monterey or Ventura, when dragging an image in from the browser, the Mac will automatically save the file somewhere deep in the computer’s registry, and this disables Gigapixel from choosing to save the upscaled file anywhere else.

This is problematic for workflow: causing an extra step that requires first saving from the browser to a particular chosen place, then finding it, then upscaling. Mac OS finder is terrible for file management and it slows down the entire process. It would be more efficient to save each image from inside of Gigapixel, upscaled straight from the browser.

This is problematic for wasted disk space: unsearchable registry folders end up keeping large images hidden away that are never found again, and may not be purged by the system automatically.

My request is for an option that makes the program prompt to designate where to save an upscaled image, or series of upscaled images, each time the upscaler runs, regardless of source.

By the way, while the Radeon R7 430 seems pretty useless for GPAI image processing, it has an interesting benefit anyway: before the Radeon was in, GPAI used to crash about every five minutes as soon as a picture was open, even if it was neither processing nor generating previews, just idle with a picture opened. The Radeon, though not used by GPAI, has stabilized my system profoundly when using GPAI, I have yet to experience a crash with the Radeon in the machine. As soon as I deactivate the Radeon in the device manager, GPAI resumes crashing. I have also changed the dedicated memory assigned to the Intel UHD 630 from 64 to 512 MB in the machine’s BIOS which seems to have given another push as to image processing and preview generation.


I did some tests with GP 6.3.3. today and increasing a very big panorma from 25Kpx to 32Kpx did result in a extreme slowdown of my Radeon Pro W6800 (32GB Vram) over the whole processing time.

There was no overheating but a downclocking.

I did notice that the Vram load did not grow over 2.7GB, normaly it did go up to 7GB+ with such an big Image.

Maybe the result was an offload of memory from vram to ram over pci-e.

Memorysetting in app was at high.

Gigapixel AI - just paid for and downloaded. KEEP getting :
Error: Image failed to process and was cancelled.
It worked first time, now nothing is working. I’ve switched from video to processor - downloaded new models and nothing there - it LOOKS like its processing, SOMETIMES, but then comes up with the above message. It will also sometimes say processing, but is doing nothing a all. Task manager shows it at very low %age. I’ve rebooted, still to no avail.

First thing that surprised me was how fast viewing multiple models was. Nice work!
Addendum: When viewing multiple models with multiple sources and double clicking one to choose, the choice isn’t accurately reflected in the UI. Another note: As pictured, the face recovery will sometimes extend too far upwards, lowering the quality of upscaling for any overlapping objects, seen most clearly in the line heavy object pictured.

Which Gigapixel model should I use to ensure the hair is also sharpened? Face restore only sharpens within a certain radius of the face.

Also, is Gigapixel being deprecated for Photo AI?

1 Like

It’s a small problem I know but it is a problem never the less.
I loaded a jpeg into Gigapixel 6.3.3 (stand alone version) to upscale and noticed a problem with it that i needed to fix in photoshop elements so i closed the jpeg in gigapixel edited the jpeg in photoshop elements and loaded the fixed version of the photo back into Gigapixel only to find that the problem i had fixed was back in the image being used by Gigapixel in other words it was presumably using the version of the jpeg that it still had in memory, by closing Gigapixel opening it again and reloading the jpeg i was able to upscale the latest version of the jpeg.
I have had a look at Denoise AI, Photo AI and Sharpen AI to see if they have the same problem only to find the same problem in Sharpen AI the other programs seem to be ok.

How can previous versions of Gigapixel be uninstalled? Unlike Sharpen, DeNoise, etc, the Gigapixel installations seem to lack an “uninstall.exe” program. This means that Windows Apps&Features is unable to uninstall them without this, nor can it be done manually.

I never noticed this but you’re right.

steps to recreate
Press Windows Key + R and type appwiz.cpl and click OK.

Scroll down to Topaz

Double click Gigapixel AI 6.2.2 (My current stable version actually installed is 6.3.3 so this entry might be from when uninstall was working and has since been broken?) and this error appears

I also just checked and a few of the other Topaz applications don’t have uninstall.exe files but their uninstall process still works for the few I tried.

If I wanted to uninstall Gigapixel or Gigapixel BETA I can’t at the moment

  • OS Name : Microsoft Windows 11 Pro N
  • OS Version : 10.0.22621 N/A Build 22621
  • OS Manufacturer : Microsoft Corporation
  • OS Configuration : Standalone Workstation
  • OS Build Type : Multiprocessor Free
  • System Boot Time : 14/02/2023, 10:57:13
  • System Manufacturer : ASUS
  • System Model : System Product Name
  • System Type : x64-based PC
  • System Directory : C:\Windows\system32
  • System Locale : en-gb;English (United Kingdom)
  • Hotfix(s) : 4 Hotfix(s) Installed.,[01]: KB5022404,[02]: KB5012170,[03]: KB5022303,[04]: KB5020487
1 Like

This has been an ongoing issue. Just delete the Gigapixel folder in Windows Explorer. Then install a new version and it will have the uninstall file. I’ve done this without any problem. You can always use Glary utilities to clean the registry if needed.

1 Like

13 posts were split to a new topic: DP Review of Upscaling Applications

Another way to get around this bug is to rename the file when you export it from photoshop elements. Maybe add _PE, or something like that.

When coming the new bêta or the new version ? Thanks

Is 6.3.3 the last version of Gigapixel? I mean, since Photo AI pretty much has everything that this version of Gigapixel has.


Try using Art & CG model.