DeNoise AI 2.2.12

Download:

Change log:

v2.2.12

  • Fixed some issues with the updating backend
  • Added the ability to postpone the update prompt
    – Should now only pop up once a day at max unless a newer version is released

v2.2.11

  • Fixed an issue where certain files would not open from third party plugins

v2.2.10

  • Fixed issue where dragging the navigator/preview to the right side would crash
  • Fixed an issue where Photoshop last filter settings were not saved between invocations
  • Fixed a potential crash using auto mode
  • Fixed in-app update downloads not running due to bad paths caused by usernames with non-ASCII characters
  • Fixed erroneously loading files with unsupported colorspaces
    • Mainly, Apple Wide Color Sharing Profile is explicitly not supported when coming in from Photoshop.
  • Fixed update button not enabling in certain cases when masking
  • Fixed a crash in masking
  • Fixed scroll bar in the file list getting too small with large amounts of images
  • Fixed certain runtime dlls not being included
  • Updated installer framework which should hopefully resolve some online installer issues

v2.2.9

  • Fixed external editors not saving back to their host properly

v2.2.8

  • Fixed trials requiring a user to login again after purchasing
  • Fixed various crashes when handling invalid images
  • Fixed various crashes when masking RAW images with crop metadata
  • Changed authentication logic to support upgrades

v2.2.7

  • Fixed batch files not being saved when auto was applied to multiple files
  • Fixed completed flag not being reset when re-saving or changing settings

v2.2.5

  • Fixed various Photoshop irregularities that caused differences between standalone and plugin
  • Fixed various file list view oddities
    – Fixed batch mode settings applying automatically when switching between rows
    – Fixed selecting arbitrary rows instead of everything not saving correctly in some cases
    – Fixed potential bug where settings do not apply properly when saving multiple images with auto active
  • Fixed brighten mode being saved to dark images when exporting
  • Fixed Re-Install Photoshop Plugins option on Windows
  • Fixed being unable to run the plugin re-installer more than once
  • Changed various toggle buttons to be the right blue color

v2.2.4

  • Fixed Photoshop filter not properly using last values when re-invoked
  • Fixed Mac’s Re-Install Photoshop Plugins menu option
  • Fixed recover detail slider not saving properly
  • Fixed chroma noise slider not saving properly
  • Changed right panel design and placement of recover detail
    – Recover detail has been placed in Post-Processing since it does not apply to the model
    – Post processing panel has been given the same box Settings has.
  • Changed save button to “Apply” and “Cancel” when in external editor mode
    – This is to try to make it clearer when people open in external editor mode by mistake (e.g., Open With, or dragging and dropping an image on a shortcut)

v2.2.3

  • Take design changes and improvements from recent Sharpen 2.1.0 release
    – Changes batch mode to only save selected images
    – Changes how auto settings are shown and handled in the file list
    – Adds Fit Zoom option and changes zoom slider layout
    – Adds Re-Install Photoshop Plugins option to Help menu for Windows and Mac
    – Various design changes
  • Fixed issues with certain models not loading correctly for some machines
  • Fixed preview panel processing continuously while mouse is held down

v2.2.2

  • Fixed calibration not working when using the AI Clear model.
  • Fixed low light model not being appended when append model name is turned on.
  • Fixed 50% zoom not working correctly on Mac
  • Fixed “Noise” being listed twice on the file list view

v2.2.1:

  • Fixed Low Noise model not working properly when using GPU.
  • Fixed the Remove Noise slider on the DeNoise AI model going to 0 instead of 15 when setting it back to default.
  • Fixed a minor typo in the Low Light tooltip.

v2.2.0 Released May 27, 2020
Major Features and Changes

  • Added the ability to mask images.
  • Added a special low light/high color noise model option under DeNoise AI.
    – This model is good at handling high amounts of color noise, especially on high ISO RAW images.
  • Auto updater is now built into the application instead of being a separate program.
    – This will do the update check and download the installer, but will not do the upgrade installation itself.
  • Added a new hotkey (Ctrl + ,) to open preferences on Windows.
  • Menus have been slightly visually updated and now show shortcuts.
  • Changed the recover detail slider step value to be 1 instead of 5.
  • Changed Close Image option to Close All Images under the File menu on Windows.
  • Close warning prompts should now all have the same buttons and do the same actions.
  • New images for splash screen and login window provided by Colby Brown.

Fixes:

  • Fixed 400% preview being offset in some instances.
  • Fixed the close all images option not prompting you to save changes.
  • Fixed update button activating by going between models with no changes.
  • Fixed update button not activating when changing view modes.
  • Fixed a bug with login dialog not staying up in certain cases.
  • Fixed a bug where flipping between images with auto and manual modes would cause the right panel to show incorrect controls.

Known Issues:

  • Moving the navigation panel preview box at the end of processing will not start another preview.
  • Using GPU mode with Low/Med/High memory will give different results
8 Likes

Good work! Is there any way to subtract from masking choices?? Thanks!

can the auto settings not include the control of recover detail slider?
i want to set auto mode for a batch of image and enable recover details, just like the default settings of ai clear in topaz studio, but the slider is always zero when the auto mode is enabled
i guess the auto mode won’t calculate suggested value for recover details, i never see a non-zero value for it when auto mode is enabled

Thanks!

If you mean subtracting from your current mask, you can toggle the hide/show button to add or remove strokes.
image

You are correct that the auto mode does not touch the recover details slider. Recover details will always add back some of the original noise from the image since it blends it back over the denoised version, and auto will not try to do that. I believe you should be able to set the slider itself while still using auto values, but if that is not the case I can take a look at fixing that.

Adam, When I uninstalled DeNoise AI beta right now it also uninstalled my most recent (prior to 2.2.0) commercial rel. product. FYI. Seems like it shouldn’t have done that. I’m only just downloading the full Win installer right now. I did the beta uninstall as a 1st step. Hmmm.

That’s strange, I’ll take a look and see if the beta uninstaller points to the wrong one.

1 Like

adam, please test it by the following step

  1. add two images first
  2. ensure all the two images are selected
  3. enable auto detect settings
  4. move the recover detail slider to 10
  5. select the second image in the list
  6. recover detail settings is 0, it’s not copied to the second image even all image is selected in the previous step
  7. click back to the first image, recover detail settings is reset to 0 instead of 10 in the step 4

it’s impossible to apply recover detail when auto mode is enabled
even if i only add one image, enable auto mode and set recover to a very high value, the exported image won’t recover detail, it’s not the same as the preview image
please check it. thanks!

Yeah, I just double-checked. Commercial DeNoise AI is definitely gone. Along with the most recent beta. Only thing in my programs list right now is DeNoise 6 (which I don’t wanna lose either…). I’ll do the commercial 2.2.0 install now.

UPDATE: Installer didn’t include an option (check box) to add an icon to my PC desktop. But when I launched from the icon that was still there from the commercial release (that got uninstalled during the beta uninstall) it showed the correct 2.2.0 commercial rel #.

Also, there’s a minor typo in the explanatory note pop up (’?’) adjacent to the Low Lite (nite) Mode. I believe the 1st word in that explanatory pop up should be “Uses” (not, “use” - which sounds like it’s telling users to use something else vs how the program works for them). :wink:

Thanks. No not that. I mean, once you apply a mask, you can press, for example, the option/alt key, turning the brush into a negative one, then brushing away the applied mask.

Hi Adam, It works for me using GPU mode Win 10/GTX1050:

1 Like

Works for me too. Night Mode on GPU as well, except mine is GTX1060, also Win10 x64.

1 Like

Hi,

no this does not Look like “Night Mode”, Night mode is much better.

Very Nice. ISO 2000, 1DX (2012).


AI-Denoise 15/46/0 (Auto) + Night Mode



No Denoise - Output (16bit Tiff) from Capture One.



AI-DeNoise Only 15/46/0 (Auto), No Night Mode.


I hope that GPU Mode will work this evening.

I believe this is a more hidden issue. The low light mode is part of the DeNoise AI network, and Myunghoon reported that when the DeNoise AI network gets loaded it does not process the low light model on GPU mode. So you will still get output, it just won’t actually go through the low light model.

1 Like

That is Low Light Mode ??? that is a 1" sensor @12800ISO, original RAW

Thanks Adam…

nah, eh oh, ok you’re @ 13.
does it change when you deactivate Night Mode?

Yep … when I deactivate Low Light Mode:

Ok i’m Silent. :wink:

1 Like