DeNoise 3.4

This update is corrupt, i had to reinstall the previous version because the font is unreadable

Try upgrading to macOS 12.1, not saying it will work but I was having crashes if I batch processed 50 to 90 from a set of 370 or so images, after upgrading I denoised the last 134 without issue.

I guess I should point out these were all DNG files, so it could be its a separate jpeg issue.

Replying to myself 3.4.1 crashes on loading any image every time for me, 3.4.0 was fine with DNG’s didn’t try it with the other types

Apple M1

Process: Topaz DeNoise AI [2934]
Path: /Applications/Topaz Labs LLC/*/Topaz DeNoise AI.app/Contents/MacOS/Topaz DeNoise AI
Identifier: com.topazlabs.TopazDeNoiseAI
Version: 3.4.1 (3.4.1)
Code Type: ARM-64 (Native)
Parent Process: launchd [1]
User ID: 501

Date/Time: 2021-12-22 23:14:37.0602 +0000
OS Version: macOS 12.1 (21C52)
Report Version: 12
Anonymous UUID: 5071BBBB-3058-0245-BD65-840BB6E0E94D

Sleep/Wake UUID: AAF52D42-0336-4FD0-A76A-5E46E637F0D7

Time Awake Since Boot: 8500 seconds
Time Since Wake: 1204 seconds

System Integrity Protection: enabled

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Type: EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000000
Exception Codes: 0x0000000000000001, 0x0000000000000000
Exception Note: EXC_CORPSE_NOTIFY

Termination Reason: Namespace SIGNAL, Code 11 Segmentation fault: 11
Terminating Process: exc handler [2934]

VM Region Info: 0 is not in any region. Bytes before following region: 4336123904
REGION TYPE START - END [ VSIZE] PRT/MAX SHRMOD REGION DETAIL
UNUSED SPACE AT START
—>
__TEXT 102740000-102b94000 [ 4432K] r-x/r-x SM=COW …az DeNoise AI

Kernel Triage:
VM - pmap_enter failed with resource shortage
VM - pmap_enter failed with resource shortage
VM - pmap_enter failed with resource shortage
VM - pmap_enter failed with resource shortage

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0 libTDenoise.dylib 0x10d80175c aiengine::AIProcessor::initBlockModels(cv::Mat const&, QMap<QString, QVariant> const&) + 292
1 libTDenoise.dylib 0x10d801748 aiengine::AIProcessor::initBlockModels(cv::Mat const&, QMap<QString, QVariant> const&) + 272
2 libTDenoise.dylib 0x10d7fa4bc aiengine::AIProcessor::initialize(cv::Mat const&, QMap<QString, QVariant> const&) + 328
3 libTDenoise.dylib 0x10d7f89e0 TDenoise::getAutoParam(float&, float&, TSMat const&, QString) + 688
4 libTDenoise.dylib 0x10d7f7fd8 TDenoise::autoDetect(QString const&) + 988
5 libTDenoise.dylib 0x10d8318e4 TDenoise::qt_metacall(QMetaObject::Call, int, void**) + 156
6 QtQml 0x1033330b0 0x103204000 + 1241264

Replying to myself again. Deleted and re-installed from the download rather than upgrading and that seems to have fixed it. So there may be an issue with the Updater.

It still crashes will doing batch processing though, just ran through the same ones as I did yesterday and it crashed after 71 successfully denoised images.

Downloaded 3.4.1 from within Denoise in response to a prompt. Download and install proceeded normally. Preference remained as Auto for GPU (to avoid previous crash issue?).
Uploaded an older scanned sepia portrait, auto model chosen and result is quite good, albeit a bit of over-sharpening creates (higlights?) some unusual facial features.
No crashes, speed is good. More playing to come

I posted some examples of DeNoise 3.4.1 tackling film grain (in scanned early-'90s 35mm images) on my blog.

I had been using Clean under Studio 2 but it seems that same Model within the new DeNoise is another option to access it!

1 Like

Updated to 3.4.1 yesterday and after a bit faffing in Lightroom to get the plug in to open the app sees to be working fine until it comes to applying the edit. It no longer goes back to Lightroom, but instead asks me to save a renamed copy. How do I fix this? Or do I need to go back one as the previous version was excellent in all respects.

2019 Intel iMac, 64GB RAM, 1tb.

Go to the first post and the issue with external editors is explained there.

Tried to get 3.4.1 update to launch on my Windows machine for several days. Chat support is not available and my emails go unanswered. Tried installing, uninstalling, and reinstalling several times. No luck. This morning saw a link for a full install and finally DeNosie seems to be running both as a standalone and as PS plugin. Won’t update as quickly as I did before and certainly won’t depend on Topaz support for any help.

4 Likes

I may be missing something but cannot find anything related to Lightroom explained there?

Yes, I have been using the Clear model on some of my film scans for several months. Usually does a good job and better than Neat Image which I had been using for almost the last 20 years.

I wrote about my scanning experiences and you may find it interesting:

Scanning Torture (or Learning to Love Your Digital Camera) – Part 1

Over 10,000 35mm slides and negatives scanned! – Part 2

Update on scanning color negatives – Part 3

1 Like

Thanks Henry!

Currently, launching DeNoise AI in External Editor mode on Mac OS using certain host applications… it seems LR is affected also.

There is also a post by the developer here …

Sadly, my upgrade line appears to stop at 3.3.2, at least for this machine (my main editing device), as my 2010 i3 27" iMac won’t go higher than High Sierra. That’s assuming there won’t be a 3.3.3.

Since I have done the Mac (using Big Sur 11.4) update the app icon bounces around then stops (when I “used to” see the app window open at that point) No window opens!
Again… it worked fine before latest update.
Such amazing products! I bought the design bundle with DeNoise in a last hope to solve a noise/sharpen issue I had on very important image that was expensive and difficult to arrange… I would have had to reshoot if the app didn’t work! It did ! Client accepted when they rejected me using pretty advanced Noise reduction techniques in PS! I can only assume it’s the AI… man… so impressed!

UPDATE: I have tried everything to from updating OS 11.6.2 to trying old version posted on downloads page (TopazDeNoiseAI-2.2.12) I can not get app working!
Ive been spending hours on this and do not know why it was working fine to nothing at all!
I right clicked dock icon to “show all windows” and see a blue outline of a window… so something there but it just won’t start!!
PLEASE! I missed my deadline today because of this … client not thrilled.

Anyone else having this issue on MacOS

Cheers yes. I think this is where my confusion came in. The same explanation is on the release notes for the previous version, which worked fine for me in lightroom. Further confusion now as I rolled back to that version and it’s doing the same thing. Now gone back to 3.2.

I know the obvious conclusion to this is that I must have been on 3.2 before anyway, except. I know I wasn’t. As I’m no techie, I have no clue why 3.4 (or 3.3) now won’t run in the way thru did before on my computer. I’ll just wait for the fix.

1 Like

How do you roll back to previous?

Uninstall it and download the earlier version here - DeNoise 3.2

Thank you Henry for your post and such a colorful description of your creative process. This is very familiar to me.
But unlike you, my main material is black and white negatives. They are badly damaged by careless handling and storage. In addition, the films have a very large grain, which different versions of DenoiseAI try to remove in different ways. I haven’t tried using the latest version 3.4.1 yet.
Nevertheless, I am glad that I am not alone in using Topaz programs for processing negative photographic film.
I hope that the developers will not forget about the users who use DenoiseAI to process negative photographic film and optimize new models taking into account the specifics of processing negatives.
I wish you creative success and good health.

1 Like