DeNoise 3.4

Ran the patched version and it was fine in all models did not try RAW. Also reloaded saved images and ran through various models then saved as different image types TIFF, PNG, JPG, DNG and they are fine.

Monterey 12.1, M1 MAX

1 Like

Everything seems to be working fine on my computer. Custom built windows i5-11600K for photo editing.

1 Like

Well I tried 3.4.1 and for my issues there are no improvements. I also upgraded to 3.3.4 but the plugin still will not work properly from LRC so if any one knows what I missed I would love to know. Thanks.

So far, the patch is working fine for me on my M1 Mini. I tested it once in standalone and also as a PhotoRaw plugin. The latter didn’t crash as was happening with the first version. Thanks for being so quick off the mark, Adam.

1 Like

I have some potential debugging steps, but I need more information.

Have you ran the application as a standalone? This is required because the application tries to update the lrtemplate every time it’s run, and the template has changed between the old version and this version.

Do you have a catalog in a non-default location? If so where it is? By default our auto check only looks in /Library/Application Support/Adobe/Lightroom/External Editor Presets so if your LR does not load presets from there then it wouldn’t load the new one. If you have it in a non-standard location, you can try to copy the lrtemplate file from /Applications/Topaz DeNoise AI.app/Contents/Resources into your catalog location’s External Editor Presets folder.

If any of these is the case let me know so I can know what the root issue is. I want to try to incorporate it into the app or update process.

The same here!

1 Like

Same as well, reverted back to previous version and no issues.

1 Like

3.4 and 3.4.1 will not run on my M1 Mini.
Running 12.01 Monterey.

It’ll open but as soon as I drag a jpeg into the program it crashes.

This happened on 3.4. Installed 3.4.1 today . same problem. I’ve rebooted once.
Please advise. Not happy right now since I recently purchased Sharpen and Gigapixel and they are dog slow on my M1 and DeNoise which has been great is now broken.

2 Likes

You can open an image to edit it that way, but there is no way to save it. You can only Save-As and create duplicates. It used to work great as a Photos plugin, but that was broken a few releases back and still hasn’t been fixed. The same with all the other Topaz programs. For those of us that use Photos to manage our library, all the programs are now unusable.

1 Like

Thank you, that was super fast!

I’m running 3.4.1 on Windows 10, but I’m not seeing the RAW option to process my Fujifilm X-S10 files. Is there a special setting necessary in the camera perhaps (due to different compression algorithms)?

On Windows 10 install using FULL installer file 1.7 GB, once downloaded and installer is launched reports file is corrupt and fails install and crashes the desktop. Running the online installer download works. Whats up with that?

My apologies, if you read the first post there is an explanation that this feature is temporarily removed until the overwrite option behaves correctly.

Note that Fuji X-Trans RAW are not yet supported as noted in the v3.3.4 release notes …

Major Changes:

** Allow loading RAW files that aren’t supported by the RAW model*
– RAW model is understandably disabled for these cases
– Mainly includes Fuji RAF files, but also any RAW that does not use RGGB Bayer color info
** Allow DNG files to use RAW model when internal RAW data is supported*
– This requires the DNG have CFA Pattern layout. Linear RAW is not true RAW data and is not supported by RAW model.

Any updates for the M1 crashes running as a standalone? I haven’t even bothered with RAW files - just jpegs so far. Thanks. This is both 3.4 and 3.4.1 on OS 12.0.1

What do these 2 things in 3.4 mean? What is the result for us users? Better noise reduction? Or something else? Items such as this can be very meaningful to the software developers on the project, but have little or no meaning to the customers. I was a software engineer for a few decades and I know how easy it is for developers to put developer-focused notes in change documents meant for customers rather than customer-focused items. Please tell us how these 2 items make things better for us. Thank you.

1 Like

Ah, thanks. So is it true that RAF files are now “supported” because they can be loaded, but not “supported” in terms of the “RAW option”?

It’s a bit confusing.

Upgrade 3.4.1 won’t launch on my windows 10 machine either as a standalone or inside Photoshop. Tried reinstalling, then did full uninstall and reinstall from web site. Still doesn’t launch.

Hi Adam,
My LRC catalog is in the default User/Pictures/Lightroom location and I looked in the location you mentioned and there is a DeNoise template from the latest 4.3.1 because I didn’t know it was there :slight_smile: and also a shortcut DeNoise template which is from the 3.3.4 which I went back to.
I removed the new DeNoise from /Applications and removed the 4.3 template leaving only the 3.3.4 template shortcut and restarted Lightroom and now I am back up and running!! Very Grateful, Thanks.

So to recap, I installed 4.3.1 on my M1 Mac mini running macOS 12.1 and I didn’t have issues with the app itself. The problems I had were with the plug-in / external editor.

I very much look forward to a fixed version because I can assure you that 4.3.n is easily twice as fast as the Rosetta versions.
If I can be of any additional assistance I am happy to help.

JP

Installed the M1 version v3.4 and it crashes immediately after opening. Then when I opened the last (non M1) version it prompted me to download v 3.4.1.

That installer removed the non M1 version and installed v3.4.1, which too promptly crashes upon opening

Hi, On installing v3.4.1 the installation process ended with the message -

Error copying file from /
Applications/Topaz DeNoise
Al.app/Contents/Resources/
TopazDeNoiseAl.Irtemplate to /
Volumes/ExPro2/Lightroom/
2021-LRCat/Lightroom Settings/
External Editor Presets/
TopazDeNoiseAl.Irtemplate

[MacBook Pro M1 Max 16”, 32-core GPU, 32GB URAM, 1TB SSD. Monterey 12.1, Lightroom 11.1, Photoshop 23.1. Note Catalogue/ images held on external SanDisk Extreme PRO 2GB SSD].

Having ‘ignored’ the installation error message, I found v3.4.1 had in fact installed and seems to work fine as a standalone and Photoshop plug-in, with Lightroom via plug-in it works, but the side issues I reported yesterday remain - i.e. after processing it returns to a click to Close Panel state, then the 4 images in the comparison view are displaced until I refresh by repositioning the image and finally the newly created/ processed TIFF isn’t loaded into Lightroom until I synchronise the folder (the original TIFF which was created to send the file to DeNoise remains there, unprocessed, and I have to manually delete it).

I’ve put my MBP to sleep, ejected/ remounted the external drive, changed catalogues and switched back to the original again (all held on the external SSD), run Denoise 3.4.1 as a standalone, via Lightroom/ Photoshop and - so far - it seems stable. I’m thinking maybe the minor update has fixed it? (I’ll see how it goes for the rest of the day, but apart from the reported snags, so far, so good).

Update - v3.4.1 crashed again after a lunchtime break. I reinstalled v3.3.4 and v3.4.1 worked once again. I have no idea what’s going on, the fix won’t stick on my system.

Update 2 - v3.4.1 crashed this morning on first use, I then ran v3.3.4 (I kept it installed!) on the very same image and it worked. Then ran v3.4.1 and it also worked. There’s a pattern developing here…

Phil