BUG: Batch process useless, AI model always reverts back to Proteus after 1st input file

  1. The bug / behavior you have encountered:

a. drag 4 files to be converted
b. Set upscale 2X - interlaced progressive - “Dione Roburst”
c. H264 Audio mode - convert
d. make sure all 4 input files are selected and clicked on “selected”
e. click on any “input” file in the left side pane and the AI mode reverts back to “Proteus”

  1. Your system profile
    AMD 5950X 64GB - nVidia 3090 - Win11

  2. Your log files (Help > Logging > Get Logs for Support)
    N/A (not need to produce the issue)

  3. Any screenshots as necessary

This makes the batch processing useless as one and only one file will be exported with the correct settings and the others will revert to Proteus.

I have been complaining about this for few weeks now…

It’s certainly not ideal … I let a batch process run (took about 2 days) and I come back to see only ONE file created with the correct AI model and all the others defaulted to Proteus. Very annoying!

The trigger is if I click on any Input File in my left pane, the AI model defaults back to Proteus.

My temporary work around:

  1. Start Topaz
  2. Drag and drop all the files I want to process
  3. Load my saved Preset
  4. Hit Export

Do NOTHING else, don’t touch the UI at all.

Of course the problem with this approach is that I can’t see when Video AI has moved onto the next file and no % complete status.

To be honest, the entire Batch/Input File selection process is a poor interface … there are “Selected” and “All” buttons in the middle of the UI but the actual Input File selection is on the left of the UI and its NOT clear exactly what is and isn’t selected (slight change in gray color) … this should be a very clear checkbox list. Developer(s) need to rethink their UI when it comes to batch input file processing.

Anyway, I hope the devs can fix this issue soon, I can’t think anything more annoying than to have a task run for 2 days only to have to dump 95% because it wasn’t the AI model I selected.


My workaround right now is to have a script that goes through every source video in the left pane, click its FFMPEG button, copy out the FFMPEG command and save it to a “batch file”.

Since the bug only affects the Export, the correct settings for each clip are still retained in the GUI as long as export isn’t used. It also gives me an opportunity to really check what command will actually be run before I commit to a “2 day encode” :wink:

But yeah, I feel for you. I had a night’s worth of processing go up in smoke like that. Less of a loss than 2 days!

4.1.2 didn’t fix it :frowning:

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.