Video Enhance v2.6.1

Download: Windows | Mac
Released November 18, 2021.

Major features

  • Updated Chronos Fast model for better quality results
  • Improved performance for mac when the app is running in the background or when display is off

Improvements

  • Keep audio on Mac works correctly on Mac now
  • The app will not slow down processing when in background, behind the screensaver or Lock Screen on mac
  • ETA estimation is more accurate
  • Files can be read and saved to all drives, remote directories and other writable paths
  • Fixes issue with flickering download of the same model again and again on certain hardware
  • Decimal places on output filenames rounds at 3 digits
  • Output won’t be overwritten even on custom file path
  • Batch processing model parameters stay as expected
  • CRF setting works correctly on output and will not generate unintended huge mp4 files
  • Output FPS can be set to as high as 240
  • Fixed FPS to be correct for decimal values
  • VEAI will not show version incompatible models
  • Selected models in Model Manager should show correctly

v2.6.0: Windows | Mac
Released November 9, 2021.

Major features

  • Native M1 Mac support
  • Chronos Fast model for videos with rapid motion
  • Proteus, Artemis and Dione updated for reduced artifacts, faster processing

Improvements

  • Improved preferences panel with all settings in one place
  • The VRAM slider is local to the user hardware, so max will mean use all memory on device
  • Ability to view and use all models without using model manager
  • All models now maintain color consistency better than before
  • Installer size has been reduced significantly
  • Lots of bug fixes

Known Issues

  • Keep audio on Mac does not work
12 Likes

TY!

Some requests if they arent on the radar:

  1. Allow rotating video in preview

  2. If the video has the metadata flag for rotation (like portait mode iphone videos) this metadata should be preserved when processing the video

  3. Forgive me if this is fixed in 2.6 but the ETA times have been very inaccurate, and since many of us use our personal PCs for this it can be difficult to plan out GPU availability for other things.

  4. “Differential” Preview (or output) mode that highlights differences between two model outputs

  5. H265 and AV1 output options (preserve audio as it was without re-encoding it).

  6. In 2.4 I notice a lot of the time my CPU would be at 100% and GPU seemed to be under-utilized despite having correct settings to use my GPU. (WIndows machine 4790k, 4 cores 8 thread, 2080 ti) Not sure if this is just because I have a 4 core or??? This is when using Proteus or Artemis or any other model.

3 Likes

Why am I seeing multiple options for “model parameters” for Proteus? Whenever I change Antialias/Deblur, all other options get duplicated. I can post an image if I could, the forum isn’t letting me post any images.

1 Like

Try clean installing the app and let me know if it goes away. I’m assuming you are getting more sliders when you move a proteus slider?

1/2. Rotation of the video and fixing landscape/portrait videos rendering will be fixed in the next version
3. Yes the ETA issue has been fixed
4. Use the comparison view for this.
5. H265 and AV1 encoding depending on hardware can be very slow, H265 also has licensing issues AV1 will be added soon for sure.
6. The video encoding is currently done on CPU hence the high utilization, this will be moved to GPU soon.

5 Likes

I did a clean install and that seems to have helped. Thanks for your response :slight_smile:

Every time I try to start processing, the program crashes.

I tried to do a clean install, but I can’t uninstall 2.3 or 2.4 because it says it can’t find uninstall.exe to do so.

1 Like

The link for the Mac download in the Email blast and also the link on the products download page are both downloading v2.4.0, not 2.6

I had the same problem with the beta version but after a little while, it miraculously cured itself?

I have the current beta version. Is it worth replacing it with this one?

I downloaded it from the email link , I got the 2.6

I have now done a clean install of 2.6 and it still crashed, so I removed that and reinstalled 2.4.

Now 2.4 can’t upload a model to run it to process a video.

What do I do?

What would be an approximation of soon? An hour? A day? A week? A month? Would be useful to have a more accurate estimate since render times appear unchanged coming from the intel version. Thank you.

Edit: What I meant to say is that I am a M1 Mac user who has migrated from the intel version of the app to the native Apple silicon version (which is now optimized and not using Roseta to function anymore) and thus should be seeing improved performance.

Also, I’ve noticed the option for exporting to Prores 4444 XQ has been removed, is there any specific reason for this and will it ever come back?

Working ok here (Windows 11, i7-7700, 32Gb, 750ti GTX (running on iGpu).

beside waiting an answer from the dev, Ida, or writting to the support, i’ll suggest to do a real clean install. including maybe registery too if you know how to do it ? which driver / graphic card do you use ?

Check my edit for the question. I didn’t express myself very well :sweat_smile:.

I was replying to timothy.steinert :joy:

i’m just a user, doing the beta testing with hudred of other people and still awake lol, so i can reply to one of your question by quoting ida who replied to someone just before the release of 2.6

You all rock! v2.6.0 has made significant speed improvements on my Mac Mini M1.

While rendering from a 480p video up-converting to 720p video using the Artemis LQ setting:

  1. v2.4.0: 0.14 to 0.15 sec / frame
  2. v2.6.0: 0.09 to 0.10 sec / frame

It is now 3x faster using a cheap Mac Mini M1 vs. my iMac 3.7GHz 6-Core Intel i5 with 40GB RAM.

I’m sure the audio bug with be fixed shortly. Haven’t had much time to play with this, but this is awesome.

1 Like

I have created a little Apple script that will combine a video with an audio portion from another file. I have assigned as a service so you can just right click on a video you want to add the audio to. it will also copy subtitles if you have any. Hope this helps

on run {input, parameters}
repeat with f in input
set videofile to POSIX path of f
set audiofile to POSIX path of (choose file with prompt videofile default location videofile)
set outputfile to do shell script “echo " & quoted form of videofile & " | sed ‘s/\.mp4/\.2.mp4/g’”
set res to do shell script "/usr/local/bin/ffmpeg -i " & quoted form of videofile & " -i " & quoted form of audiofile & " -vcodec copy -acodec copy -scodec copy -map 0:v -map 0:a\? -map 1:a\? -map 1:s\? -max_interleave_delta 0 " & quoted form of outputfile
end repeat
return input
end run

2 Likes