Video Enhance v2.6.4

Just uninstall 2.6 and then reinstall. If it still fails post the logs.

I use only ProRes 422 files. Is the audio issue a problem or is it corrected by removing the previous version?

The audio issue in mac has nothing to do with the previous version. We left the previous version in place so people who want audio can still use that one. I would recommend using the apple script by @domdom posted above.

The focus for the next VEAI release will be Video IO. So soon would be mid dec early Jan for release version and couple of weeks for the betas to start rolling out.

2 Likes

Can you post the logs, if you are still having issues.

Hello! Is it possible to use the new models with the older VEAI v2.3? I parallelize upscaling individual jobs across many local and remote GPUs to significantly speed them up (~40fps when upscaling 480p to 1080p), but it’s only possible to do that using the veai cli tool that was last shipped in v2.3.

Alternatively (and I should probably just try before asking), can I drop the veai cli tool from v2.3 into v2.6’s folder and have that work?

Thanks!

Did some testing of the new version on Apple silicon and my Windows desktop. A few things I noticed:

  • I can open files from external storage and preview just fine. However, if I try to actually process the video from external storage on my Mac, I get an error that says “The following video cannot be opened for write. This may be due to no write permissions on the folder, or an invalid file path.”
  • The first time I tried to process a video, estimated time always said 0 seconds (on both of my machines).
  • After the first video, I did get estimated times, and they are more accurate than before. However, it estimated that my Desktop would take a little longer than the MBP, even though it was actually a little faster (on the order of estimating it would be 20% slower, when it was actually 20% faster).
  • I compared results on two different models (Artemis LQ and Proteus v3), exact same settings. However, the videos output on my Mac were significantly larger than those on my Desktop. I double-checked that the same grain and compression settings were selected both places (MP4 - H.264, Quality 15), and I also confirmed that it wasn’t due to the difference between GB and GiB. Is this expected? Are the encoders actually different?
  • A weird bug - if I process a video, close the video after it was done processing, then try to open it again, the video doesn’t load correctly
  • I know it’s already mentioned, but the “Keep Audio” function didn’t work for me on my Mac.

Also, in case anyone is curious, here is a speed comparison between my Desktop (a Ryzen 5950X / RTX 3090) and my new M1 Max 14" MBP. I took a 3:53 clip that’s originally 720x528 at 24 fps and did a 2x upscaling on both machines. Here’s what I got:

Proteus v3:
Desktop - 7:55 (11.8 fps)
M1 Max - 9:25 (9.9 fps)

Artemis LQ v13:
Desktop: 7:13 (12.9 fps)
M1 Max: 8:46 (10.6 fps)

So the M1 Max laptop only took about 20% longer compared to a 5950X and 3090. That seems pretty impressive.

Also, I know there are probably licensing issues, but recent graphics cards have built in H.265 encoders that are very fast. If you’re planning to add GPU support for encoding in the next version, could you look into adding H.265 along with it? That would be amazing.

5 Likes

Can you try setting your output directory different than the input one in preferences.
The ETA estimate for smaller videos may be a little skewed by the model load/initialization times.
The version of FFMpeg libraries used on Mac are different than the ones on windows. The next version should use the same version so the results should be similar.
The H265 encoder for M1 Max is capable of getting around 20fps, so yes along with the ProRes options, barring any licensing issue we will enable H265.

I would recommend using higher input resolution(HD or higher) to get a more realistic estimate of performance between M1 Max and 3090.

3 Likes

Thanks for the reply. Forgot to mention, I did already try outputting to a different directory (just to my Desktop), and I still had the same error. This error did not happen with the previous version of the program (both were run on the same version of Mac OS, with the previous version running through Rosetta 2).

That’s fair on ETAs being skewed for smaller videos. And yeah, I’m planning to test on higher resolution videos as well, just wanted to do a quick test that would only take a few minutes to start.

And that’s good to hear that H.265 is a possibility, would love to see it for both Mac and Windows.

Unfortunately, there is no CLI tool with this version yet. You should be able to use some of the newer models by modifying the json files in 2.3,
Let me know if you are unable to use Proteus v3 by updating the version number in the json. I can probably send you a Chronos fast json file to use as well.

3 Likes

Thanks, I appreciate the response. If it’s just tweaking json files I should be able to manage.

Do you expect the cli tool to work as-is if dropped alongside v2.6’s executable?

edit: Answered my question: it seems like AIEngine (the ModelMaker specifically, but probably other stuff too?) has changed too much for the old veai to handle. ModelManager seems like the replacement. I think AIEngine still exposes all the necessary functionality to create an effective cli so I’ll try linking it and creating my own

Does the problem go away if you run the new version with Rosetta-2?

Nope, still have the same error even after forcing it to run using Rosetta (by doing “Get Info” -> checking “Open Using Rosetta”).

Same issue. Using my gaming PC to process files overnight. Files are hosted on an external drive connected to an M1 mac mini (that also processes files). I cannot write to that external drive anymore from VEAI on my PC, but it did work in 2.4 just last night. If I set the directory to my secondary hard drive in my PC (then restart VEAI!) it works.

1 Like

@suraj The audio issue appears to be more of a video length issue. See 2.6.0 release logs from a 42min show, it lost the same “1 second” of data, that a 1hr 33min show lost. This points to something else happening.

Source length should equal converted length, correct?

Original: 0:42:40:599
Optimized: 042:39:633

Makes the AppleScript @domdom nice, but no fix because the audio re-muxed together is now out of sync about half way through it starts to edge further out.

(okay, well, even though I had the logs turned on, no log was created for the first video I encoded giving the error above. I’ll do another one and post the log, but this is very annoying.

Believe it or not, I don’t have a decent GPU. My setup is Intel® Core™ i5-7400 CPU @ 3.00GHz 3.00 GHz with 16GB of RAM running 64-bit Windows Professional Build 21H1.

What I have done in the meantime is to reinstall 2.3 and THAT seems to be working fine.

I don’t know how to do a clean reinstall with registry scrubbing.

Hi
There should be a neural engine in Apple chips. Is that part of the chip useful to our workload?

Since applications and models are separate, maybe it’s time to introduce its own “Video Enhancement Models” thread?

The output path which is specified is is entered into the Windows registry in a wrong way. The entry in my 2.6.0 version under “OutputDirectory” is “/C:/Users/rs-hppd600/Desktop” which will produce the aforementioned error. After removing the first slash (entry now “C:/Users/rs-hppd600/Desktop”) and saving the registry the software saves correctly.

I shall try if this works with remote paths as well.

Update: entering a remote path as output dir in the VEAI prefs (in my case, another PC connected via to the PC running VEAI) left the “OutputDirectory” in the registry blank. However, after inserting the path manually into the registry my VEAI 2.6 now saves to the remote machine without error.

1 Like