VEAI with the Intel Arc A770

Hi there, I’m just trying to optimize VEAI for the Arc A770 (13700K), and I’m looking for any advice you can give me.

I’ve spent the last week playing around with VEAI, currently using version 3.1.6. I’ve encountered some issues. I’ve been trying to upscale a 480p DVD TV episode to 1080p using Proteus Manual, and interpolating 23.976 fps to 60fps using Apollo. Current results for a 43 min. episode: 12 fps (.08-.09spf), 3h30mins.

Crashes: Basically any time I begin a render, if my computer goes to sleep, the render stops with an unknown error. Any time I try to render more than 1 video at once, it crashes with an unknown error after around 5-10 mins.

Other weird things:
Under AI processor, I get the following choices:
Intel(R) Arc™ A770 Graphics
Intel(R) UHD Graphics 770
Intel(R) Arc™ A770 Graphics
All GPUs

Not sure why the Arc A770 shows up twice?

Performance stats show differently on the Arc Control app vs. Windows Task Manager. Currently, the Arc Control App displays 79% GPU Activity, 78% Render Activity, 3% Media Activity, while Task manager shows between 3% and 20% GPU Utilization. I’m not sure which one to believe. (Intel’s software is super buggy)

Also, GPU Core Power is only at 114W (this card goes up to 220W), GPU VRAM is at 2279 MB (out of 16GB), and temps are low (around 65). I’m not sure why I can’t get to 100% here, where the bottleneck is, but using my RTX 3050 Laptop GPU, it uses 100% of the GPU while it’s rendering the same file. Arc is working much faster, but what can I do to improve performance?

With intel’s “Deep Link” enabled, shouldn’t the integrated graphics be doing something?


1 Like

Bonjour, je suis un peu dans le même cas que vous, ma config n 'étant pas tout a fait pareil !

processeur Ryzen 9 5950x
carte graphique Intel arc a 770

j’utilise la version 3.2.2 et des que je lance une previews il fait une erreur presque systématiquement (erreur inconnue) et souvent il ferme le logiciel et quelque fois il reboot mon pc !!
que ce soit d’un dvd up a 1080p ou 2k ou 4k…

je n’arrive a rien avec cette config j’avais dans l’idée de partir du Ryzen et mettre tout Intel ms si avec votre config c’est pareil je vais attendre…

Yeah, all A770 owners have been dealing with this same issue for almost 2 months now. Since I originally posted this, I’ve learned a lot.

The Unknown Errors come from a problem with FFMPEG, and it’s an Intel-side bug that is set to be addressed in one of the next driver updates. You can try rolling back your drivers to 4125. If you still get errors, try rolling back VEAI to 3.1.6 and using with driver 4125.

  1. I am seeing that my CPU throttles by about 30% when I minimize Topaz Video AI. I go from 80% utilization to 50% utilization when minimized. I have double checked all Windows 11 power settings, everything is set it to ultimate performance and the CPU min and max is set to 100% in the power settings as well. This is not due to thermal throttling because you can see a direct correlation to the CPU utilization dropping as soon as you minimize the app. I have also double checked to make sure efficiency mode is not turning on for any of the topaz programs.

  2. System - 4090 / 13900kf. Running 3.2.3

Any ideas? Has anyone else run into this issue?

I also have this issue.
When minimized, the fps drop from ~10fps to ~5fps and all I am doing is browsing internet or using Spotify.

Hi @Mr.Lanning & @Wombart Unfortunately, this is a known issue that we are currently unable to resolve due to recent Intel updates. We are hopeful that this can be resolved shortly.

1 Like

Thanks for the answer!

1 Like

Split out from the below thread as requested:

As of Intel ARC drivers past 4125, VEAI 2.6.4 and the Intel ARC optimizations are no longer working. Regardless of selection, rendering falls back to the CPU and doesn’t appear to utilize the GPU whatsoever.

If I apply the openvino patches noted in Very slow performance on Topaz Photo AI and Video Enhance AI on Windows with Intel GPU - #19 by XBrav, VEAI 2.6.4 will close without error when attempting to preview or run any model. 2.6.4 appears to use openvino 2022.1.0.0 and I’m trying to use it with 2022.3.0.9052.

Topaz Video Enhance (4.3 MB)

2023-04-04-06-33-46-Main.tzlog (86.0 KB)
2023-04-04-06-33-46-Qml.tzlog (8.8 KB)

It looks like it’s closing due to C0000419 FAST_FAIL_INVALID_ARG, but I can’t diagnose much further past this.

Initial Discovery:

For those of you with older VEAI versions, it seems to be fixed by only updating the following files:

  1. openvino.dll
  2. openvino_c.dll
  3. openvino_intel_gpu_plugin.dll

You can leave the other openvino files as-is. This increased my Proteus rate from 0.96/s to 0.15/s on the A770 on driver 4255.

Further Discoveries:

There is an incompatibility with the calls to openvino_ir_frontend.dll in the latest openvino release and VEAI 2.6.4 that causes the crash. If you copy all the files EXCEPT the ir_frontend DLL, the optimizations will return.

Is there a way we can get a patch for 2.6.4 to use the current openvino runtimes for continuing support of the ARC GPUs?

1 Like

Yep having the same issue. I haven’t been able to use Intel or Nivida Graphics for the last month. Topax offically useless for me.

Thanks @andrew.bryan! One of our main specialists, Ida, is out sick right now so we’re running a bit short on hands for Video AI, but we’ll try to look into this as soon as possible.

Hello, Much appreciated. New update did allow me to use Nivida GFX so thats good. I can progress with trimmed over night runs and then I’ll render them all together. Intel still having issues as you no. Its the dedicated upscaling gfx so upscaling projects have been slow or onhold for a while. But thanks for your hard work and keeping at it.

Hi Andrew,

Just checking in to let you know our team is working on improving performance and stability with Intel’s Arc GPUs. Since this platform was released so recently, our newest version (3.2) is the recommended Video AI build to use on Arc GPUs. Please update to this latest release and see if performance improves. VEAI 2.6 will continue to work even with version 3 installed on the same system.

Thank you!

1 Like

Hey @tony.topazlabs,

I appreciate the update. As much as I would happily upgrade to 3.2, my license guarantee for upgrades was not long enough to include the upgrade to version 3, so I’ve been parking on 2.6.4. Unfortunately, the $149 USD upgrade is not in the budget currently.

I was hoping for an official minor patch to 2.6.4 as it did work until recently with openvino changes. I can run 3.2 in trial mode for testing, but the paid upgrade path is not currently an option for me.

I give up at this point. I brought an Intel GPU for upscaling with Topaz but its over a month and still not working with updates and provided soultions. Appreciate the effort and I know its differcult but I’ll try other products now.


Wanted to give an update on the ongoing issues with Intel ARC GPUs: Intel and our team have identified the issue and there is currently a driver fix that is in final stages of preparation for release. This bug affects Topaz Video AI as well as any other program that relies on the GPU to decode videos, including Davinci Resolve. We hope to see this fix go public as soon as possible and once again we thank you for your patience.

Hey @tony.topazlabs, thanks for the update!

Just for clarification, will this fix be situated within Intel’s driver itself, or will it require a patch to VEAI and other products?

I often run their beta drivers, so I’ll post an update when a newer driver is published and I’ve tested it. Thanks!

This is great news! I did notice they recognized Topaz VEAI in their “known issues” section of their last beta driver release notes. Thank you for letting us know. I’m excited to see what this program can really do with the Arc series!

@XBrav @gargamel314 Hello, we have a link to the latest beta driver for Intel ARC, please install this package and try it out, we are in contact with Intel about this issue and we will provide feedback based on user’s experiences: Intel® Arc™ & Iris® Xe Graphics - BETA - Windows*


Hey @tony.topazlabs,

Thanks for the update. With 4311, the issues are still present. When the model is loaded, VEAI appears to fall back to using the CPU without any errors shown. My Ryzen 9 3900x loads to a minimum of 50% load on the VEAI process delivering frames on Proteus at around 1.95 seconds per frame.

According to ARC’s overlays and Task Manager, there is no load on the ARC GPU.

Is there a lower level debug log I could generate to better isolate the issue for you?


This is the error in the main log that may provide some insight:

2023-04-19T16:23:09.609 [Debug ] Thread: 0x21991a61370 < line #: 0> Parameters: device = 0 2
2023-04-19T16:23:10.071 [Info ] Thread: 0x21991a61370 < line #: 0> check: "AMD Ryzen 9 3900X 12-Core Processor " Intel(R) Arc™ A770 Graphics false
2023-04-19T16:23:10.072 [Info ] Thread: 0x21991a61370 < line #: 0> check: “GNA_SW” Intel(R) Arc™ A770 Graphics false
2023-04-19T16:23:10.072 [Info ] Thread: 0x21991a61370 < line #: 0> check: “Intel(R) Arc™ A770 Graphics (dGPU)” Intel(R) Arc™ A770 Graphics true
2023-04-19T16:23:10.072 [Info ] Thread: 0x21991a61370 < line #: 0> OpenVino device string is GPU 0
2023-04-19T16:23:25.254 [Debug ] Thread: 0x21991a61370 < line #: 0> - Running CPU fallback because of this error [ cldnn program build failed! Incompatible OpenCL runtime: no binary section found. ]
2023-04-19T16:23:25.604 [Debug ] Thread: 0x21991a61370 < line #: 0> - Loaded with CPU

Hello, is the fix intended to be for Video AI 2.x or 3.x?
I couldn’t help but noticed it’s not working correctly on 2.x for @XBrav and I myself am still seeing plenty of issues when running version 3.2.2 and the 4311 beta driver from intel.

For me, the software is now stable enough that I can navigate inside of it and preview frames, but it’s still not stable enough to actually export a video.

Here are the issues I’ve experienced. Let me know if I need to spin off a new thread specific to the 3.x version of Video AI.

  1. Using my Arc A770 for AI acceleration was completely out of the question until I went into my BIOS and enabled my iGPU. I can confirm, it shows zero activity when processing a clip inside of VAI and the A770 does show usage, so it doesn’t appear the software is actually using the iGPU. But… having it there in the system does at least allow me to somewhat use VAI.

  2. Even with the latest beta driver from intel (4311), hardware decoding / encoding appears to still not be working correctly inside of VIA.
    a) I’ve noticed artifacts being introduced when trying to use AV1 (INTEL) as the encoder. Selecting another encoder results in the artifacts no longer being introduced into the resulting clip.
    b) Encode / decode seems to be entirely software. I think it’s just decode that’s being entirely handled via software, but I’m not sure how to verify this. I end up with 100% CPU usage, with ffmpeg.exe being the main culprit:

    You can see in the two screenshots above, CPU usage is absolutely pegged at 100%. The Arc A770 GPU is comparatively putting in very little work. The iGPU is putting in zero work, despite the fact that having it disabled in my BIOS cauises VIA to not work at all for me.
    Here is what the Arc GPU’s usage looks like in task manager:

  3. While I can run the built-in benchmark and even render previews, once an export runs longer than 5-15min, Topaz Video AI gives me an “Unknown error”:

  4. This might be unrelated to me having an Arc GPU, but I keep finding that if I leave VIA maximized and then alt tab and go back to it, it’ll suddenly expand to take up the entirety of my screen and therefore cover up the task bar. I’m really only mentioning this here because I’ve seen all kinds of odd behavior with the A770, such as snipping tool refusing to work at all once you’ve used it a handful of times & only working again once you reboot.

If it’s any help, here’s the benchmark results from my system, which also includes my system specs & what version of windows I am running:

Topaz Video AI  v3.2.2
System Information
OS: Windows v11.2009
CPU: Intel(R) Core(TM) i9-9900K CPU @ 3.60GHz  31.872 GB
GPU: Intel(R) Arc(TM) A770 Graphics  15.875 GB
GPU: Intel(R) UHD Graphics 630  0.125 GB
Processing Settings: device: 0 vram: 1 instances: 1
Input Resolution: 1920x1080
Benchmark Results
Artemis		1X: 7.43 fps 	2X: 3.54 fps 	4X: 1.07 fps 	
Proteus		1X: 5.97 fps 	2X: 2.93 fps 	4X: 0.92 fps 	
Gaia		1X: 4.90 fps 	2X: 3.26 fps 	4X: 2.38 fps 	
4X Slowmo		Apollo: 6.80 fps 	Chronos: 5.07 fps 	Chronos Fast: 8.41 fps 	

I can also share the log from a crash if needed, but I looked through a few of them and pretty much all I noticed was:

  1. No accelerated colorspace conversion found from yuv420p to rgb48le gets logged quite few times.
  2. This gets logged maybe 20-30 times at the start of an export
2023-04-20 10-41-00.932 Thread: 17480 Debug Open Called for file "C:/Users/Belle/Downloads/Wedding_prob3_temp.mp4" -1
2023-04-20 10-41-00.932 Thread: 11212 Debug Updating video info {"sar":0.8839506172839506,"framerate":29.97002997002997,"startNumber":1,"frames":123520,"progress":0,"status":2,"frame":109,"procStatus":{"status":2,"eta":9293.135574780132,"fps":13.278801957792895,"message":"Running...","pass":1,"error":"","progress":0,"frame":109,"priority":3,"requestPos":0,"processorIndex":0}}
2023-04-20 10-41-00.933 Thread: 17480 Critical Unable to open file "C:/Users/Belle/Downloads/Wedding_prob3_temp.mp4"
2023-04-20 10-41-00.933 Thread: 17480 Warning Unable to open reader at path: "C:/Users/Belle/Downloads/Wedding_prob3_temp.mp4"
2023-04-20 10-41-00.933 Thread: 17480 Info Trying to close the file "C:/Users/Belle/Downloads/Wedding_prob3_temp.mp4" false
2023-04-20 10-41-00.933 Thread: 11212 Info OUT: 2 frame= 109 fps= 12.4014

Then it seems to clear up and work fine for awhile, logging messages like this:
`2023-04-20 10-45-45.325 Thread: 11212 Info OUT: 2 frame= 3869 fps= 13.1846

And then after awhile of that running, it crashes:

2023-04-20 10-46-00.300 Thread: 11212 Info OUT: 2 frame= 4065 fps= 10.7157

2023-04-20 10-46-02.715 Thread: 11212 Info EXITED: 2 -1073741819 1
2023-04-20 10-46-02.715 Thread: 11212 Debug passProcDone 0 2 2 -1073741819 1
2023-04-20 10-46-02.716 Thread: 11212 Info Close and delete path "C:/Users/Belle/Downloads/Wedding_prob3_temp.mp4"
2023-04-20 10-46-02.717 Thread: 11212 Info ~TProcess(): destroyed
2023-04-20 10-46-49.366 Thread: 17480 Warning Unable to open empty filepath
2023-04-20 10-46-49.372 Thread: 11212 Info "C:/Program Files/Topaz Labs LLC/Topaz Video AI/ffmpeg" QList("-hide_banner", "-t", "1", "-i", "", "-c:v", "hevc_qsv", "-profile:v", "main10", "-preset", "medium", "-max_frame_size", "65534", "-pix_fmt", "p010le", "-c:a", "copy", "C:\\Users\\Belle\\AppData\\Local\\Temp/54264080/previews/_811763798_tvai.mp4") false
2023-04-20 10-46-49.375 Thread: 11212 Info ffmpeg started for audio CMD: C:/Program Files/Topaz Labs LLC/Topaz Video AI/ffmpeg -hide_banner -t 1 -i  -c:v hevc_qsv -profile:v main10 -preset medium -max_frame_size 65534 -pix_fmt p010le -c:a copy C:\Users\Belle\AppData\Local\Temp/54264080/previews/_811763798_tvai.mp4
2023-04-20 10-46-49.375 Thread: 11212 Info Trying to close the file "C:/Users/Belle/Downloads/Wedding.mp4" true
2023-04-20 10-46-49.375 Thread: 11212 Info Closing the file "C:/Users/Belle/Downloads/Wedding.mp4"
2023-04-20 10-46-49.375 Thread: 11212 Info Removing video "C:/Users/Belle/Downloads/Wedding.mp4" 0
2023-04-20 10-46-49.375 Thread: 11212 Info Cleanup directories C:\Users\Belle\AppData\Local\Temp/54264080/temp C:\Users\Belle\AppData\Local\Temp/54264080
2023-04-20 10-46-49.376 Thread: 17480 Warning Unable to open empty filepath
2023-04-20 10-46-49.378 Thread: 17480 Warning Unable to open empty filepath
2023-04-20 10-46-49.379 Thread: 11212 Info Cleanup directories C:\Users\Belle\AppData\Local\Temp/54264080/temp C:\Users\Belle\AppData\Local\Temp/54264080
2023-04-20 10-46-49.402 Thread: 11212 Info ~TProcess(): destroyed
2023-04-20 10-46-49.405 Thread: 11212 Info ~TProcess(): destroyed
2023-04-20 10-46-49.409 Thread: 11212 Info ~TProcess(): destroyed
2023-04-20 10-46-49.416 Thread: 11212 Info ~TProcess(): destroyed
2023-04-20 10-46-49.417 Thread: 11212 Info ~TProcess(): destroyed
2023-04-20 10-46-49.417 Thread: 11212 Warning QProcess: Destroyed while process ("C:\\Program Files\\Topaz Labs LLC\\Topaz Video AI\\ffmpeg") is still running.

It’s also worth noting that the logging process appears to be flawed / not quite working right for me. Even once the the export process is complete, the file remains open & locked inside of VAI. Even selecting the “get logs for support” option doesn’t work right - you get an archive that is empty except the list of encoders, and you can see an error in the current log file reporting that the log was locked inside VIA when it tried to create the archive. I had to exit out of VIA to get to the log.