TVAI 5.1.1 Stable - AION model "error": conversion don't start!

Hi Developers!

  1. BUG: if i select the new AION model for Frame Interpolation for slow motion, sometimes run correctly, but sometimes i get the “error” massage, and the conversion don’t start!

  2. My PC =
    CPU: AMD Ryzen 9 3900X
    GPU: Nvidia RTX 3070 FE (Studio Drivers: Latest 551.61 WHQL)
    Mobo: ASUS TUF GAMING B550-PLUS (BIOS v3404)
    RAM: 16x2 GB DDR4 3200Mhz Dual Channel
    SO: Windows 11 Pro - Build 22631.3155 (23H2)
    JakSpoon - DxDiag.txt (125.0 KB)

  3. My LOG files =
    JakSpoon - TVAI 420 (726.4 KB)

  4. Screenshot =

Please help me… thanks!

1 Like

FFMPEG Command =

ffmpeg “-hide_banner” “-t” “11.611600000000001” “-ss” “43.53” “-i” “C:/Users/JAK montaggio/Desktop/Need for Speed Hot Pursuit - E3 Reveal Trailer.mp4” “-sws_flags” “spline+accurate_rnd+full_chroma_int” “-color_trc” “1” “-colorspace” “1” “-color_primaries” “1” “-filter_complex” “tvai_fi=model=aion-1:slowmo=6:rdt=0.015:device=0:vram=1:instances=1,scale=out_color_matrix=bt709” “-c:v” “hevc_nvenc” “-profile:v” “main” “-pix_fmt” “yuv420p” “-b_ref_mode” “disabled” “-tag:v” “hvc1” “-g” “30” “-preset” “p7” “-tune” “hq” “-rc” “constqp” “-qp” “17” “-rc-lookahead” “20” “-spatial_aq” “1” “-aq-strength” “15” “-b:v” “0” “-map” “0:a” “-map_metadata:s:a:0” “0:s:a:0” “-c:a” “aac” “-ac” “2” “-b:a” “256k” “-map_metadata” “0” “-map_metadata:s:v” “0:s:v” “-movflags” “use_metadata_tags+write_colr” “-metadata” “videoai=Slowmo 600% using aion-1 replacing duplicate frames” “C:/Users/JAK montaggio/Desktop/Need for Speed Hot Pursuit - E3 Reveal Trailer_aion1.mp4”

I have the same issue. AION doesn’t work for me; error after a few seconds of work (export & preview)


Perfect… at least now I know I am not the only one! :rofl:

@kyle.topazlabs suggested I try to install the previous NVIDIA STUDIO drivers… version 551.23: I’ll let you know if I solve it!

Same issue, except I can generate previews, but it won’t process and export a video.

I have an AMD based system, with a rx6800 16gb RAM card. Apollo works flawlessly on the exact same video.



As already recommended by you, I downgraded to the NVIDIA STUDIO Drivers prior to the last ones that could cause problems (now I have version 551.23 WHQL), but the problem did not resolve (i just tried the latest BETA, and the problem persist);
here I show you the new “error message” that appears with the latest beta:

I attach as well the newer LOG for suppor for stable release with STUDIO Drivers 551.23: (363.0 KB)

At this point it is clear that these are not problems with Nvidia’s STUDIO drivers, since the other user also has the same problems even though he has an AMD GPU… it is clear that the problem is on “your side,” so let’s wait for it to be fixed soon, because for now this new AI model is unusable!


1 Like

In the latest logs I am seeing memory errors, try setting the max memory to 75% and run the clip again. The Aion model uses more vram than some of the older models.

1 Like

can you share the logs from these attempts?

If it’s OOM errors, that doesn’t make sense, because I can upscale a 360x2088 to 2700x2160 @60FPS and 2x slow mo, using apollo, with no problems. I can also upscale a 1924x1080 to 4k @60 FPS using gaia first and second enhancement. There’s something with AION itself.

I would like to point out that on certain videos, it works normally. On the first two that I tried, it didn’t work but only when I did an upscale at the same time. If I enable AION only, it works.

OS : Windows 11 Pro x64 23H2 Build 22631.3235
CPU : AMD Ryzen 7 5800X
RAM : 2x16 Gb DDR4-3200 Dual Channel
GPU : EVGA RTX 3070 XC3 ULTRA GAMING (08G-P5-3755) - Driver Game Ready 551.76

2024-03-09-10-10-6-Main.tzlog (300.5 KB)

1 Like

Maybe it’s the VRAM, we both have a 3070, but GPU-Z doesn’t have time to detect it, around 2300 MB used just before the error on this video. (same issue with “Max Memory %” at 40, 60 & 80)

1 Like

I just ran a test and here is the error shown in my log:

2024-03-10 11-37-30.610 Thread: 3764 Info OUT: 3 frame= 1821 fps= 1.07611

2024-03-10 11-37-32.954 Thread: 3764 Info OUT: 3

2024-03-10 11:37:32 22468 CRITICAL: Caught exception in tile processing thread and stopped it msg: Unknown exception1
2024-03-10 11-37-32.954 Thread: 3764 Info OUT: 3 OpenCV: terminate handler is called! The last OpenCV error is:

OpenCV(4.5.6) Error: Assertion failed (u->refcount == 0) in cv::StdMatAllocator::deallocate, file C:\Users\Gregory.conan2\p\b\opencb7b82bbe96ee7\b\src\modules\core\src\matrix.cpp, line 169

2024-03-10 11-37-43.324 Thread: 3764 Info EXITED: 3 -1073740791 1
2024-03-10 11-37-43.324 Thread: 3764 Info Going to delete path: “”
2024-03-10 11-37-43.324 Thread: 3764 Info Close and delete path “”
2024-03-10 11-37-43.324 Thread: 3764 Info Going to delete path: “I:\upscale\Upscaled/Imperial Age - The Legacy of Atlantis @Hard Club Porto 2018_Full-HD_aion1_ghq5_ghq5.mp4”
2024-03-10 11-37-43.324 Thread: 3764 Info Close and delete path “I:\upscale\Upscaled/Imperial Age - The Legacy of Atlantis @Hard Club Porto 2018_Full-HD_aion1_ghq5_ghq5.mp4”
2024-03-10 11-37-43.326 Thread: 3764 Info ~TProcess(): destroyed
2024-03-10 11-37-50.514 Thread: 3764 Warning Retrying to obtain clipboard.
2024-03-10 11-37-50.579 Thread: 3764 Warning Retrying to obtain clipboard.
2024-03-10 11-40-11.918 Thread: 3764 Info Logging files: 4
2024-03-10 11-40-11.923 Thread: 3764 Warning Showing in graphical shell: “C:\Users\Alexi\AppData\Roaming\Topaz Labs LLC\Topaz Video AI\logs\”

I monitored my video card stats and here’s the relevant info:

2024-03-10 11:37:32.509,99.000,1923.000,51.000,94.000,3011.000,14512.000
2024-03-10 11:37:33.511,99.000,2048.000,51.000,93.000,3019.000,14512.000
2024-03-10 11:37:34.511,16.000,501.000,43.000,59.000,3027.000,14512.000
2024-03-10 11:37:35.511,19.000,501.000,41.000,57.000,2990.000,14512.000
2024-03-10 11:37:36.512,7.000,79.000,40.000,57.000,2710.000,14512.000
2024-03-10 11:37:37.511,6.000,59.000,40.000,55.000,2528.000,14512.000
2024-03-10 11:37:38.510,7.000,52.000,39.000,56.000,2375.000,14512.000
2024-03-10 11:37:39.511,9.000,75.000,39.000,55.000,2253.000,14512.000
2024-03-10 11:37:40.510,13.000,97.000,39.000,55.000,2156.000,14512.000
2024-03-10 11:37:41.511,6.000,59.000,38.000,54.000,2070.000,14512.000
2024-03-10 11:37:42.510,21.000,498.000,37.000,49.000,1966.000,3655.000
2024-03-10 11:37:43.511,18.000,500.000,38.000,52.000,1863.000,3655.000
2024-03-10 11:37:44.513,16.000,500.000,37.000,49.000,1799.000,3655.000
2024-03-10 11:37:45.511,16.000,501.000,37.000,51.000,1738.000,3664.000
2024-03-10 11:37:46.513,2.000,28.000,37.000,50.000,1699.000,3782.000

It consistently used about 14GB VRAM, 16GB Total.

1 Like

Not only Nvidia and AMD but also Apple Silicon. Out of Memory errors on at least the “Ultra” variant of M1 and M2 chips even though there’s PLENTY of memory (64GB total / 48 GB VRAM) - while the model indeed does work on an M1 Pro with only 16GB total RAM - so much for "insufficient memory“…

Here’s the log from that failed attempt: (42.2 KB)

And here a screenshot of the allocated RAM:

(maybe the OOM error given by the app is false and it fails for another reason?)


Yea, something isn’t right. I tried a different file as a test, 720p, upcale to 4k, convert to 60FPS, proteus then gaia, stayed just below 12GB VRAM the entire time, took a bit over an hour to process, but it was fine in the end.

1 Like

I have to say that, after @kyle.topazlabs and @tony.topazlabs “advice”, I reduced the video memory usage from settings to 80% instead of 100%, and setting the program with this “limitation”, the ai AION model worked on my PC with RTX 3070: I hope this is only a “temporary” solution though, since we are not talking about a GPU with 6 GB RAM or less. … and the test was done on a “simple” YOUTUBE video downloaded to the PC at 720p resolution, so we’re talking about a really low resolution by now… and seeing memory saturation problems with such a video is indicative of some optimization issues, for sure!

I really hope that with the next stable version, the problem will be fixed!

1 Like

Aion requires 12GB+ of VRAM to run at 100% memory limit, this will probably not change in the current version of the model.

I have my memory at 30% and it’s still failing
2024-03-19-01-26-19-Main.tzlog (323.3 KB)

1 Like

if u dont mind can you upload the test file somewhere so i can also try? i have a 6800xt and aion works for mine at 100% memory limit
the only time it error was if i undervolted the gpu core too much.

I confirm that the problem is even more complex:
I did a complete formatting on my living room GAMING PC where I have mounted as CPU a Ryzen 7 7800X3D and an ASUS TUF RTX 4070 Ti SUPER with 16GB of VRAM… and after installing from scratch the latest stable version 4.2.1, and trying to slow down to 4x a YT video with AION, the conversion process stops after a few seconds!

I attach as always all the details:

CPU: AMD Ryzen 7 7800X3D
GPU: Nvidia ASUS TUF RTX 4070 Ti SUPER 16GB (Studio Drivers: Latest 551.86 WHQL)
RAM: 32 GB (16x2) DDR5 6000Mhz Dual Channel
SO: Windows 11 Pro - Build 22631.3296 (23H2)
JakSpoon 4060 Ti SUPER - DxDiag.txt (109.1 KB)

My LOG Files =
JakSpoon - 4070 Ti Super - (893.7 KB)

Original video =
DRAGON BALL: Sparking! ZERO - Gameplay Showcase [BUDOKAI TENKAICHI Series] (

Downloaded with 4K Video Downloader+
Specs: H264 1920x1080 60fps

1 Like