Topaz Photo AI v1.2.8

I don’t think so.i have tried on group photos of 31 members, and all faces were can deselect manually but cant select manually.

Every time I use the Photo AI filter, the button shows a momentary “Authenticating…” message before allowing me to click the button. I have two questions:

  1. Why does it seem to have to authenticate every single time? It seems like it should authenticate only perhaps at the start of the session. It causes a split second delay that impedes my workflow when I have to process multiple photos.
  2. Does this “Authenticating…” step require internet access? What happens if I’m offline?

Steps to reproduce issue:

  1. Click on latest Photo AI filter in Photoshop.
  2. You’ll see the “Authenticating…” message on the active button momentarily, during which I cannot click the button – requiring a 2nd or 3rd click, which interrupts my workflow.

Topaz Photo AI [v1.x.x] on [Windows/Mac]

Well, in offline mode, you will not be able to save your image. The save button will always be in “Authenticating” mode indefinitely. This is a new bug in this version 1.2.8. It means that you have to have an internet connection all the time otherwise the software is totally unusable. Which is a shame.


Unnecessary just give a solution to the user instead of trying to dramatize it as it is a known issue.

Remember people come here for a solution to their issue do they can keep working.

It is a known issue and all you can do until a fix arrives is to revert to v1.2.7, which can be downloaded from the release thread here:

Hopefully @adam.mains will have a solution in a flash in the next version.

1 Like

See the post above this with a link to download v1.2.7

I have same problem .in offline and online which is a shaaame.

Trivial thing but can I have the option to save as .jpg rather than .jpeg as the latter means I have to rename every file or have issues when sorting directories by the extension (to split Raws and JPGs).


I didn’t mean to be dramatic if that’s what you thought. Maybe a mistake when I translated from French to English. I just wanted to say that there was a new bug related to the network and that it was a too bad for those who don’t have a connection and can’t use the software.

In short, sometimes the translator does not always translate certain words well or accentuates the desired effect in a sometimes negative way lol.


why when I have put an image through and it states it has only de noised then I save it says de noise and sharpen… ??? also now after this I edit via my MacBook the image goes blurred when scrolled back to it through my photos… ??? help please

Topaz is frozen in Authenticating. It is on line.

1 Like

Interim solution is in the posts above, revert to v1.2.7 while the issue is looked at.

Hi - thanks for the new update. I get quite bad artifacts after sharpening on the sharpest parts of the image (wood structures and metal).
Thanks for checking!


Cannot install on 2023 M2 Mac Mini, Ventura 13.2.1, 500/16.

Screenshot 2023-03-27 at 11.51.40 AM

I’ve had grief with Topaz on this computer before and of course it’s the best computer in the house and the one that I really need for running Topaz software.

I also updated Photoshop and Bridge just before this with no issue. PAI 1.2.7 fails as well.

Topaz apps run fine on my 2013 i7 MacBook Air (ouch) and 2020 M1 MacBook Pro.

Log details:

Mar 27 11:54:31 EMini Installer[818]: Failed to load specified background image
Mar 27 11:54:31 EMini Installer[818]: Failed to load specified background image
Mar 27 11:54:32 EMini Installer[818]: Could not load resource readme: (null)
Mar 27 11:54:36 EMini Installer[818]: PUKApplicationCloser: Plugins in to kill: (
Mar 27 11:54:36 EMini Installer[818]: PUKApplicationCloser: Done updateOpenAppsAndPlugIns!
Mar 27 11:54:36 EMini Installer[818]: PUKApplicationCloser: Alert did end with code: -1
Mar 27 11:54:39 EMini installd[596]: PackageKit: ----- Begin install -----
Mar 27 11:54:39 EMini installd[596]: PackageKit: Install Failed: Error Domain=PKInstallErrorDomain Code=110 "An error occurred while extracting files from the package “TopazPhotoAI-1.2.8.pkg”.

Photography is one of the most dramatic arts. I have no problem with the dramatic description of events. It is better to raise your tolerance threshold a little higher. It seems that you feel obligated to give everyone the answer, or maybe you think that you are too smart or know everything.

I can’t save the image after editing it in Photo AI. I get a message saying "Cannot save image, unknown error. I’ve completely uninstalled, deleted the plug-in from the Lightroom Classic appdata folder & reinstalled. My subscription expired on March 5th but it was my understanding I would be able to continue the use the software, just wouldn’t get updates.
Photo AI 1.2.8, Windows 11

2023-03-27-19-44-47.tzlog (177.4 KB)
2023-03-27-19-46-59.tzlog (65.5 KB)
2023-03-27-19-48-29.tzlog (1.7 MB)
2023-03-27-19-36-38.tzlog (945.3 KB)

DxDiag.txt (94.1 KB)

File → Plug-In Extras → Process with Topaz Photo AI method. Also get the same error when opening directly into Photo AI. When using the edit in method the edited file thats gets saved back to Lightroom Classic has no edits from Photo AI applied.

What has that got to do with what you were asking, I didn’t reply to you because you were one post below the solution to your issue.

Note that, unfortunately, people don’t take time to search for the issue that is why we have to provide a solution (the same) on a written reply to most.

It has nothing to do with photography … it’s best if you keep your comments to yourself because you haven’t added at all to the conversation about the issue you are experiencing which is the same as as others are.

This is a personal reply to correct your ignorance …

I certainly don’t know everything but I do give answers to help people who need a solution to issues they are facing.

As for your dramatic statement …

Photography is one of the most dramatic arts.

Why would you need software to modify your photographs if they are art? Isn’t the AI software the artist and NOT you? If it was such an art to you you would only photograph in JPEG because you wouldn’t need to modify your art.

1 Like

Overall Topaz it’s working really good and doing it’s job. I have only one issue I really have to announce.

In my case, it’s not crashing, however, the face recovering it’s being a big issue.