Topaz Photo AI v1.2.7

My trust has been shaken, that’s for sure. And so many tech companies do things until they are told they can’t. And look at all the other “AI” companies out there, they never asked for permission to use our images or text for training (GPTChat, Midjourney, etc).

And honestly, the fact that we are paying to essentially beta test their new software is not cool, either.

1 Like

Crowd funded product design !

This is about Photo AI 1.2.7.
I loaded an image that was 750x375 px and specified an exact output size of 720x360 (720 was entered, 360 was defaulted since the ratio was locked). The output size of the corrected image, however, did not change–it was still 750x375. I updated this morning from 1.2.4 and the behavior is new–I use this scaling function many times a day every day and it has always produced an output image that was within 2px of the specified dimension.

I tried it by specifying a 0.9 ratio in the S box (to generate a 675px width) and the results were the same, no scaling of output image. I also tried it by changing the filename and results were the same.

Steps to reproduce issue:

  1. Open original image.
  2. Use all autopilot settings, except enter the desired width as 720px.
  3. Once preview is complete, click the Save Image buttons. The Queue information message says the image is being output at the new size.
  4. Output is generated at wrong width of 750px.

I believe it has something to do with the autopilot feature. If I override any of the settings (noise, sharpen, faces or resolution) it generates the proper output width. It appears scaling is not properly overriding the autopilot for the output size.

I have uploaded various images so you can see the settings used, plus the log. I cannot upload the actual input image as it is a WEBP image. That has never caused a problem before.
SettingsScreen shows the settings I used specifying 720px
QueueMessage shows the program saying it will output to 720px
OutputImage is the actual output at 750px.
ImageSizeCheck is another program reporting the image at 750px.
Log File

2023-03-18-08-52-40.tzlog (1.5 MB)

Topaz Photo AI [v1.2.7] on [Windows]

What about Gamin when they release their new watch? They sell to few retailers first, hopefully user find bugs, before they sell it to the mass a month later?

I dont mind, it makes the product even better. At least Topaz is listening to cuz feedbacks. Others like DJI, etc. they dont listen!

Is the test the same thing? For the DNG, you have to get out of the container, pass it to Photo AI, etc. So ACR has its own color profile, Photo AI has its own color profile. To me, lens correction and color correction are not the same for every manuf. They varied widely.

No idea what you are on about, DNG was not used anywhere. All 4 process I have used in my 3 posts to this forum, have the ability to each process the original CR2 and decode the data. Each of the four was used in its " auto " settings allowing the process to show the native function of that process.

It is quite obvious that you are having issue with something , but I can not fathom it from your post. Adobe ACR has many selectable profiles for the conversion , however I do not use them as I have found that their colour is not accurate or enjoyable. I therefore used software to analyse the output of a colour checker image and build my own custom profile for ACR, that is specific to my camera and lens used. I build these custom profiles all the way to final print, to offer as accurate a rendition as possible.

Topaz’s profile for a decoded RAW image is built in by the writer of the software, and baked into the resultant file. “User” profiles are not available , sadly , as then we could all render to our own intent.

If you are suggesting using DNG as the output and then rendering that in PS, then I suggest that this means that Topaz AI is not a standalone software, but always a plugin requiring either to receive the file from Photoshop plugin or from a DNG for a second bite at the cake. Not a lot of use for the many users that want to pay £200 or so for a standalone processor.

Topaz has a vibrant community of volunteer beta testers.

These user forums have a purpose, and yes, non beta testers can come in here looking for help, to give advice, etc. And yes, the devs seem open to ideas.

But PAI was released as a paid product in 09/22, and it quickly became apparent that it was an obvious beta product. It had not, and Topaz admitted as much, reached Version 1 ready release features. Nor had it reached anywhere near the level of output quality that a release product should have. It still doesn’t match the the output quality of the 3 programs they sell that it is supposed to replace.

PAI is obviously being actively developed, not just squashing the occasional bug or adding new features, with paying users to make the product into what it should have been on release day. And could have been done with the existing community of beta testers.


I just updated Photo AI from version 1.2.4 to 1.2.7. (Recent versions of) Photo AI sharpening feature is too strong and the scaling is ineffective.
I am working on wildlife (mostly bird) pictures with mostly strong raw noise. The sharpness is good with some unsharpness/softness in less important areas. The application activates sharpness and artifacts are showing in places that hardly need sharpening (plumage).
As usual I try Standard, Lens Blur and Motion Blur. When I drag Strength and or Clarity to the extreme left ( 1 ) the artifacts are not noticeably better. I’m sure it is a question of scaling. Currently the only option is to refine the selection, which is a bit time consuming.
Can’t those typical artifacts be detected by AI and automatically avoided?
Thank you for the good work;
Best regards,
Thierry Hoornaert

Make sure you provide examples so the devs can see it here …

Like many have noticed face recovery sometimes creates part of glasses when the original has no glasses. I also noticed than upon recovey of a low quality pictues of a face with glasses the recovery fixes the glasses so the left and right side are not even. The left part has a different shape than the right part. It would be nice that the recovery would me more consious about both sides to create an even image.

1 Like

I am working with old low-resolution photos, and have run into an issue several times where the background looks great, except for a giant square around the subject.

In this example, where I blurred the face, I drew a rectangle around the portion where the background is blurred. The flowers on on the outside of the rectangle are nice and shape, the trees in the upper background are clear, but then on the inside of the rectange the tree and flowers are noticeably blurry. It is very strange looking at the photo to see this rectangle blurry area behind the subject, with sharp lines and objects just outside of it.

Steps to reproduce issue:

These are my settings:

Topaz Photo AI [v1.2.7] on [Windows]

Thierry, sometimes I wonder if the argument over “auto” sharpen, is because of the huge difference in the sensor rendition of cameras. If I look at the requirement in sharpening and post processing between for example the Canon 5D and the Canon 5DSR , there is a vast change. The 5DSR uses a lower aliasing filter over the sensor and was paralleled by the 5DS in case users were worried about moire. How you deal with this in post is basically to drop , or heavily reduce the degree of sharpening used. I am not sure how PAI deals with this, but perhaps a "global " control in prefs might allow all users to tune their copy to match the sensor used. I find that the noise reduction slider for detail can be responsible for the "over sharpened " look.

I upgraded to the newer version in the middle of my work project, and it would not process my photo. How do I get it to work? I checked all my system requirements for my Nividia GTX 1080 V 526.98 with more than enough RAM, but it still does not work.
Thanks for any assistance you can provide.

If you’re in the middle of a project, why don’t you roll back to the prior working version to complete the project. Uninstall this version & re-install the version you were previously using.

When you complete the project then you can try again with 1.2.7 & then provide your system details - including OS & if all drivers are up-to-date - and specify what you do and what exactly happens with this version. With more details, someone may be able to help you troubleshoot.

I am having very similar color shifts in the latest version, as well.

Hope this screen shot of pre (left image) & post (right image) PhotoAI shows the color shift. I just updated to the latest version & have not been able to generate a useable image so far without the color shift. Until this update I’ve been very pleased with the results.

Topaz Photo AI version 1.2.7 / Photoshop 24.2.0 / macOS Ventura version 13.2


It may have to do with your raw file type. I tried both using a jpg and a Sony ARW (raw) photo and both showed no color shift. Each had similar color tone as your photo. I’m using a different OS, Windows 11. RX 5600XT GPU.


Sony raw file:

Yeah, your’s look fine. The file I used on my image was an OOC .jpg from an Olympus but I also tried a raw ORF file & it had a similar color shift. Mine looked OK in Photo AI but the saved version shifted color when I opened the file in Photoshop.

Here’s a new image screenshot from Photo AI:

The colors haven’t shifted.

Here’s a screenshot of the OOC .jpg & the Photo AI saved .jpg in Photoshop:

I get the color shift when I open the Photo AI modified file in PS.

At this point I’ll probably reinstall Photo AI when I get a chance & see if that makes a difference. Other suggestions welcome!

(post deleted by author)

So, now I’m a bit confused. I just ran a test using the Photoshop plug-in & there is no color shift. I can only assume there is something going on with the Color Profiles. I work in ProPhoto RGB & follow the same “Convert to Working RGB” workflow in Photoshop with all files. Maybe it has something to do with converting a saved Photo AI file to ProPhoto RGB. No problems converting .jpg or raw ORF (Olympus) or NEF (Nikon) files.