Topaz Photo AI v1.2.0


This week brings some exciting new upscaling models as well as lots of fixes! There is a new High Fidelity model for Enhance which excels at minimizing artifacts for high quality and high resolution images. We’ve also replaced the Natural model with a new Standard model. The Standard model excels at natural textures and should avoid blocky results from previous Natural model versions.

Cropping is still in beta and has several fixes. We are working towards changing how the crop is applied for next week hopefully and will be adding straightening at a later date. Expect crops with straightening applied to not rotate in the app until straightening is implemented.

Please give us any feedback or report issues with this release. We’ll be updating TPAI regularly to address those pieces of feedback and issue reports. If there’s a specific image you’d like us to see, you can send it us at this dropbox link.

Released February 2, 2023
Mac: Download
Windows: Download

Changes since 1.1.9:

  • Added new High Fidelity upscaling model
  • Added new Standard upscaling model which replaces the old Natural model
  • Added ability to crop in plugin modes that support resizing
  • Remove open images and show images in finder/explorer while in plugin mode
  • Cropping on import via metadata now handles CropArea tag
  • Automatically try to correct cases where crop size is knowably incorrect
  • Updated app icons
  • Updated upscaling Autopilot models
  • Update lens correction files
  • Fixed HEIC files being incorrectly oriented
  • Fixed Standard Sharpen clarity slider not doing anything
  • Fixed crash when combining crop and masking
  • Fixed alpha channel not being oriented the same as the image
  • Fixed CLI not accepting directories as arguments
  • Fixed edges of original image showing behind preview on images with transparency
  • Fixed RAW images having incorrect size due to order of lens correction and metadata cropping
  • Fixed issue where Autopilot values were incorrectly cached between cropped and non-cropped images
  • Fixed crash when re-entering cropping after refining the mask
  • Fixed Olympus Stylus 1 and 1s camera profile mappings
  • Fixed some images with unsupported lens correction data showing wrong image after cropping

Known Issues:

  • In rare cases it’s possible that an image gets saved twice as two different outputs while batch exporting. We are investigating the cause.

Along with this week’s Photo AI update, we’re also beginning to reorganize much of this forum. Going forward, Photo AI will have its own category on our forum’s home page. It will be split into the following subcategories: Releases, Roadmap, Ideas, and General. Video AI will also have these same changes, and we will be posting this same message on the Video AI releases thread along with the next update.

Hereon out, we will encourage all our users to filter their discussions and questions appropriately within each of the above mentioned categories. This organization should make it much easier for our team to navigate through your questions, comments, and concerns about Photo AI – as well as making it much easier for you to find relevant threads and existing discussions that might answer any queries you may have. We know this may take a bit of time for users to get adjusted to, so we appreciate any help directing discussion and politely spreading the word about these changes and to other users who may not be aware of this yet over the coming weeks.

Each of these new subcategories will have an ‘About’ page that explains what their intended purpose is, but we can also try to answer any initial concerns or questions here. This reorganization is something that will likely change over time as we learn what does and does not work, so keep in mind that how things currently look may not remain so in the future.


Thank you!
Finally, the new Standard and HF models from GAI 6.3 came to Photo AI! :slight_smile:

I love running my 20+ year-old 1-megapixel images through Topaz apps!

I’m really impressed by the latest Standard model. Below we see the different models on different images.

I also notice the app seems much faster, even on older hardware (Mac). I can smoothly app-switch during processing, which was not always the case before


HI .
Sharpening is still the issue, even at I strength, plus if I select half the portion it still sharpen the whole. I have uploaded same file under Bee crw to YAZI, to check . no reply yet.

1 Like

Hi Jayesh - the bee image has already been shared with the research engineers. Improving the slider (strength) responsiveness is something we’re working on when updating the models. As for the bee getting fully sharpened even when selecting a portion of it, we cannot internally reproduce this. Can you please help send us a recording showing this issue when masking a portion of the subject and only having the Sharpen filter enabled? You can send the recording through: Dropbox. Thank you.

Is it possible to give the control over new rescaling models parameters to the user, like it’s in GAI 6.3? :slightly_smiling_face:

It would be great to be able to control sharpness, denoising and, most importantly, “Fix compression” slider. I noticed even GAI (the last GAI I can use for now) is still way better with “new high fidelity and standard model”, for example, removes JPEG artifacts in a much better manner, and it can be under further control by the user.

Sometimes, while switching types of view, this version of PAI can still crash (I switched from single to side-by-side view)

Great new release. How do you enable the The “High Fidelity” upscaling model?

1 Like

Ah, ok. I found it.

Photo AI working well.
Only one annoying problem if I export several photos from Lightroom Classic all goes through photo AI ok but in return to Lightroom the 3rd image ends up at the end of row and colours are all out. Resend the photo back again and returns fine.
Regards Allan

1 Like

There’s a slightly red tinted box extending around the bounds of heads while using face enhance. Would prefer not to share the original image


1.2.0 standalone app, windows 11, most recent nvidia studio driver and a 4090

Overall v1.2 is working well except I was using it and suddenly it started only showing the original view. Nothing I did could make it show a updated preview (see picture 1). Closing the picture and loading another one did show an updated preview until I moved the image at which time it would only show the original view.
Picture 1:

The standard sharpen model was much better at enhancing background detail than the other two.

I have just updated AI and every time I launch it inside PS as a filter - PS crashes and closes.
Any advise please?

New Issue: Raw Remove Noise leaves artifacts on clear sky.

Raw Remove Noise =off:

Raw Remove Noise =On:

Denoise removes all detail in some images and slider does nothing. Denoise AI works perfectly on these images. I noticed this in the previous release as well.


I have tried the new version on several of my ARW raw files and it cashes after cropping. It seems to be related to when sharpening is applied but I’m not sure.

I am still having an issue with a row of colours across the top of the image after processing. I have chosen a particularly bad image here so that I could show the issue. I know you are aware of it but it is really annoying.

1 Like

Hi Yazi,
Thanks for the reply, My process is, open image, autopilot will detect subject, I will refine subject by subtracting back portion, autopilot has detected the image need to sharpen, ,I have select sharpen subject only as I intended, it still sharpen the whole Bee, your research team got the raw file they can fallow my steps.Well I tried with standalone sharpen Ai and it did as I intended , I will be sending another image which created pink marks in sky.

I have tried 4 times to install the new version of Topaz Photo (ver 1.2.0). After a long process of installing the product, I got the message that there is no internet connection and the process finished. My internet connection is ok. Does anyone have the same issue? I am using a PC with Windows 10 installed. Any help will be appreciated.

Bad grammar: Should be “Must be run”

Screenshot 2023-02-03 at 4.39.03 PM


I have same problem. nearly in all previous version . I have uploaded file to their dropbox.