Topaz Photo AI v1.1.7


This week’s update is focused around one big new feature we’ve been working on: Cropping. This feature is considered in “open beta” starting with this week’s release, as there are still quite a few improvements we want to deliver in the following weeks. In the meantime, we’d love to hear your feedback on the feature and the direction you’d like to see us take it in!

Please give us any feedback or report issues with this release. We’ll be updating TPAI regularly to address those pieces of feedback and issue reports. If there’s a specific image you’d like us to see, you can send it us at this dropbox link.

Released January 12, 2023
Mac: Download
Windows: Download

Changes since 1.1.6:

  • Added Cropping feature (public beta)
  • Added “About” dialog
  • Fixed horizontal scrolling/dragging not working on file list
  • Fixed applying settings to all taking a long time
  • Fixed some images showing wrong dimensions in resize panel

In case you didn’t see it last week, we have a new quarterly roadmap available! It’s a great place to voice your feedback not directly related to this specific update:


Win 11 Pro Desktop PC. Processor = Auto (AMD RX6800 XT, Intel i0 12th gen)

Downloaded/installed quickly.


  • In UI processing speed keeps improving - feels fast - :+1:t3:
  • New Crop function worked - used on Custom (initially it was retaining orig. image aspect ratio by default and it worked that way too).
  • Resized to diff. upscales as desired - no saves while in the UI
  • Used AI Brush with blue overlay - adjusted opacity of the overlay okay - used diff. size designation brushes to select objects for sharpen only.
  • Still baited breath for a manual Masking Brush w/previously requested attributes. The user & other likes for the wished for feature set is now up to 20.
  • Still thrown by the rippling appearance (don’t know if it’s pixel shifts) when moving the vertical dividing line in the Split View view mode. It’s very distracting & tough to tell from Before/After side of that split line how improved the image is when it’s “moving” like that. Hope that can be fixed at some pt.

Ps 2023 Plugin:

  • Installed during installer run - shows up in Ps Filter menu
  • Can open into PAI UI from Ps layer stack, process image, return to Ps layer stack - working with a .tif image
  • Not seeing a pixel hop on the returned layer in this rel. - :+1:t3:
  • Tried the new Crop feature (assuming it wouldn’t work in Ps, but hey) & got the helpful pop-up msg that it’s disabled in Ps


:+1: this is the one I have been reporting as well

1 Like

Apply settings to all works great, thanks for the fix!

1 Like

getting a ghost face after cropping this raw image

When I change the output size to 2x or 4x the preview jumps forward (large) and backward (small again) sometimes and remains in that zoom level until I click onto the current enlargement 2x or 4x again to be seen here at 1:35 and 3:15 when I select max.:

opened up a jpeg image, no crop box appears.

Can recreate. It’s not jpeg specific, RAW images are the same.
Workaround: change aspect ratio to another option and back to original again. Afterwards it keeps working for other images. Needs to be done once every launch of TPAI.
Another workaround: move your mouse to the top left and look around until it becomes a resize arrow > now click and drag. The crop box was there, but really (really) invisibly tiny.

Hi! It’d be great if you can send me the original image through: Dropbox. Please let me know if you’ve sent something. Thank you!

Hi - can you please send me your log file from the same timestamp of any failure session from Help > Open Log Folder? Thank you!

Though I have little interest in the crop function as I mostly use the plugin in Photoshop, I should have thought that being able to rotate during the crop ( allow a double headed arrow when over the corner ) would allow horizons etc to be corrected whilst cropping. To crop without this correction is removing the extra pixels that would allow this to be done later . After tens of versions releases , and a download record of 137 Windows to 34 Apple , why is it this software ignores the now basic Windows function of screen division control. … Sharpen AI and Noise AI all allowed for these !


Found a faster workaround by the way; simply clicking the “reset” button.

Hi Yazi Saradest,

I installed the latest version of Topaz Photo AI version 1.1.7.

Speed is very good.

Interface better (more data displayed).

But still does not detect picture orientation and can not apply a size limitation.

I mean as explained to your team in the past, suppose I set Max size to 2400 px, if it is the width that is the max input size, the 2400 px width is applied and the height is computed accordingly. If it is the height that is the max input, the 2400 px height is applied and the width is computed accordingly.

Kind regards.


1 Like

What system are you using? Mac, PC.

I’m on Win 11 & it worked okay for me. Saw grid. Able to select diff. crop aspect ratios. Crop applies when accepted okay.

Installed on Win 11 OK but C1 was open and although the installer asked for programs to be closed it didn’t register the fact that C1 was the problem in the dialogue box.

Running 1.1.7. When I try to take a *.dng from LRC to Photo AI via File>Plug In Extras>Process with Topaz Photo AI I’m presented a new dialog box asking if I want to edit the original or a copy. Selecting either will launch Photo AI and give an error message saying that DNG’s are not supported.

Am I missing something? Any suggestions?

when face recovery is enabled some images get lilac/orange coloring. in addition, the faces have a sharp square or an unclear part.

Was out of town and missed three updates, so I just installed them. Because PS crashed after install, which has happened before, I deleted and reinstalled the plug-in in the PS 2023 plugin folder. This time it didn’t work; when I open a pic in PS and try to edit with PAI it starts to open, then I get a message saying “plugin crashed”. The plug-in works just fine in LRC. Log folder attached. TIA.
2023-01-14-14-42-34.tzlog (11.1 KB)

My Topaz Photo AI is version v1.1.4. Today I tried to install the updates, but the process stops at 137MB into the download and pops up a message the installation failed. May not be a valid Windows installer. Have tried twice with the same results. System is Windows 11.

Stanley - Did you use the Win installer that is at the top of this discussion thread? If not, perhaps you might try it.

The shortcut to the top of the thread is the Home key.

I’m assuming you have a current PAI update “subscription” and meet all the tech specs on your system.