Topaz Photo AI v1.1.7

Did you, by any chance, have Ps open when you ran the installs? I know I did that once and had to redo the install. And, I’ve been using/testing these products for many yrs. I’m sure you already know (& probably run a ton of other software too…), but Ps must be closed for install. It seems you’ve had ongoing issues for quite a while.

Can you please please please add File Compression to TAI asap, Gigapixel has it. I convert to beyond 4x a lot so I need it.

By using autopilot settings on more than 15 jpgs with less than 1 MB in one go, the jpg-thumbnail in the Finder after that shows one and the same picture of one of them. I tried it several times

Well, good point. As you know, the installer offers to shut down both LRC and PS as it’s doing the install. I always click “OK” and assume they have indeed shut both down. I tried totally removing PAI manually, shutting down both programs and then re-installing and it now works. I’m not sure if the problem was that it tried to install three updates at once, or if the installer doesn’t actually shut down PS when it says it’s going to…but one of those things appears to be the problem.

1 Like


i played a lot with many kinds of pictures, for me the best solution if you have old analog photos scanned with 300-600dpi and use 2x upscale + very-compressed are very good ! :slight_smile:
also if you have slightly unsharp/blure HQ pictures, it works also fine.
best option to upscale very good and sharp HQ pictures is to blure them before ore only blure all without the faces (gaussian~0.8), to make the noise ore the (too sharp pixels) next the face al little smoother for the conversion …


I just wish we could have a decent brush selection tool, it’s not a lot to ask surely?

1 Like

I am getting this pink in the background. Any ideas?
This is before saving…shows up on the Photo AI side… If I save the
photo back to lightroom this pink goes with it.

When I use Topaz as a Lightroom Plugin Topaz does not carry the star rating back to Lightroom. This makes it very difficult to find the photo. I always rate my photos before doing any edits, if Topaz does not carry the rating back to Lightroom, the photo basically does not show up in Lightroom when Topaz returns me to my catalog.

I have the same problem. This is caused by the denoising module when it is automatically set to standard. If denoising is switched off or switched to Strong, then the pink artifacts have disappeared.

I’ve found (on my PC) not only do I have to shut Ps down before running an install, but I do a Restart (reboot) before running the install. Even when I’ve checked Task Mgr (b4 doing a reboot post Ps shutdown) and ensured Ps wasn’t running, the Topaz product installers still thought my Ps was running. The synapses in the installer’s “mind” would not connect the already shutdown dots. So now I do those extra (should be unnecessary) steps to be on the safe side & avoid further hassles…

Nice to have a cropping function and I know we’re in beta-mode, but it would be great if there were reciprocal aspect ratio choices in the drop list (e.g., both 3:4 and 4:3) plus a means of rotating an image. Also, when you use a custom ratio, it would be most helpful if there were an indication of what it is as your re-sizing it (for example, DxO PhotoLab displays the current pixels and AR:1, such as “5,450 x 7,267 px (0.75)”). It would also be great if you could save custom ARs to the drop list (e.g., 6x7/7x6 for certain medium format bodies).

1 Like

Yes, it’s nice that more features are added.
But from my point of view, all reported bugs should be fixed first!
And unfortunately there are plenty of them.
I have opened various tickets and am put off to later versions.
It is regrettable that in between some errors were fixed and now reappear.
For example, once again the camera profile of my Canon Powershot GX7 II is not used.

  1. Upscale
    Need a magnifying lens to read Input and output sizes in MB. Make a larger font.
    And why do the sizes show up as negative (-) MB?

  2. Output
    The line following “Output” makes it look like it is a slider. Change it so it does not look like a slider.

  3. Under Output, what does the “S” mean?

  4. Multiply out the W and H megapixels so that we don’t have to do this math.


Probably related to needing a magnifying glass to read it, but it’s not a - but a ~ (tilde) to indicate it’s an approximation. The font is indeed a bit small.

It’s in front of the scaling factor, so I’m assuming “Scale”.

1 Like

Even with a magnifying lens I can’t be sure what symbol that is. Font needs to be changed.

Not sure why they even need the S and the x number next to it. The scaling factor used has a blue box in front of it.

It’s all about human factors engineering and minimizing confusion.

1 Like

Is there an easy way to just save single photos (the one being displayed) when using TAI and working on multiple? I’ll sometimes process a few, but only want to save 1. The default option is “Save all photos”… A more readily visible “Save Photo” next to that would be nice to have. I’ve been having to close all the background ones instead (or save all)

Thanks for the crop feature.
I could crop with Photo AI as a stand alone app. I could not crop in either Lightroom Classic 12.1 or Photoshop v24.1.

Win 11 Pro desktop PC. Processor = Auto. Working with Ps 2023 Plugin of PAI 1.1.7.

Hadn’t yet tried a monochrome (BW) image with this release. Test image shot in color, converted to BW in Ps adjustment layer.

Just tried PAI with one of my street photography shots. It sharpened to a level needed. Didn’t pixel hop back on the layer. May have done a hint of denoising (since this was shot through a car windshield). It’s like one of those ‘can you find it’ puzzles - there are 3 guys working on the awning …

1 Like

just installed latest update & Topaz Photo AI 1.1.7 now locks and hangs on the 13th or 14th image. Settings are Nikon RAW files camera Z9. Strong Raw Noise, Normal Sharpen, face is off. trying to save 176 images to DNG file with same settings. Fails each time & on both my machines. Never had this hang before like this.

Make sure you send the log files to support, see the Help menu.