Topaz Ai "unable to save photo" after today's software update

[Please describe your issue here. Try to include logs (Help → Logging) and add screenshots if necessary.]

Using Apple Photos 8.0 on an iMac running OSX Ventura 13.3.1 (both up to date). When processing the photo in the Topaz AI window and the window closes the save option in the remaining Photos window gives the message “unable to save changes”

Steps to reproduce issue:

  1. Step 1 Closed both apps
  2. Step 2 Reopened Photos and was able to save some additional photos. But the error kept getting worse.
  3. Step 3

Topaz Photo AI [v1.x.x] on [Windows/Mac]

I forgot to mention that I shoot raw images on a Nikon D7500. I do not know how to generate log files for Topaz Ai.

If you select Help, Open Log Folder they will be there. Either ZIP them up and upload here or upload the individual files: (126.6 KB)
Thank you for the help. Here is the zip file of the logs.

The issue happened again several times earlier and one of them we able to be saved after the initial failure. The difference was that after it failed, I tried again but after I adjusted the crop of the image (I straightened it slightly). When I tried again out of stubbornness it was able to save as normal. I don’t know if that is helpful or not.

Does this happen with all images or only some images? Does the location of the image affect whether it processes or not?

Please follow the instructions in this video to send me the crashpad zip (Mac). I can share this with my team so we can hopefully fix this.

Only some. Depending on the day, 1 in 10 or 4-5 in 10. It seems random. I’ll try to get that crash file. I uploaded the log file already if that is what you were referring to. (1.4 KB)

I see that it is a different file. Thanks. Here is the compressed crashpad folder.

Thanks for sending this. I will bring up this crash with my team at our meeting tomorrow.

I looked through all the logs you sent and there were no crashes in there so I will rely on the crashpad to figure it out.

The app did not crash. It simply said the changes could not be saved. But went on to function as normal except in some cases where it again just failed to save the changes. So I am not sure how that would appear in a log or in crashpad.
Thanks for your help. Please let me know what other information you need from me.

I had this occur yesterday with a group photos I imported into Apple Photos. Earlier imports still saving normally. Went and shot some more and imported those and they saved after being enhanced by Topaz normally. I then tried to treat the non-able-to save-after-Topaz through finder and avoiding the import to Apple photos, and the program behaved normally; I was able to save them. Thinking maybe there was glitch in the import process to Apple Photos on that one group, I imported the images from finder again and they still wouldn’t save the Topaz enhancements. I’m shooting RAW on a z9 and can see no difference in the size or properties of the photos that aren’t able to be saved with enhancement from hose that are. This was difficult to explain, sorry if confusing.

Thanks for your input turbosax. With my photos they are all being worked on by Topaz as a plugin to Apple Photos. And this happens for me on new and old photos shot from several different cameras. So for me at least, it does not appear to be related to recent vs. old images/imports. I feel like it is a glitch in either Photos or Topaz. But since Topaz gives the message and is unable to complete the saving process, my feeling is it is within Topaz.

This sounds like a different issue. Are you seeing any error message appear? If you are, please send a screenshot.

I notified our plugin developer about this issue. So far, it looks like the error is from when Topaz Photo AI sends the image back to Apple Photos. I made a task for them to investigate this.

If you process the image again, do you have the same issue or does it work the second time?

Thanks for the help. The screenshot is in my first post up top. If I try to reprocess it after the initial fail, the problem persists no matter ho many times I try. The only time I was able to get it to get it to finish sending it back to apple after a failure was when I closed it, then edited the image in apple photos before reopening it in Topaz AI. After which point it was successful.

No, it is the same issue. A random photo taken with my Nikon z9 has the “unable to save” in Apple photos no matter how it is imported, whether from the card or from Finder. I was able to use the same photo in Finder, process it through Topaz, and not get the “unable to save”. So for whatever reason there is something about the photo that Apple Photos won’t save it, but Finder has no problems saving it.

Just had it happen today to a group of photos from a 30 fps burst (the last one of the session) from a walk in a park today. All of hundreds of photos taken before that can be loaded into apple Photos, processed through Topaz and can be saved to Apple photos. All settings the same.

That’s correct, this seems to be an issue with Apple Photos that the developer needs to debug. He will start working on it next week I believe.

1 Like

For now a workaround seems to be that if you make even the slightest edit in Apple Photos before trying to use the plugin for Topaz AI, then I don’t run into the problem. It just sucks when you forget to edit first, then do a bunch of refining of a subject and it doesn’t save. But at least there seems to be a workaround at the moment.

1 Like