Topaz Ai "unable to save photo" after today's software update

Odd…I have never been able to open Topaz as a plug-in in Apple Photos if any -even the slightest- edits have been done in Apple Photos. I’ve just accepted that as a limitation.

The separate “unable to save” issue occurred to all of the photos taken in a session this morning. I haven’t have the issue popup in the last week or so.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Are you still having this issue with crashing? If you are, please resend me the logs next time you crash.

You can securely submit your files to my Dropbox using the link below.
Dropbox File Request

Thank you so much, this works for me. I was having this problem too

Will this be fixed? This is a pretty big problem. The workaround of making an edit first doesn’t work because it will send a jpeg to topaz rather than the raw file.

Is this a problem that the folks at Topaz AI can fix or does it need to be from Apple? If from Apple do you know an appropriate way to send Apple to bug information?
Thank You For Your Help

I just purchased Topaz Ai today and have been frustrated by this issue whereby I get the “Unable to Save Photo” error when using the plugin with Apple Photos. Some photos save others don’t. Is this bug still being worked on? I’m glad I have 30 days to get my money back if it’s not fixed. Is see reference to a solution in this chain, but am unable to see what the solution is. Thanks in advance for your help.

Please take a screen recording of this behavior so I can see exactly what is happening. Loom is a great free application for this: Download the Loom Desktop App | Loom

After today’s update, using Topaz Photo Ai plugin in Apple Photo will not allow saving the changes into the iPhoto Library.

Yeah, it is even more buggy now. Sometimes editing in photos first, then opening the topaz plugin works, (though it is no longer editing in raw mode), other times I need to quit photos and reopen it just to get it to work even with the .jpeg file. The raw is still not saving as per the origin of this post, however, the frequency of this error is now much higher. !00% of my newly imported images will not save from raw editing. All of the equipment and software is the same as before. This is very frustrating. Topaz is a fairly expensive app. I wish it would work reliably. Not that I am blaming the developers specifically, It may be Apple’s fault. Al l I know is my Topaz Photo AI is almost useless to me.

Please schedule a screenshare with me from the link below. Make sure you have Zoom meetings installed.
Schedule a screenshare appointment

I can gather some information to check what the issue is.

Hello Lingyu,
I have a 16:00 EST Zoom appointment with you. I became available earlier and can have the meeting any time you like. Feel free to call me at 732-618-4748 if you would like to set up an earlier time. Or I will just check my email regularly if that is better for you. If not, I will see you at !6:00.
Be Well, Jason Ksepka

1 Like

Hello Lingyu,
My name is Jason Ksepka. I am relatively new to Topaz Photos AI. I am excited about Topaz Photo AI 2 coming out today. But I am wondering if I could get a discount since I only purchased TP AI 1 on 4/19/23. I love the software, but the price is a bit steep for me right now as I just got back to work after two years. Having an additional upgrade so soon is not what I had planned on.
Thank You, Be Well, Jason

Please ignore my previous email. The website promted me to sign in and produced a much better discount. Thank You, Be Well, Jason

1 Like