Sharpen AI v3.3

For those experiencing issues please supply the details of your technical environment. The best way is to open the application then select Graphics info from the Help menu. Press Copy on the dialog and paste the info in your post.

Not sure what has happened in 3.3.1 but there has been a dramatic change in the sharpening performance for all modules. At this stage the edge that Topaz had over sharpening alternatives has diminished. I need to fall back to the previous version, how can I do this?

Just select the version you you want from the Product Releases category on this forum and download from the first post in the category.

I’m not sure what has happened but NO Topaz software will run on my Mac Mini. Nothing, as far as I know, has changed recently except the recent security updates for Apple. I’m running Catalina ver 10.15.

Topaz begins, and just simply exits. I’ve deleted all Topaz software, rebooted, and even tried downloading the Trial software. All with the same results?

Any suggestions… I’m not having any other issues with any other software. This is just specific to anything from Topaz ???

Same problem here. In fact it appears to reduce the resolution of the image. I’ve rolled back to the previous version - thank goodness it’s working again!

We can no longer adjust Remove Blur and Suppress Noise for each model independently. Please bring this back. I would often make individual adjustments in order to choose the best result. Also, as it is now, when a change is made the user has to wait until all models update instead of just the model of interest.

1 Like

Regarding this update (updated to 3.3.1 yesterday 11/14/2021):

When attempting to batch process, if Sharpen Model is set to Auto, the software hangs on the second image every time. The progress bar continues to move back and forth to the right and left with the second image never actually being processed. The first image is processed normally.

I attempted to manually load each image in the batch (by clicking on each down the list) so that the software could “pre-set” the Model Parameters prior to starting the batch processing. This made no difference in the behavior.

If the Sharpen Model is set manually to Too Soft - Normal, for example, processing proceeds as expected. (In this processing, the Sharpen Model was set to “Too Soft - Normal”, the Model Parameters were set to “Auto” and Select was set to “Off”.)

1 Like

iMac, OS 10.14.6, 4ghz Intel i7, 32GB Ram, Radeon R9-4GB:
Sharpen AI 3.3.1

  1. Makes photo blurrier not sharper.
  2. Slow as molasses.
  3. Nearly locks up the iMac…makes doing anything else when Sharpen is running impossible.
  4. A downgrade, not an upgrade.
  5. Nope, not a beta tester.
1 Like

Exactly the same problem as everyone else, just got home from a days photography to process photos asked to update to 3.3.1 so did… and trying several photos this update makes them worse… originals look better even though they have slight noise. not happy considering the cost and only been using a couple of months… anyone know how to revert back on a mac?

1 Like

Hi, same on my Windows 10 machine with similar HW setup. This release is a disaster, no longer works. Need to go back to 3.2 which was slow like hell but at least it sharpens…

1 Like

I have had Denoise, Gigapixel and Video Ai since the end of August this year. Other programs seem to be fine with GP and SH used the most. GP has never had a problem but Sharpen keeps crashing and it is now a problem.
Did all of the due diligence in settings (CPU, Card, Low Med etc.) Doesn’t matter what they are it still crashes. Did a system recovery and the program worked great, in fact incredibly for a couple weeks. Started crashing again, then tried to get away with using a previously created restore point just after the system recovery, worked but not as well now back to crashing again. Very tired of this.
So, do you believe it is the new PC or the software?

Application & Version: Topaz Sharpen AI Version 3.3.1
Operating System: Windows 10 Version 2009
Graphics Hardware: NVIDIA GeForce RTX 3060/PCIe/SSE2
OpenGL Driver: 3.3.0 NVIDIA 471.41
CPU RAM: 16150 MB
Video RAM: 12288 MB
Preview Limit: 8000 Pixels

Tried uninstalling and using the new update but still same result.

Hi, seems like you running on a buggy GPU driver.

Change to the latest Studio Driver.

https://www.nvidia.com/Download/driverResults.aspx/183577/en-us

Decided to upgrade Sharpen and Gigapixel.
OUCH!!! That was big mistake. Now I see that problem has been here over 7 days now and still no fix??!!
Cmon?!

1 Like

I have the same problem with a Dell XPS15 (Windows11) and my work computer AMD Ryzen 9 5950X with GeForce RTX 3090 (Windows10). Batch processing is essential for me.

Same problem with my Imac.
Things are getting not beter. Please make the upgrade offline!

Since the 3.3.1 update, I’ve lost preview response when changing from the fully automatic SAI choice. If I change to any other setting, the preview reverts to the original non-sharpened state and stays there. I too disabled the GPU option and got the previews back. Alas, MUCH slower, so not a solution. Mac Mojave 10.14.6 using a Radeon RX 580 8 GB GPU, and have 32 GB RAM.

I totally agree, this version seems like a sizeable step backwards. The “Motion Blur - Very Blurry” did just that, made the subject super blurry, like some sort of sick joke. Other features seem like very very subtle (or unnoticeable) or very strong/too strong. It seems there’s no in between and no fine tuned tweaking or control. I couldn’t believe this was even released. I noticed it’s a bit faster, so I guess I’ll try CPU. Strongly considering going back to the last version as well, if possible.

CPU does seem better.

2 Likes

Just select the version you you want from the Product Releases category on this forum and download from the first post in the category.

How is there still not one acknowledgement about all the issues above, no fixes given, no eta’s. just fellow users suggesting to revert to an older version (thank you to those by the way) but nothing from Topaz themselves. thanks for taking our money, you’re welcome…