Sharpen AI v3.3

v3.3.3
Released November 30th, 2021

Windows: Online | Full
Mac: Online | Full

Fixes

  • Fixed various image quality issues on older hardware
  • Fixed auto model parameters not being set correctly
  • Fixed auto model remaining on when the preview panel opens in comparison view
  • Fixed comparison view frames not storing/loading model parameters
  • Fixed comparison view frames not using their own settings when generating the preview
  • Fixed auto model being ignored during batch processing when comparison view is active
  • Fixed expired license dialog appearing for users with a license that’s expired after 3.3.0 released
  • Fixed all models list sometimes incorrectly showing the top model as selected
  • Fixed crash when using edge aware to refine a mask
  • Fixed various display issues when downloading models from the manager
  • Fixed downloading models when generating a preview causing progress bar to go above 100%
  • Fixed error when needing to download models while processing images
  • Fixed a permission error on Windows about writing some preference files
  • Fixed external editors opening in standalone mode
  • Fixed view selector being enabled in masking mode

We’ll also be releasing a new update to every model soon which should solve several image quality issues, including the image shifting slightly, and causing halos.

v3.3.2
Released November 19th, 2021

Windows: Online | Full
Mac: Online | Full

Fixes

  • Fixed issue where preview sometimes doesn’t update correctly
  • Fixed quality issue where output is blurrier than original (and several other image quality issues)
  • Fixed app requiring admin on Windows
  • Fixed in-app updater

Known issues

  • Edge-aware brush is currently crashing. We’ll release a fix for this shortly
  • Comparison view sometimes sticks to a single model in certain cases. Change view modes to work around this.

v3.3.1
Released November 10th, 2021

Windows: Online | Full
Mac: Online | Full

Fixes

  • Fixed users not being automatically logged in after upgrading their app
  • Fixed an innocuous error message appearing on mac during install

v3.3.0
Released November 10th, 2021

Windows: Online | Full
Mac: Online | Full

Major Changes

  • New model selector
  • New preferences panel
  • New model management system
  • New auto mask models (and removed the old one)
  • New “Select” section in side panel
  • New interface for masking mode
  • The offline installer for windows no longer needs a legacy version
  • New update feed dialog

Changes

  • You can now open images while in mask mode
  • Generating mask previews no longer blocks the UI, instead shows spinners
  • App startup is slightly faster
  • Disabled escape and enter hotkeys in plugin/external mode while a dialog is open
  • Includes new main toolbar design from DeNoise
  • The suggested model is now the “Very Blurry” variant on large images
  • Removed decimals from overlay opacity slider
  • Minor graphical fixes/improvements
  • Swapped brush hardness for brush softness
  • Disabled selecting, adding, and removing images buttons while processing
  • Updated text for when auto params haven’t been determined yet

Fixes

  • Fixed AI Processor sometimes reverting to “Auto”
  • Fixed undo/redo not re-generating the mask preview when AUP is off
  • Fixed mask opacity scroll-based shortcut not working properly on mac
  • Fixed opening images sometimes using the previous image’s auto model/params
  • Fixed several instances of comparison view not disabling auto model
  • Fix startup dialogs replacing other dialogs - now they appear on top
  • Fixed the masking brush outer circle showing the softness rather than the sample area when edge aware is on
  • Fixed dragging images into Sharpen while in masking mode would appear as if the mask was now being applied to the new image
3 Likes

I am using the Motion Blur and am seeing no difference in my images even when applying Remove Blur at 100%. When I apply Very Blurry all it does is blur my images. Motion Blur has been my mode of choice from precise sharpening and it simply is not working.

5 Likes

The more I use the other options, the more the entire Sharpening program seems to be non-functional.

4 Likes

same here. It actually BLURS the image rather than sharpen.

5 Likes

again, same here. This sucks. Going from moderately sharpened original to BLURRY is the opposite of what I want. I should have waited. I hate being a beta tester.

1 Like

I have about two days before I will be in desperate need of the fix. I haven’t seen any information about reverting back to an older version.

6 Likes

The 3.2 version is here: Sharpen AI v3.2 - Product Releases / Sharpen AI - Topaz Discussion Forum (topazlabs.com)

4 Likes

I have found that using GPU and Motion Blur - Very Blurry actually blurs my images more. It’s the kind of blur when you scale down an image 25% and then blow it back up 400% with Bilinear. The other models don’t really have much effect one way or another under GPU, regardless of Remove Blur settings, whether you set to 0 or 100. (Too Soft - Very Blurry works a little.)

Switching to CPU works better, though more slowly. But again, the Remove Blur amount makes no difference, it’s the same no matter what number you dial in.

I will have to fall back to the previous version, if I can figure out how.

3 Likes

Thank you! I’m back up and running.

I think this release is a step backwards. I tried the previous version, 3.2.2, right on a photo right before installing 3.3.0, and noted that the Focus method added significant color noise to the image in 3.3.0, which was not evident in the previous version. The same is true for Too Soft, but to a lesser degree. I’m disappointed; I normally expect a newer version to be better than the previous one.

2 Likes

Hi Kevin. We’re sorry to hear about this issue. Would you mind sharing with us an example? We’ll need the original image, the processed one, and a screenshot of the right-hand menu settings used in the software with the same image. You can securely submit the files through:

Once you’ve sent the images, please make sure you send us an email on https://support.topazlabs.com/ to let us know you’ve sent something and for us to follow up with you.

Thank you,

Hi Mark. I’m sorry to hear you’re also running into this issue. Can you please share with us the same information I asked Kevin for? I’ll need:

-The original image
-The processed one
-A screenshot of the right-hand menu settings used in the software with the same image. You can securely submit the files through:

After doing that, please send us an email on https://support.topazlabs.com/ to let us know you’ve sent something and for us to follow up with you.

Hi Greg - we’re collecting information about this issue. Can I please ask you for the same information I asked for above? We’ll need an example that includes:

-The original image
-The processed image
-A screenshot of the right-hand menu settings used in the software with the same image. You can securely submit the files through:

Once you’ve sent the files, please make sure you send us an email on https://support.topazlabs.com/ to let us know you’ve sent something and for us to follow up with you. Thank you!

As a note, you can find the previous versions of the software on: https://community.topazlabs.com/c/releases/sharpen-ai

1 Like

Hi! Can you please share with us the example image? Please send us:

-The original image
-The processed image
-A screenshot of the right-hand menu settings used in the software with the same image. You can securely submit the files through:

Once you’ve sent the files, please make sure you send us an email on https://support.topazlabs.com/ to let us know you’ve sent something and for us to follow up with you. Thank you!

The masking Auto-Select is still not good enough on landscape images …

Has the Halo problem been resolved in this version?

1 Like

Same issue here. (I thought I mentioned it during beta testing!)
This is using SAI as a plug-in with PhotoRaw 2022 on an older MacBook Pro running OS Monterey

2021-11-11-07-45-4-Main.txt (113.4 KB)

Has anyone else noticed that the preview screen is useless in this version? Everything looks worse than the original raw file from lightroom or photoshop, once it’s processed that too even looks different than what is in the preview window.

What’s up with that??

3 Likes