Sharpen AI v3.3

Yes, I agree and have rolled back my installation to version 3.2.2, which works as designed and provides beautiful sharpening for my images. It’s highly unfortunately that Topaz has released such defective updates as versions 3.3.x. I sincerely hope they can get this product back on track quickly and can improve their testing and release processes to prevent such missteps in the future. They have wasted hours of my time because of these quality issues.

1 Like

I am getting excellent results with v3.3.2, although it runs very slowly on my older MacBook Pro (OS Monterey).
However, two glitches (that might be due to RAM issues):

  1. Auto mode switches itself off after a few seconds when batch processing
  2. In comparison view, all results look the same to my eye.
    Is anyone else experiencing this?

Hi Ray - Yes, your glitch #2 is exactly what I was seeing, sometimes, with releases 3.3.x. The processed image snippet in the comparison display either looked identical to the unprocessed image, regardless of the parameter settings, or it looked worse (blurrier) than the unprocessed snippet. It’s possible that this defect only affects the comparison display, not the final processed image - but even if so, that defect makes the product nearly useless; there’s no useful way to determine the optimal sharpening parameters if you can’t see their results in the comparison display. I reverted to version 3.2.2, which works fine, as has every earlier version I have previously had. I won’t waste more of my time upgrading this product until Topaz actually fixes it. -Jim

2 Likes

Where can I download v 3.2.2 from? I am currently running that version via upgrades, but I don’t have a copy on my PC. I would like to have it before I upgrade to the new version in case I have a problem. The Sharpen AI download page only has the latest version.Thanks.

Under the Sharpen AI v3.2 in the Product Release category.

A post was merged into an existing topic: Sharpen AI v3.2

I have the same problem. I used versions 2.2.1 and 3.1.2 which are much better, whereas 3.3.2 turned out even more blury as the original. Do you want the original jpg and the processed tiffs, or do screenshots suffice.
Thanks Edu

Purchased and ran stand-alone app yesterday. Worked great. Tried to run via Affinity Photo plugin and stalled on white screen with Topaz Sharpen logo at top left corner with spinning ring. Now standalone will not work either with same “spinning ring” as it tries to load to no avail. Thinking it’s something in the registry. Clean re-install of app and same thing whether stand-alone or plug-in. Please help as soon as possible. Thank you in advance!

OS Name Microsoft Windows 10 Home
Version 10.0.19042 Build 19042
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Name DESKTOP-F6U12EK
System Manufacturer Dell Inc.
System Model G7 7790
System Type x64-based PC
System SKU 08EC
Processor Intel® Core™ i7-9750H CPU @ 2.60GHz, 2592 Mhz, 6 Core(s), 12 Logical Processor(s)

NVDA GeForce RTX 2060 Driver: 462.31

Sharpen AI 3.3.2 Will not save multiple files when “Select All” is selected.

4 Photos I am sharpening

  1. Select All
  2. Apply
  3. Reverts back to the Preview
  4. 3 photo left
  5. Apply
  6. Revert back to the Preview
  7. 2 photo left
  8. Apply again

Repeats this back and forth until all 4 images are saved.

Exactly the same. I can’t see no more sharpening or improvement. I suppose it’s an error. I reinstalled the software second time, it worked once. After that, the images are the same. If I open a new image in Auto mode, it blures it.

1 Like

There seem to be some serious issues in the current sharpen. Most of my wildlife images change colours as shown in the attached screenshot. Does not matter where I use Sharpen from…LR or PS. Since I get a message that I cannot post images here, there is no attached screenshot!

1 Like

I’ve recently updated it to 3.3.2 from some older version and I struggle to get quality pictures from auto settings. It seems like it always picks up the sharpening at 30 and noise reduction at 10 - no matter what photo, and always Too Soft - Very blurry.

Like there is no auto setting, just default. This is annoying because the previous version I had was very good at this.

Until this is fixed I have two questions:

  • is there a way to say what version I had before? Any log or version history on a local PC?
  • how to get the older version installed, so I don’t use the broken update.
3 Likes

I have the same problem/observation.

2 Likes

Mikey & David, You can roll back to the previous release version to see if that works better. You can find several generations of releases (for Win & Mac) at the top of this Product Releases discussion thread.

v3.3.3
Released November 30th, 2021

Windows: Online | Full
Mac: Online | Full

Fixes

  • Fixed various image quality issues on older hardware
  • Fixed auto model parameters not being set correctly
  • Fixed auto model remaining on when the preview panel opens in comparison view
  • Fixed comparison view frames not storing/loading model parameters
  • Fixed comparison view frames not using their own settings when generating the preview
  • Fixed auto model being ignored during batch processing when comparison view is active
  • Fixed expired license dialog appearing for users with a license that’s expired after 3.3.0 released
  • Fixed all models list sometimes incorrectly showing the top model as selected
  • Fixed crash when using edge aware to refine a mask
  • Fixed various display issues when downloading models from the manager
  • Fixed downloading models when generating a preview causing progress bar to go above 100%
  • Fixed error when needing to download models while processing images
  • Fixed a permission error on Windows about writing some preference files
  • Fixed external editors opening in standalone mode
  • Fixed view selector being enabled in masking mode

We’ll also be releasing a new update to every model soon which should solve several image quality issues, including the image shifting slightly, and causing halos.

4 Likes

:grin: finaly.

5 Likes

Do you have your software set to record logs or is it turned off (under the Help menu in Topaz products)? If it is turned on you should have logs recorded in the Program Data > Topaz Labs LLC > [software name] > Logs folder

Hi Anthony,

Happy post-Thanksgiving!

I just downloaded/installed the full Win installer for 3.3.3 (w/out uninstalling 3.3.1). When I launched it, this is what I saw. Trial mode. I thought the changelog said this was remedied… anyway, FYI in case there’s something else that can be tweaked to avoid this for fully subscribed active users…

Also, I did my usual thing & launched the standalone vers. before attempting to run the Ps plugin. No matter what I do, there is no way I can change the upper left quadrant (in Comparison View) to a different model that I want to show up there (I wanted to make it Motion Blur - Normal). It is impossible to change it. It stays fixed on what you can see in this snip. There seems to be a bug in general in the upper left quadrant in Comparison View (consistently across releases of product in case there’s some way to troubleshoot code there).

Also, when I tried to manually sharpen some of the views (in Comparison View) b/c I was underwhelmed with the sharpening, the yellow “switch” next to “Model Parameters” kept flipping to on/yellow while I was adjusting the sliders. Should it be doing that?. I don’t remember those on/off switches moving in the past unless I’d turn them on to run Auto functions.

1 Like

Great news!

@anthony.lawn

3.3.2 does not check for updates on startup.

Also the manual search in the app brings no result, it thinks it is up to date.

2 Likes