Sharpen AI v3.3

Do you think that such system differences may affect SAI output? I do not think so. But if it does, I will never go for newer version of SAI and likely other Topaz apps.

Windows 11 is still quite young and still causes problems.

For example, I may not use it until May.

Direct ML is part of Windows, maybe it brings something if you turn off the model download.

Thanks, does the same occur in other imaging apps (from Adobe, DxO, On1, etc)? BTW, the model download is another reason that makes me unlikely to update…

https://helpx.adobe.com/download-install/kb/windows-11.html#known-issues

Thanks, not really anything similar to artifacts or halos, ha? I’m monitoring Photoshop forum at Adobe, and all Windows 11 complains I’ve seen were about the decreased performance and problems with setting up color profiles (on some systems only and for the very first Windows 11 release). It appears that Windows 11 became a de facto standard for new computers (e.g. Dell, HP).

Version 3.3.2 claims to fix a “quality issue where output is blurrier than original (and several other image quality issues)”. THIS IS NOT TRUE!! I just installed version 3.3.2 because that issue was making version 3.3.1 totally useless to me, and version 3.3.2 is NOT ANY BETTER THAN 3.3.1! Please get this fixed immediately - and please actually test your “fixes” before releasing them!

2 Likes

Concur with jdp3az: no difference between performance of 3.3.1 and 3.3.2. Neither works at all.
I have backtracked to 3.2.2, which didn’t cry out for such a dramatic overhaul.

2 Likes

Yes, I agree and have rolled back my installation to version 3.2.2, which works as designed and provides beautiful sharpening for my images. It’s highly unfortunately that Topaz has released such defective updates as versions 3.3.x. I sincerely hope they can get this product back on track quickly and can improve their testing and release processes to prevent such missteps in the future. They have wasted hours of my time because of these quality issues.

1 Like

I am getting excellent results with v3.3.2, although it runs very slowly on my older MacBook Pro (OS Monterey).
However, two glitches (that might be due to RAM issues):

  1. Auto mode switches itself off after a few seconds when batch processing
  2. In comparison view, all results look the same to my eye.
    Is anyone else experiencing this?

Hi Ray - Yes, your glitch #2 is exactly what I was seeing, sometimes, with releases 3.3.x. The processed image snippet in the comparison display either looked identical to the unprocessed image, regardless of the parameter settings, or it looked worse (blurrier) than the unprocessed snippet. It’s possible that this defect only affects the comparison display, not the final processed image - but even if so, that defect makes the product nearly useless; there’s no useful way to determine the optimal sharpening parameters if you can’t see their results in the comparison display. I reverted to version 3.2.2, which works fine, as has every earlier version I have previously had. I won’t waste more of my time upgrading this product until Topaz actually fixes it. -Jim

2 Likes

Where can I download v 3.2.2 from? I am currently running that version via upgrades, but I don’t have a copy on my PC. I would like to have it before I upgrade to the new version in case I have a problem. The Sharpen AI download page only has the latest version.Thanks.

Under the Sharpen AI v3.2 in the Product Release category.

A post was merged into an existing topic: Sharpen AI v3.2

I have the same problem. I used versions 2.2.1 and 3.1.2 which are much better, whereas 3.3.2 turned out even more blury as the original. Do you want the original jpg and the processed tiffs, or do screenshots suffice.
Thanks Edu

Purchased and ran stand-alone app yesterday. Worked great. Tried to run via Affinity Photo plugin and stalled on white screen with Topaz Sharpen logo at top left corner with spinning ring. Now standalone will not work either with same “spinning ring” as it tries to load to no avail. Thinking it’s something in the registry. Clean re-install of app and same thing whether stand-alone or plug-in. Please help as soon as possible. Thank you in advance!

OS Name Microsoft Windows 10 Home
Version 10.0.19042 Build 19042
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Name DESKTOP-F6U12EK
System Manufacturer Dell Inc.
System Model G7 7790
System Type x64-based PC
System SKU 08EC
Processor Intel® Core™ i7-9750H CPU @ 2.60GHz, 2592 Mhz, 6 Core(s), 12 Logical Processor(s)

NVDA GeForce RTX 2060 Driver: 462.31

Sharpen AI 3.3.2 Will not save multiple files when “Select All” is selected.

4 Photos I am sharpening

  1. Select All
  2. Apply
  3. Reverts back to the Preview
  4. 3 photo left
  5. Apply
  6. Revert back to the Preview
  7. 2 photo left
  8. Apply again

Repeats this back and forth until all 4 images are saved.

Exactly the same. I can’t see no more sharpening or improvement. I suppose it’s an error. I reinstalled the software second time, it worked once. After that, the images are the same. If I open a new image in Auto mode, it blures it.

There seem to be some serious issues in the current sharpen. Most of my wildlife images change colours as shown in the attached screenshot. Does not matter where I use Sharpen from…LR or PS. Since I get a message that I cannot post images here, there is no attached screenshot!

I’ve recently updated it to 3.3.2 from some older version and I struggle to get quality pictures from auto settings. It seems like it always picks up the sharpening at 30 and noise reduction at 10 - no matter what photo, and always Too Soft - Very blurry.

Like there is no auto setting, just default. This is annoying because the previous version I had was very good at this.

Until this is fixed I have two questions:

  • is there a way to say what version I had before? Any log or version history on a local PC?
  • how to get the older version installed, so I don’t use the broken update.

I have the same problem/observation.

1 Like