Sharpen AI - botched v2 installation

This is 3rd out of 4 Topaz products I have with similar issues. My confidence in Topaz lessens with every release… Said that.

  • I downloaded TopazSharpenAI-Online-Installer.exe from new release e-mail link.
  • I run installation as standard user and selected all components, allowing UAC elevation when asked.
  • After installation completed, I selected Run now.
  • Registered
  • SAI started and reported a new version is available
    -> First issue - the online installer installed 2.0.1, while 2.0.2 was already available
  • I completed 2nd installation (upgrade), allowing UAC elevation when asked - 1.2 GB of data downloaded again.
  • After installation completed, I selected Run now.
  • Registered
    -> Why did I need to register again???
  • Closed.
  • I start SAI as a standard user, and it is on version 2.0.1!
    -> Why did only admin version get updated?
  • I get prompt that update is available
    -> I have no way to upgrade to v2.0.2, as I have plugins installed, so another installation would just reinstall v2.0.2 for Admnistrator

I agree that Topaz devs seem to be not able to get the hang of Windows standard user installation procedure. Since they use the new installer users report the same problems over and over again.

It should be easy for them to fix these issues: it’s just a Windows registry thing. When you install as an admin (or with UAC) the needed registry keys are created only for the admin user, not for standard users.

Steps to fix this yourself (on Windows):

  1. Run the application with your normal standard user account
    If there was no application icon created on the desktop of this user you can launch the app directly from the install folder: c:\Program Files\Topaz Labs LLC\Topaz Sharpen AI\Topaz Sharpen AI.exe

  2. Quit the application
    Now most of the needed registry keys should have been created for your standard user account

  3. Now you have to modify the registry as described for Denoise AI 2 in this thread.
    It’s the same procedure for all Topaz products that use the new installer.
    Attention: it’s always a good idea to make a backup of the registry first!
    Open the registry editor by clicking the windows start menu button and type: regedit and hit enter.
    For Sharpen AI 2 you have to add/modify the registry keys “DataPath” and “InstallPath” in the branch
    [HKEY_CURRENT_USER\Software\Topaz Labs LLC\Topaz Sharpen AI]


    Check if DataPath has the value C:\ProgramData\Topaz Labs LLC\Topaz Sharpen AI
    Check if InstallPath has the value C:/Program Files/Topaz Labs LLC/Topaz Sharpen AI
    (note the different slashes: DataPath wants backslashes, InstallPath wants forward slashes)
    Finally check for the key “tgrcFolderLocation” in the branch
    [HKEY_CURRENT_USER\Software\Topaz Labs LLC\Topaz Sharpen AI\appMain] - it should have the value “/tgrc” (without the quotes).
    Now close the registry editor.

Alternative for those that don’t want to mess with the registry editor:
Instead of applying the changes manually you can copy & paste the following code to notepad and save it with reg extension (for example name the file topaz-sharpen-fix.reg):

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Topaz Labs LLC\Topaz Sharpen AI]
"InstallPath"="C:/Program Files/Topaz Labs LLC/Topaz Sharpen AI"
"DataPath"="C:\\ProgramData\\Topaz Labs LLC\\Topaz Sharpen AI"

[HKEY_CURRENT_USER\Software\Topaz Labs LLC\Topaz Sharpen AI\appMain]
"tgrcFolderLocation"="/tgrc"

After you saved the file to a folder of your choice (or your desktop) you just need to double click the file to apply the needed changes.

When you start Sharpen AI now, it should work normally.

Hope it helps.

Trying to install the latest updates after receiving an email from Topaz this morning has driven me crazy.
The update instruction was that the update would have two components - an update to my current version and a separate of a new version with selective adjustments including a masking feature.
I was told there would now be two version and there would be essentially two programs. After messing around for some considerable time I finally managed to install version 2.02 and I now have one aplication incorporating ver: 1.46 and the new, which is listed as ver: 2.02 this latter version does incorporate selective adjustment and masking.
Not sure from the comments already made in previous posts whether thereis a separate problems for Windows users as I am on an imac running Catalina OS.

It actually said it would leave the old version alone and install the new version - which is exactly what it’s done. From the email:

" Please note the previous version of Sharpen AI will still be installed on your computer, so you will see two versions of Sharpen AI on your machine after installing the new version. The choice is yours to remove the old version or leave it on your machine."

Thanks Paul for your reply - I did remove the previous version as I could not see any purpose in retaining it and new version is working fine.
Thanks for your assistance.

I am having this exact issue! Are we supposed to delete the older version or uninstall it? I cannot find any post or instruction that clarifies this. I hesitate to remove the older version entirely as I don’t yet know how that will affect Studio 2 or LR functions. As a standalone Sharpen AI 2.02 works. But I can’t figure out how to get it to run in LR or Studio 2. Systems keep reverting back to 1.46 whenever Sharpen AI is invoked from those platforms. In another thread someone said that when they installed it they were prompted to delete the older version. I run on a Mac system and never received that prompt or any clarification beyond being told this was a separate version of the software.

Hi Tom

The update message did say you could retain the older 1.46 version and just install the 2.0 version - it was entirely your choice.As the new feature version included all I required in the earlier version I deleted it as I am a bit of a clean sweep merchant. I do now however have some problems as the new version does not appear as a plugin in either Lightroom or Photoshop Elements 2020.Daresay I will get some assistance from the internet re this problem although it is not the end of the world for myself.

Thank you for the reply. I’m a great photographer - not always so great with the post processing tech. :wink: I have likewise noticed that the new version does not seem integrated with LR and Studio 2 so I guess for the time being I will keep both versions and hope that Topaz sorts this out. Maybe I’m just a voice in the wilderness crying out, but I cannot fathom why they keep releasing “updates” that require this many steps to integrate into your work flow. Seems to me it would not be so hard to update a program that is ready at install to fit right in where the previous versions existed and replace them. But as I have mentioned, I am not a super tech savvy guy.

Much like myself with the processing - I work at it but when it gets too much I just haven’t got the patience or am prepared to spare the time. It is annoying when you have to search the internet looking for answers when the update should have installed and picked up the plugins as previously. Maybe someone at Topaz will take pity on us and provide a solution.

This is a problem in the installer framework itself. If you are a non-admin user, the executable is made so that you do not (and should not) run it with UAC. I’ve contacted the installer framework support, and they have provided no way around this. If you install as an admin on a non-admin account, the installer sees HKCU as the admin, and thus writes stuff there. It would also try to install to the admin account’s documents in the case of Studio. I designed the installer to (hopefully) work around this by moving the install to AppData for non-admins and putting the photoshop plugin step into a separate UAC backed executable.

Long story short (unless I’m missing something), if you are a non-admin you should not run the installer as admin, except for when the photoshop plugin phase shows up. Ideally these workarounds wouldn’t be needed, but the actual implementation of how the installer handles UAC is out of my hands.

1 Like

I didn’t run SAI installer as admin, only entered admin credentials when asked by UAC - and still had the all the issues.
I have another idea:

  • First install as Administrator on Administratora account with all the options (including plugins).
  • Second install - as normal user on normal user account, without selecting plugins.
    So that first installation makes plugins available systemwide, and second sets up everything correctly for the standard user.

Could Topaz QA verify this scenario? Playing with 1+ GB online installers on rural WiFi is kind of… tough.

I will add that as a QA step but unfortunately there probably won’t be a fix this next patch. I do plan on revisiting the installers soon as one thing I want to fix is the online installers downloading components that are not necessary, which would save tons of bandwidth.

As a tip, if you run into a scenario where you are running the online multiple times it might be better to get the full installer instead. That way you can avoid downloading components multiple times. You can find it at the same URL as the online installer, just replace “Online” with “Full”.

Hi,

I really hope that Topaz can fix this “restricted user” issues in near future. At the moment this software needs to be run with admin account in windows in order to work. Applies also to Denoise AI.

Both the Sharpen and Denoise are something that I would like to use on regular bases, but requirement for admin account is show stopper. I have now used couple of hours trying to “fix” things with registry edits and re-installs, but no success.

I know I will not pay for the software that behaves like this. I really hope you can find a fix during my 30 day trial so that I can confirm it works.

Same this applies both for the windows and mac computers, as noted here in denoise-ai-v2-doesnt-denoise-unless-i-run-it-as-administrator thread earlier this spring.

Frankly? I have lost any hope already. The inability to fix such issue for such a long period speaks a ton about company reliability, priorities and ability to handle business - what are the best features for, it they cannot be used?
If there is no fix before my free upgrade period ends (pretty soon), I am not going to invest a single penny more in Topaz software. There are other companies around, which seem to be more responsive to software issues.

Hi,

Now it seems that Denoise AI and Sharpen AI both are installing quite nicely both in Mac (running Catalina) and windows PC for restricted user account. However, in Windows PC you need to manually change the install directory to match the one of the restricted user.