Proteus 3 black splotche blotting

It’s happening only in zoom 300% - bug work on my computer.

For my case (see above) it happened, for 1080p (to be upscaled to 4k), at ca. 270% zoom. Looks to be some sort of issue with running out of memory.

I take it you meant ‘without’ any problems? At any rate, the problem never occured for me with Proteus 2, only 3. And, as you can tell from my post, support clearly acknowledged the issue, and said it was on their todo list.

yes, meant ‘No’ problems.

And @TicoRodriguez is, I believe, a user like us who has signed on as a beta tester. I don’t think he’s in Topaz Support

I don’t use the command line directly; not sophisticated enough for that. I drop the file into the UI of Topaz Video AI v3.0.5, upscale to 300%, Proteus model with all of its parameters set to 0, and export to ProRes. Simple. That’s enough to produce the error. Here’s a copy-paste of “Show preview command” in the UI if you want it:

E:\ffmpeg "-hide_banner" "-nostdin" "-y" "-nostats" "-t" "2" "-ss" "1.2929583333333334" "-i" "C:/Users/someguy/Desktop/Dropbox/VEAI_error_input_lagarith.avi" "-flush_packets" "1" "-vsync" "0" "-avoid_negative_ts" "1" "-sws_flags" "spline+accurate_rnd+full_chroma_int" "-color_trc" "2" "-colorspace" "2" "-color_primaries" "2" "-filter_complex" "veai_up=model=prob-3:scale=0:w=2112:h=1440:preblur=0:noise=0:details=0:halo=0:blur=0:compression=0:device=0:vram=0.9:instances=1,scale=w=2112:h=1440:flags=lanczos:threads=0,split=2[out1][out2]" "-map" "[out1]" "-c:v" "tiff" "C:/Users/someguy/AppData/Local/Temp/somenumber/temp/_tvai_867486382/%06d.tiff" "-map" "[out2]" "-c:v" "prores_ks" "-profile:v" "3" "-vendor" "apl0" "-bits_per_mb" "8000" "-pix_fmt" "yuv422p10le" "-map_metadata" "0" "-movflags" "use_metadata_tags+write_colr " "-map_metadata:s:v" "0:s:v" "-an" "-metadata" "videoai=Enhanced using prob-3 with recover details at 0, dehalo at 0, reduce noise at 0, sharpen at 0, revert compression at 0, and anti-alias/deblur at 0. Changed resolution to 2112x1440" "C:/Users/someguy/AppData/Local/Temp/somenumber/previews/"

FWIW my system is
Windows 10
AMD TR 1950X
Nvidia RTX 3090 (24GB)

I know this. :slight_smile: But my confirmation came from Topaz Labs support directly:

“I have shared all of this with our development team and they are working on a solution, however, this fix will take some time. In the meantime, please use v2, you should not find any advantage to using v3.”

So, they are definitely aware.

Dunno, is Proteus 2 still a thing in VEAI 3? If so, maybe you could try 'veai_up=model=prob-2’?

Thanks, but no model manager in VEAI 3’s UI, so idk how to access that. (The black-splotch issue is not a show-stopping issue for me personally, so I’ll just live with it until it’s fixed. I just wanted to report the issue.)

Had it not been for Proteus 2, yeah, those blotches would have definitely been a deal-breaker for me. :crazy_face: Removing Proteus 2 (at least from the UI, haven’t tried the CLI yet) is another area VEAI 3 oddly regressed, for no good reason.

Yes, I am a beta tester.
I’ve never seen that happen at my side, but I may have just not noticed it, so I wanted to make sure it was reproducible.
Also, if it is a reproducible bug with a lot of users, I think it would be a big request for a fix.

As I already mentioned, support has already acknowledged the issue.

As for reproducibility, for me it took a 1080p movie, upscaled to a pseudo pan & scan type of 270%. Those are rather specific conditions. The fact that we don’t hear about it often, does not mean it’s not a real issue, of course.

I tried different Proteus values and it was reproduced.
It occurs when the value of "REVERT COMPRESSION(compression)“RECOVER DETAILS(details)”“REDUCE NOISE(noise)” is small.
The value of “SHAPEN(blur)”“DEHALO(halo)”“ANTI-ALIAS/DEBLUR(preblur)” does not seem to be affected.
It does not occur at 2x, but only at 4x.
(VEAI scaling is 2x4x scale only; all other scaling is adjusted by Lanczos.)

ffmpeg -y -i %1 -sws_flags spline+accurate_rnd+full_chroma_int -filter_complex veai_up=model=prob-3:scale=4:compression=x:details=x:noise=x:blur=0:halo=0:preblur=0 -an -c:v prores_ks -profile:v 3 -vendor apl0 -pix_fmt yuv422p10le “”


It happens even in 3.0.12. Is Topaz not going to fix this?


I made an AviSynth script that patches a Proteus4X ProRes render with an equivalent Proteus2X render when it detects a hole, lol. ZIP file includes a demo.

Here’s the debug view mode in action:


Nice work sir! Good job

1 Like

@TicoRodriguez @Kadet @ForSerious @collinstrevor25 @meimeiriver @Krazeyivan

Hi all, we are still attempting to recreate this issue and thus far, this does seem to be occurring due to each of your GPUs overheating. We have been unable to recreate this issue. Of those of you who have commented on this issue, can you please answer the following questions;

  1. Is this occurring with v 3.2.7?

  2. Is your GPU up to date

  3. Do you have a cooling unit for your GPU?

  4. If you enable low power mode, does this still occur?
    Please post the following (even if you have already for us to have concise information for each case):

  5. System profile
    How To Obtain Your System Profile (Windows)

  6. Screenshot showing the heat of your GPU while this issue occurs


Nope, just tested this on CPU only and it does the same. Definetely not GPU overheating.

Check these video samples yourself Black flickering spots in encoded video

  1. also occurs in 3.2.7.
  2. GPU Driver is the latest version.
  3. the GPU has a standard fan. In this test, including balanced mode, the temperature never exceeded 72 degrees.
  4. I compared the results in balanced mode and low power mode. low power mode resulted in lower conversion fps and slightly lower temperatures, but both resulted in artifacts. The file sizes are exactly the same.
  5. DxDiag will post with Machine name and Machine Id removed.

I also compared CPU (device=-1) and GPU (device=0) after seeing testthewest20’s post.
The artifacts are slightly smaller on the CPU, but occur at the same frames and same locations as on the GPU.

CPU Ryzen 7 5800X RAM 64GB GPU RTX 2700 SUPER

Balance mode CPU

Low Power mode CPU

Balance mode GPU

Low Power mode GPU

Balance GPU-Z

Low Power mode GPU-Z

File Size Compare

CLI Bat & DxDiag & other
VEAIBlack.ZIP (31.3 MB)


Thank you very much can you also post your Dxdiag?

I don’t think it’s an overheating issue. I have everything up to date (Nvidia 3050 Studio driver). In my case, black spots popped up on the video when I zoomed in more than 2x. When I magnified exactly 2x, there were no spots. Tested on 3.2.7.

1 Like