Proteous gives up and eventually degrades to only producing black images

Just got a new computer, I think the most important difference between my main computer is that it has an AMD RX 6900 XT GPU instead of an Nvidia RTX 3080 ti.
Upscaling DVD resolution to FHD with Proteus Manual, output PNG. It always starts out fine. After two minutes to two hours of processing, one section will go black, then more and more sections will follow until the output is only black images.
I’ve tried changing the memory usage. It still devolved the same way. I would have reinstalled everything, but I tried using VEAI 2.6.4 and it had the same result. Making me think it’s an issue with the model and not TVAI.

I tried searching for this issue, because I vaguely remember others reporting something similar a long time ago. I couldn’t find any of those posts.

Attached is the last log file from a run with the issue, my dxdiag.txt and an output image from when the issue started appearing. (1.2 MB)

Maybe it’s not just Proteus. At this point I just don’t know. Here’s some images from Artemis High:

The more it processes, the more sections of the video go black. With this run, it produced about 50 PNG images that are corrupt and cannot be opened before crashing the computer entirely.
I’m willing to admit it might be an issue with my hardware only. I just don’t know if it would be the CPU or GPU.

This seems like a GPU-related issue, however, it is quite difficult to determine exactly why this is happening. The log shared does not show any processes being called. I am unsure at this time if logs are needed, so let’s wait on collecting more logs.

Out of curiosity, if you output a ProRed file, does this still occur?

Can you set peak power to 90% in Radeon settings?

I lowered the power limit to 90%. Tried the same movie. It got about the same amount into the movie, the black boxes appeared again, but went away. About twenty frames later the PNG files became unreadable. 147 of those unreadable frames later the whole computer crashed. I wasn’t watching so I don’t know what the crash code was. Also, if it makes a difference, I was using the CLI.

Another note. I just updated to 3.1.11 and the speed is reduced quite a bit.

I’m running it now with the GUI to see if I get the same issue with 3.1.11. I’ll try ProRes if it fails.

ProRes crashed too. This time I couldn’t play the file to see if it blacked out or not. I happened to be there when it crashed. The crash code lead me to posts saying it may be the hard drive I’m running it on. Tried a different hard drive. Still black spots, well, the whole thing was black and never showed a single bit of the movie. Ummm, I can try turning the mem usage back down to 10 and the power limit to 90% again, but I think it’ll still produce random black sections.

Also tried to see if anyone else with an RX 6900 XT is having this issue, but no one has posted one in the benchmarks but me.

Found a tool I had downloaded years ago for testing stable GPU overclocks. Ran it on the default settings in the AMD software and got thousands of memory errors. Tried several other settings, finally left it on the Quiet preset to go eat dinner. Came back. Ran the test again and got no errors.

Running a show now to see if that fixes it.

Nope. Same issue. Not getting any more memory errors, but also not completing a video without black sections. I tried a few demanding games on it. No issues.
If my GPU is the only one with this issue, I think I’ll just sell it and get another one.

Just processed a 35 minute video without issue. I’ll try a 2 hour one tomorrow to make sure.
The update seems to be what I needed.

1 Like

@ForSerious Thank you for the update! @ida.topazlabs is out sick right now, so thanks for your patience. I’ll keep a lookout if I need to keep this one open once you have a chance to test further.

It happened again when I tried to process two DVD resolution files at the same time outputting at 100% scale.
I’ve also noticed that my mouse cursor gets a black box around it for a moment when I move it over my task bar in Windows. Because of that, I’m thinking it’s probably more an issue with my particular GPU, since it does that without TVAI running.

So 3.2.0 helps with whatever is going on, but it’s not totally fixed.


If the issue is still happening in 3.2.1, could you share what driver version you are on for the 6900XT? It does seem like a VRAM limitation since the black boxes reappeared when running two parallel processes though.

1 Like

I’m marking this solved. I’ve processed about three long movies, and did about six short movies two at a time. No issues. I’m pretty confident some of the problem was the HDD I was using. Between using another drive, updating to 3.2.1 and using DDU to clean out any old drivers then updating to the latest, this issue has not come back.

Taking all that back.

This started at about 1:46:28.000 into the movie and persisted for the rest.

I guess I just needed to try a three hour movie to get it to surface again.

Updated to 3.2.2. Ran the same movie with the same settings. No issue this time. I have two more I want to run on it before saying I’m confident it’s fixed. (They take at least 10 hours each, and I’m running something else. So I’ll report back in a few days.)


Thanks for reporting back on this, I’ll keep a lookout for any updates I can relay to the VAI team!

I have now run 4 long videos on version 3.2.2 with no black boxes appearing. That part seems to be better for now.
For the second part of this issue, well, it came back when doing a 20 minute video in Apollo with slomo 2.5X. After a few hours of processing, it starts to create corrupt unviewable PNG files, then the computer crashes.
I thought it was the hard drive before, but that’s been changed out.

Tried the same video with the same Apollo settings on my other computer. Processed fine. (AMD Ryzen 5900X and Nvidia RTX 3080 ti)
I suppose I could try putting that 3080 ti in and seeing if it works. That would narrow it down to just the GPU and not CPU. I don’t think it will fit in the case though.

Would you be able to open a new thread since this one is titled as an artifact (black square) issue?

Sure. I can do that.

1 Like

New topic created about the crashing issue.
For this issue: I did 6 ~23 minute videos yesterday. One of them had black blocks in the first 10 or so frames, but none in the rest. This happened doing DVD resolution to FHD with Proteus manual.

As stated in the other topic, I can confirm that this issue is unique to my AMD RX 6900 XT. I tried my Nvidia RTX 3080 ti in this machine and it has no such issues.