Only 10 images transfer from LRC during Batch Processing

Topaz Photo AI isn’t loading all the photos I select from lightroom classic. It seems to be limited to around 15. Also, often it sends back 4 images to lightroom of the same shot.

I have installed the latest version 3 (same error as one version before) of Photo AI and only a maximum of 10 photos are loaded into the plugin. I can not continue using it like this because it costs me too much time.

I have noticed that when i try to bring images in from Lightroom classic “edit in” only a few actually come across.
Selected 33 images to edit but only 12 came into PhotoAI. Tried once more and only 3.

Not sure if there is a limit to how many or their size (only jpgs)

I would rather do this as a batch when editing to keep the renaming sequential.

Any progress on this issue? I posted about it two weeks ago and last heard from you one week ago.


Hi John–

Any progress on this issue of only a few photos sent from Adobe Lightroom appearing in Photo AI? It’s been two weeks since I first posted about it and it’s clear that others are having the same problem.


I’m having the same issue since updating to Topaz AI 3.0.0 where only 10 images will go to Topaz from LRC.

Memory must be purged after applying changes to an image.

I am a photographer on Mac M3 and M2. When I send more than 30 files from Lightroom or Photoshop to Topaz Photo AI at the end the memory empties quickly to the point of blocking the machines. The stats clearly show that Topaz does not “clean” the memory gradually and takes everything for itself. I work on 2000 files on each workflow and it’s not possible to send 10 or 20 files to Topaz, wait, and after that send 10 or 20 files to Topaz, wait, and after that send 10 or 20 files to Topaz, wait, and after that …

And why not make aa workflow possibility where Lightroom send 1 file, topaz work on it, save ans close automatically, next file, topaz work on it, save ans close automatically, next file, …

Thank you

Photo AI does not handle more than 20 photos sent to processing from LT.
Only part of the selected photos is eventually opened on PhotoAI

When using Lightroom classic and TPAI as plugin, I selected 204 images to be edited in TPAI.
I then select the option - edit copies with LRC changes applied.
LRC then creates 204 tif images with edits applied and passes them on to TPAI.
Now I select models and preferences and choose select all images.
It then says do you want to export all 18 images. Not the 204 images.

I then went back to LRC, selected all the tif files and said edit with TPAI, use original files. 204 are selected.
Again in TPAI when I go to export it says only 18 images are in the queue.

To get them all edited, I had to open TPAI and browse to my LRC catalog and select all the images through the TPAI file browser. It is now processing 204 images.

Topaz Photo AI [v3.0.0] on [Windows]

Batch processing of 204 tif files TPAI opened as stand alone app, LRC and PS closed.
59 images were processed in about 2 hours.
TPAI crashed (5.2 MB)

I have tried

  1. Using TPAI 3.0 as LRC plugin, editing copies with LRC changes.
  2. Using TPAI 3.0 as LRC plugin, editing original tif files
  3. Using TPAI 3.0 as stand alone app and browsing to tif files
  4. Restarted PC and only open app was TPAI 3.0 browsed to tif files

All attempts have failed.

Topaz Photo AI [v3.0.0 on [Windows]

Try any way possible to batch 204 files and you will see that TPAI 3.0.0 will crash after approx 50 files.

Steps to reproduce issue:

  1. Step 1
  2. Step 2
  3. Step 3

Topaz Photo AI [v1.x.x] on [Windows/Mac]


There is a memory leak when processing many files as shown in the Windows Task Manager. I have to restart the app often.

1 Like

The following are snippets out of eMails I received from Topaz Labs Support to my report of a “Apparent memory leak in Photo AI”, which was submitted on March 12th, 2024:

Sent: Wednesday, March 13, 2024 11:21 AM
Thanks for sending that info. My team believes they’ve found the cause of the memory leak and our Head of AI is creating a potential fix for this. We appreciate your patience and understanding while we get this sorted for you.

Sent: Thursday, March 14, 2024 2:13 PM
We’ll keep working on that! If we have test builds, we can also send them to you to try out.

Sent: Friday, March 15, 2024 1:13 PM
The Upscale enhancement is particularly resource-intensive so if you’re running that on hundreds of images, let alone the memory leak, it could cause the computer to freeze up. We’re still investigating the memory leak on our side. If you could, try processing smaller batches (~100 images) and see if that works better.

Sent: Monday, March 18, 2024 12:45 PM
Thanks again for the testing. Our AI engine team is looking into this as a top priority.

Sent: Thursday, March 21, 2024 11:11 AM
We’re still working on it! I don’t have a solution for you just yet. Thanks for understanding!

Sent: Friday, March 29, 2024 10:58 AM
Our development team is running some tests for the memory leak now so it wasn’t included in yesterday’s release but it’ll come to a future update soon.

Sent: Thursday, April 4, 2024 11:37 AM
We are still working on it. The backend team has a lot on their plate and has not gotten around to fixing it yet.

At this point, I stopped sending Support eMails as it seems, now five weeks in, that this issue will be fixed when it gets fixed. Until that happens, my only option, if I want to run large batches is to go back to a version which does not have the memory leak.

As far as testing goes and I have done a lot and sent my test plan & results to support. The memory leak appears to be linear and maybe impart caused by a recursive function being called when doing batch processing.

I have not monitored memory usage for the application while processing single very different images over time. Which is to say keeping Photo AI open for an extended period while working on individual photos. This could indicate the leak is not just related to batch processing. Generally, that is not my workflow.

My Windows 11 system has 256GB of RAM (it can take up to 2TB, not that I could afford that!), and so I can process well over 100 images in batch before I need to restart Photo AI.

As others have reported, the issue is not related to operating system memory management, either in MacOS or Windows.

If one’s computer has 32GB of RAM, then if Photo AI is consuming 20GB of RAM, as it did in my last batch run of 100 images, the operating system’s memory management will start thrashing virtual memory pages to disk, slowing down everything, potentially crashing the application and possible the operating system as well.

At the beginning of this thread, it was stated by Dakota Wixom concerning Presets, “This will speed up the process of editing large batches of hundreds or thousands of photos at a time”, for me this would be great as I process tens of thousands of video frames… that is if it worked.

The product description, see Topaz Photo AI - Maximize Image Quality with AI, in the Easy workflow section states, “Use the standalone to batch process thousands of images in sequence…”, at the present time this is not possible.

The memory leak issue has been around since the 2.4.x release. I have 256GB of RAM in my system and after about 120 images the memory used by Photo AI grows to about 17GB.

Memory leak

Beyond this, the processing time per image goes up from about 5 per minute to, in one case 9 minutes for a single image.

I also agree this has been since 2.4, I remember reverting to 2.3 because of this. Then I updated again because it became 3x hoping this was fixed but it still going around I don’t know why release updates with this problem still being an issue. I’m going back to 2.3, I hope we will be notified when newer versions have this fixed.

Using the flow of
Plug-in Extras → Process with Topaz Photo AI
I selected 204 images in LRC. When I get into TPAI, only 10 images are there to process.

Topaz Photo AI [v3.0.0] on [Windows]

I’ve got a similar (the same?) issue. My computer has only (?) 64 GB of memory and TPAI starts by using only maybe 16 GB and rapidly escalates to 59 GB or so (whatever is available). Processing then becomes very slow with frequent TPAI crashes. This occurs when I drop RAW files directly into TPAI (because it won’t process more than a few files at a time when I send them from Lightroom Classic). As a result, my workflow has been badly damaged.

Keep in mind my system has 256GB of RAM.

The other night, I started a batch of 150 4K images in Photo AI. It was doing Face recovery, Sharpen and Adjust lighting, then saving my jpg images to jpeg files.

I checked the memory use after about 140 images where processed, it was:


Yes, that is nearly 103GB, it is fortunate my system has 256GB of RAM.

After my batch of 150 4K images in Photo AI, which was doing Face recovery, Sharpen and Adjust lighting, then saving my jpg images to jpeg files, completed I created a graph of processing time. As was the case before, it took longer and longer for each image to process.

Hopefully, today’s update will address this issue.

Version 3.01 seems to fix the speed and memory problems but it still limits the number of edits per batch to about 22. I really need to edit hundreds (maybe a thousand or more sometimes) in each batch.

I am having the same issue. Installing Topaz Photo AI Version 3.0.1 did not fix the issue. LRc still sends a max of 10 files to Topaz at a time.