On installation Topaz AI does not install in the Image/Edit With menu of Capture One 23

I have recently purchased Topaz AI and I was using Capture One20 Fujifilm version.
My original version of Topaz did install to the Image/Edit with menu but did not work with DNG files and I found that it was very buggy and frequently crashed.
I upgraded to TP AI V1.2.9 and it then appeared to work correctly and the I was no longer experiencing the crashes. I have just upgrade to CaptureOne 23 Pro version and Topaz AI is not available on the Edit with menu. I can browse to it manually but this has to be done for each image. If I have TP AI open then using it via Capture One also opens and new instance of TP AI. TP AI is saving the output image back to CaptureOne correctly.

Topaz Photo AI [v1.2.9] on [Windows]

Check in the preferences Plugins of C1 and make sure it is selected there.

@christopher.roberts try running the full Photo AI installer from our Topaz Labs Download Page again (with Capture One completely closed) if you’re still not able to find it there – also, make sure you’re using Process with Topaz Photo AI like in the screenshot below;

@AiDon Thanks for this. It wasn’t there,even after a clean install but this helped me solve the problem. See my response to @preston.werner

The clean install did not solve the problem, however following the lead from @AiDon I did some more reading. The problem wasn’t with the applications but was a Windows issue. The Plugin only became available and visible in Capture One once I had associated a file (e.g. a .jpg or RAW) with Topaz using the the Windows File explorer, right click “Open with” menu and browsing to Topaz AI. This then allowed CaptureOne to install access to the plugin. From my reading it seems that this may also need to be done for Lightroom as well as CaptureOne. I get the Topaz Photo AI plugin and not the “Process with Topaz Photo AI”.
Incidentally there are two application files in the install folder and I was wondering what the difference was. Topaz Photo AI at 5,533 KB and tpai at 7,025 KB in size.

Thanks for your help.

I get the Topaz Photo AI plugin and not the “Process with Topaz Photo AI”.

After downloading v1.2.10 from the forum and installing this (so no in-app update, but full installer) I ran into the same. There was no more Process with Topaz Photo AI, but only the Topaz Photo AI option.
I found the documentation states you simply use “Edit With > Topaz Photo AI” and I figured the way the integration works had changed. Strange this was never mentioned in change notes or roadmap updates though.
So… has it changed? Or is the installer buggy? Using the Topaz Photo AI option seems to work and Topaz even shows “save to capture one” on the save button.

If you are talking about Capture One there has never been a Process with, only Edit in And Open with. For anyone having issues with C1 make sure that you know hoe Capture One works … here is an article on the C1 support and although it says Photoshop it applies to ALL external apps you want to use as plugins:

That’s a rather condescending reply while falsely ‘correcting’ me. Up until the last TPAI update Capture One DID have the option edit with > process with topaz photo AI. Of this I am certain. I used to click this option and have done so many times.

It’s only ever had Edit with or Open with, did you get it to work?

Please just stop gaslighting me. Previously it had “edit with > process with topaz photo AI” (white icon) AND a “edit with > Topaz photo AI” (blue icon). Now it only has the latter. It seems to work fine as I said before.

You’re going on my ignore list.



1 Like

I was wrong and I apologize; this is a Topaz thing and I incorrectly interpreted your post as a Menu option of just Process with … from your statement “There was no more Process with Topaz Photo AI

@Propheticus @christopher.roberts

I believe this is an issue with the Capture One plugin folder disappearing so Topaz Photo AI has nowhere to install the plugin files.

Please follow the instructions in this video and let me know if that fixes the issue. I’ve seen a few instances of this issue in the last week but haven’t pinned down the cause yet.

If your Plugin folder is missing please notify me.

The Topaz Labs docs page will always have the most up to date information about the application and our plugins @AiDon.

1 Like

I’ll check when I get home. If this is the case that would mean that the installer of TPAI v1.2.10 removed the plugin folder. I didn’t update or change Capture One (22) in the last months.

The TPAI documentation on plugins was changed from the screenshot I shared under “new” to again mention “process using…” And states:

DO NOT use Image > Edit with > Topaz Photo AI on images. This option does not import the image back to Capture One.

This is false. TPAI shows a “save to Capture one” button and the processed tif is saved and visible back in CO. Sometimes the CO preview needs to be regenerated though, because it still shows the original copy.

The Plugins folder was indeed missing. This must’ve happened when installing v1.2.10; this is when the plugin went missing.
Perhaps related to Topaz Photo AI v1.2.10:

Copying the com.topazlabs.TopazPhotoAI folder to a newly created plugins folder indeed restored it.

Thanks for sharing this information. I just updated the docs to reflect the Edit with > Topaz Photo AI behavior for Windows and Mac.

It works on Windows (but cannot create a DNG) and does not work on Mac.

I let our plugin developer (Anthony) know about the plugin folder getting deleted so he can investigate. I don’t have a lead on what is causing it yet.

Well, good news is that the v1.3.1 installer did not remove it :slight_smile: So perhaps already solved…if it’s not one of those hard to catch bugs that only happen on a specific combination of conditions / timing of events.

I think it may be one of those hard to catch ones. I’ll keep an eye out for more reports and see if we can fix it entirely. Please let me know if it happens to you again.