Object Selection Brush for Remove Crashes

when I try and use remove function and opt for object selection rather than pain - as soon as I try and select object program crashes


Topaz Photo AI [2.4.2] on [MacBook Pro M1 16gb ram on Sonoma 14.2.1]

We will be working on a fix for the Object Selection brush in Remove so it’s no longer crashing. I know it’s the easiest way to do selection in Remove so it’s quite frustrating that it doesn’t work right now.

Many thanks John do rectudcupdate and I will look forward to that.
Thanks
Thomas

1 Like

I have been seeing a few random crashes since updating to 3.0.1, with no single user action seemingly to blame. However, I can reliably recreate a crash when trying to use the Removal tool as detailed in steps below:

Steps to reproduce issue:

  1. Open image (multiple tried) and allow auto pilot to complete
  2. Add enhancement - select Removal
  3. Wait for progress bar to settle (preparing, locking edits, etc.)
  4. Attempt to select or paint for removal
  5. Crash occurs on first or second selection attempt.

Topaz Photo AI [v3.0.1] on [Windows 11]

I am on windows 10 and I have the same issue,
for me it crash only when you use object selection, and do not crash with using the brush selection.
what I do is… I open an image, i remove all the enhancements, including the upscale, and then i use the removal object… i noticed that the larger the image, or the more the corrections, the more often the crash. I think it’s an out of memory issue. I have a RTX 2070 super with 8GB or ram-

Step 1) Start Remove…
Step 2) I changed power/quality to all the way up
Step 3) I changed to object selection
Step 4) I selected a person.

Tried in older version. Then it informed me of an upgrade when restarted. I upgraded to:
Topaz Photo AI 3.0.2 still same crash
2024-05-10-07-22-6.tzlog (117.2 KB)

I have exactly the same problem on Asus PC , running latest and up to date WIN10, the program crashes when I choose the "object selection " option in the "Object Selection " menu, the “regular” option works fine

Steps to reproduce issue:

  1. Step 1
  2. Step 2
  3. Step 3

Topaz Photo AI [v1.x.x] on [Windows/Mac]

App closes suddenly when remove with object selection, no matter the image, nor the number of processing layers.

  1. Open the image
  2. Select remove tool
  3. Choose object selection.
  4. Click elsewhere when system is computing, not waiting to the selection ends. Repetitive clicks also reproduces this instability.

The only workaround is being very careful using the brush: slowly, clicking when the system responds.

Topaz Photo AI v2.4.x on macos Sonoma 14.4 macbook air M2.

2024-03-20-21-31-57.tzlog (131.2 KB)

Please follow the instructions below to perform a clean install to better troubleshoot why you had this problem with Topaz Photo AI:

Start by clearing any previous plist files that are on your computer for Topaz Photo AI by following the steps in the link below:

Topaz Photo AI | plist Files Mac

After you have done this, disable any antivirus, firewall, VPN, or proxy software that might be active on your computer. These tools are sometimes known to interfere with the installer’s ability to download the model files.

Please also ensure that the Topaz Photo AI installer has all the proper settings in your system by going to your Mac System Settings > Privacy & Security tab and scrolling down to the security section. You will want to make sure you have 'App Store and identified developers ’ selected. Here is a video example:

Example of Proper System Preferences

Finally, rerun the installer. You can download a new installer from the downloads page directly :

Topaz Labs Download Page

Let me know how that goes for you and I’ll keep an eye out for your reply.

Thanks John, but nothing change at all: repetitive clicks on object selection in remove close the app. Also in state ‘preparing’ when remove starts.

Please reach out to us at the following link so the team can take a look at this together:

Topaz Labs | Support Page

The problem persists in newer versions.