Object Selection Brush for Remove Crashes

When trying to use Remove on an image, the program continually crashes while an object is being selected and forces me to start over.

Topaz Photo AI v3.0.3 on Mac

The app crashes every time that I try to remove an objet.

Apple MacBook Pro M2 Max 96 RAM 4TB ssd

[Please describe your issue here. Try to include logs (Help → Logging) and add screenshots if necessary.]

Steps to reproduce issue:
The remove tool stopped working. All I get is a red box that says clear selection ? Please help.

  1. Step 1
  2. Step 2
  3. Step 3

Topaz Photo AI [v1.x.x] on [Windows/Mac]

Removing objects crashes Topaz AI Photo.

Steps to reproduce issue:

  1. Add Remove workflow
  2. Set brush settings to object selection
  3. Select some plates or glasses on a table
  4. Topaz crashes almost every time. Maybe once out of 5 time succeeds.

Topaz Photo AI [v3.0.4] on Mac OS Sonoma 14.4.1

Mac Air Book Chip Apple M2 MEMORY 16GB SONOMA 14.5

Steps to reproduce issue:

  1. Step 1 load image make minor changes
  2. Step 2 erase unwanted element
  3. Step 3 immediate crashes

Topaz Photo AI 1.3.12
2024-06-16-21-39-18.tzlog (367.9 KB)
2024-06-16-21-02-29.tzlog (295.1 KB)

Hi!

If I use the “Remove” function, I can at best mark the relevant places, then the programme crashes and closes. Sometimes Topaz also starts to calculate, then crashes, or shortly after the items have been removed. It doesn’t matter which image I use. It seems to happen more often with users. The rest of the software works without crashes.

My system:
Win 11 - all graphics card drivers updated
Laptop with RTX 3060 Nvidia + latest Drivers (Studio Driver 555.99)

Topaz Photo AI [v3.0.4] on [Windows 11]

1 Like

I have the same issue. Win11 RTX 3060. Photo AI 3.03 crashes on almost every change. I wonder if this is localized to Win11 + RTX3060. I feel like it must be or people would be screaming about how incredibly unusable and buggy this software is.
Again, no error trapping, nothing in the logs, just … gone.

I would be happy to help troubleshoot if anyone from the Topaz team is reading these.

1 Like

Mac M2 Pro with 14.5 and Photo AI 3.

The object selection in the remove tool is unusable. The app always closes immediately after I try to select an object. I’ve tried disabling all other edits, editing a JPG instead of a TIF and it always closes.

Latest log attached.
2024-06-29-09-32-52.tzlog (123.1 KB)

[Please describe your issue here. Try to include logs (Help → Logging) and add screenshots if necessary.]

Steps to reproduce issue:

  1. Step 1
  2. Step 2
  3. Step 3

Topaz Photo AI [v1.x.x] on [Windows/Mac]
2024-07-01-14-00-22.tzlog (79.6 KB)

I tried to remove only a small portion of an picture. But the screen shows me the red preview all over the picture. I can not clear this selection. I draw over with the brush and after that I pushed the green button “remove selcetion”. Now the Photo AI chrashed.

In PHOTO AI, MAC version, every time I try to do REMOVE, the program always crashes. Please improve.

Der Remove Teil ist kaum brauchbar. Das Programm stürzt ab, und kann oft nicht richtig bedient werden.
Will man etwas entfernen, wenn es dann geht, bleiben Reste übrig, die sich nur schwer entfernen lassen. Bitte überarbeiten Sie das Programm. Dann hoffe ich, es wird besser!
Martin Keller

Hello @thomas.nors and everyone :slight_smile:

Hello Mark,

Wanted to let you know that we have released Photo AI v3.1.0 which improves the performance of the Remove Tool.

You will be able to download this update from your app directly or by using the following link here:

Here is the full list of changes/fixes done on this release.

Let us know if any issues still remain when trying this version!

1 Like