My FPS is LOWER with a 4080 than a 3080, how is this possible?

Topaz Video AI - v3.1.4 → Max Memory Usage 100%
AMD Ryzen 7950X
Nvidia RTX 4080 - latest drivers
Windows 10 x64 - latest patches

Usually get 9.2 fps when exporting with Artemis Medium on a 1080p video.

Is this normal? If not, how can I leverage the full power of my computer? Should I export multiple videos at one time? Would running via a SSD help at all in terms of fps?

What storage drive are you using? And is that FHD to UHD you are doing with Artemis?

Gen4 PCIe M.2 SSD

Resolution staying the same at 1080p. Exporting purely to remove noise (denoise) via Artemis at Medium setting.

Okay you’ve got something wrong for sure. I just tried that on a 1080p video and got 15fps.
I’m on a 8TB WD Red HDD.
Ryzen 5900X.
and RTX 3080ti.

Does it start out fast and then slow down after awhile?

It starts at 8.8 fps and goes as high as 9.2 or so fps.

Here’s my settings:

Change all GPUs to the 4080, maybe.
I had my output to PNG, but that shouldn’t make a difference.

Zero difference. See here: Imgur: The magic of the Internet

Do you have two 4080s?
I don’t even have the option for All GPUs.

The only other thing I can think of is I have XPM enabled for my RAM, and in my tests it was slower with it off. But again, that’s DDR4 and the difference between 3200MHz and 3600MHz.

No, I only have one 4080, not sure why it is showing 2.

I have a AMD motherboard, so not sure how to disable XPM.

Try exporting this with Artemis Medium, keeping the resolution the same.
Its a 4K clip.

I only get 2.1fps

Made sure to keep all the settings the same: Artemis Medium. I’m even converting a DVD to H265 with a QTGMC denoising filter on in the background.


I don’t get it. I have better tech, what could the issue be. How do we even diagnose this?

I’m trying to help as much as I can because if it was my machine, I’d be going nuts trying to figure it out!

Appreciate you man. It doesn’t make any sense. I have everything possible in my machine to supercharge encoding, even have a better RTX 4080 than your 3080. I am at a complete loss.

Could it be the AMD Motherboard and Ryzen chip? Seems outrageous if it was.

This was with Encoder (H265 Main (NVIDIA) with mkv and 80 bitrate?

Okay. I tried NVENC:
On PNG the fps was constant. With NVENC it started strong, then slowed down quite a bit.
Here’s the times: NVENC then PNG
That’s just a 15 second preview. (Same result when I repeated NVENC.)

Did a complete uninstall, removed all remaining leftover files. Installed fresh. Same result.

Get 1.9 fps… When doing running these settings:

This question.

I am on Windows 11. And I haven’t updated my GPU drivers in about two months. (527.56)
Also wondering if you have some sort of anti-virus going on.
Umm I don’t use my C drive to process in TVAI… but I have done tests using it and the speed was the same… before the great speed increase update.

I am just using Windows Defender, nothing special. Hope someone can help me fix this…

Try reducing memory % in TVAI settings to 10% or 20% and repeat test. I don’t know if it works for Windows, but reducing the max memory setting on Mac M1 below a certain amount somehow “forces” significantly more GPU usage and hence much better performance. I’ve no idea why it works, and sounds counter-intuitive. So perhaps worth a try, but maybe just a quirk of M1 / M2 Macs.



Sadly, makes no difference.

Can anyone please help fix this for me?

I am only getting 7.2 fps for a 1080p (no upscaling) using Artemis Medium with H265Main

2.3 fps for me on that 68.85 MB 4K file, using your settings posted lower down. I have a 3060 ti with a Ryzen 5800x and 32GB RAM.

TVAI 3.1.4 settings are “Auto” as I have found previously that selecting any specific GPU can slow things down a bit. RAM usage is set at 90%.