Must preview image first or export is skipped and no changes applied

Must preview image first or export is skipped and no changes applied.

Started experiencing this issue immediately after updating to 3.03. Windows 11 environment. Multiple users experiencing this same issue as noted from the following post;

Would you mind taking a screen recording of this behavior so I can see exactly what is happening?

Loom is a great free application for this : Loom | Free Screen & Video Recording

I have this same problem. Here are screenshots - I copied settings to all files in the batch but did not preview file 02 in the list, but did preview some others and it skips the ones I haven’t previewed.
Screenshot 2024-06-06 073307

What’s weirder is that yesterday I was able to batch export 400 files no problem and it didn’t skip any. With that I was working with DNG → DNG and these are tiffs.

I experienced this issue was with tiffs as well. I have not tried any other file formats yet

I was able to replicate this behavior and have reached out to the devs for further investigation.

1 Like

Running into the same issue, killing my productivity. Hopefully, there’s a fix soon.

When I try to batch edit photos, it stops (skip editing) after the first photo… Bug?

I’m having the same issue after the update. Only jpegs. Frustrating! Hope there’s a fix soon.

I have a scenerio where I have applied a preset to 47 photos, then tried a batch export of all 47. It skips all 47 and gives me a message for each, saying that no edits were applied :-/

Any idea what’s going on here? I did a batch edit of a focus stack before the update, and it worked just fine. Is this a glitch brought inby the update? or am I missing something?


Same here with the latest update!

1 Like

Ive been playing with photos all morning…several app crashes, failure to allocate memory error, what a nightmare. We should get a major discount for being beta testers. None of this was happening before the update :-/

I am having the same issue. I found that if you click each photo individually… (not very efficient but I have photos due dates to make), and let it load for about a second each, it will export as it did before the update. But if you don’t click each photo individually, it skips and says the whole “skipped: no edits applied” BS. Not sure what’s going on, but that’s the only way I’ve found it won’t skip while also trying to get a hole of someone with Topaz Support Help.

1 Like

Yeah, same here. Painfully slow. It was nice to set a batch export and just go to bed LoL!

Same exact issue here. Only way I could get the batch export to work was to preview each item individually.

That’s odd. So your batch export functions, but only if you first preview each image??? That might be useful info for devs. As if preloading the image into a buffer helps with the export? Hmm.

Precisely. I opened a separate ticket before I saw this post. Hope they can get this squashed soon. Creating major processing delays for us.

1 Like

I’m having the same problem, but more to add. If I start with a DNG sequence everything exports no problem. If I start with anything that’s not RAW, it will skip unless I preview. (Also tried starting with RW2 files (also RAW) and the export worked without having to preview)

Mine bad experiences have been with Nikon NEF raw.

I have been able to recreate this same issue after the update on both PC Windows and MacOS. In order for the changes to take effect in the export, I must preview each image and allow it to make the edits in preview. Any image not previewed is skipped by the export when bulk exporting