Incorrect Colours displayed, colours appear to be dull and grey

I use a lot of Topaz products, but with Photo AI I can’t preview in the correct image colours which makes it hard to get a good idea of what I’m editing. All the colours in the image are very grey and don’t show the warmer colours. I hoped with the new release it would be fixed, but it’s not.

All of my other Topaz products preview in the correct image colours.

Steps to reproduce issue:

  1. Step 1 - open an image from photoshop or lightroom
  2. Step 2 - you can see right away the colours are not reproduced correctly
  3. Step 3 - make changes, save back to photoshop and hope for the best.

Topaz Photo AI [v2.4.0] on [Mac]

What type of camera are you using for these images that you are seeing a color shift with while using Topaz Photo AI?

Canon Mark IV.

It’s not the camera, it’s this software. Every image renders in the correct colour in your other software applications. I have all of the Topaz products and this is the only one that renders with desaturated colour.

I had hope the new update would fix this, but the new update is pointless and unusable. If there are ways to tweak the image adjustment settings, they’re well hidden.

I feel that I paid for a useless application with this one.

Would you mind sending in some more information to get a better understanding of the problem you are having with this particular type of image? Please send the following information:

  1. The original image file.
  2. The processed image.
  3. A screenshot or description of the settings panel so I can see what adjustments were turned on.

You can securely submit your image(s) to my Dropbox using the link below.

Dropbox File Request

Please be sure to send me a note to let me know you sent something.

You don’t understand.

The processed image displays the correct colours. The issue is that those colours are not rendered in Photo AI on the screen.

Look at it this way.

I open an unedited image in Photo AI. It renders as desaturated colours.
Lets say I run it in the software. It makes adustments. It still renders incorrectly. This means, I can’t accurately predict what the image will look like when I save it.

When I do save it, it is back in correct colours in Lightroom or photoshop.

So lets say it sharped the image. Opening back in Lightroom would produce the right colours, but you cannot see those correct colours in Photo AI.

Hi there,

I’ve sent 3 screenshot files of a squirrel. Lightroom original. Photo AI render, and save back to Lightroom.

Also, 4 files of foxes. Lightroom original, Photo AI render, save back to Lightroom and an additional shot of how the photo displays in Denoise AI. Correct colours in Denoise, incorrect colours in Photo AI.

Thanks for sending in those screenshots of the issue you are reporting. I can see the color shift you are reporting from these examples.

Let’s try updating you to the most recent version release to see if this resolves the issue.

Please make sure you’ve also turned off any firewall, VPN, or proxy that may be on your computer. These are known to block the installation. Also, make sure there are no settings or configurations in your OS system that could interfere.

Try using the appropriate OS system link to update:

If you are still experiencing problems, please reach out to us at the following link:

Topaz Labs | Support Page

The update did not fix it.

That’s a colour management issue. TPAI is probably having a problem with the monitor profile.
This thread from last year might be worth looking at:

1 Like

This worked for me. For anyone else with this issue.
Go to: Preferences/General/
Scroll down to Enable sRGB Preview Fallback. Toggle this to “on”.
It won’t change initially. Close Topaz Photo AI completely, then reopen.

Colours now display correctly.


This topic was automatically closed after 60 days. New replies are no longer allowed.