Gigapixel v4.9.3.2

Download: Windows, Mac
Released June 2, 2020.

Major features

  • Resizing with physical dimensions (inches, centimeters, and PPI) has been reworked to be more intuitive and easy to use. More details below.

Improvements

  • When changing width or height based on inches or centimeters, the image pixel size now correctly changes.
  • Physical dimensions now update correctly when resizing the image based on scale.
  • PPI text has been changed to “Pixels Per Inch” or “Pixels Per Centimeter” based on which unit is selected.
  • Pixels per unit metadata now correctly gets written out, so opening the image in other programs will now correctly read what the physical dimensions are.
  • Changing the pixels per unit no longer changes the physical width / height.
  • Menus on Windows have been changed to a lighter color so they don’t blend into the background.

Fixes

  • When multiple images are open and only one is selected, the “Selected” text in the right panel no longer overflows.
  • The right panel no longer overflows when using custom application scaling modes on Windows.
  • Buttons now correctly highlight and grey out in the Product Tour.

Known Issues

  • Some users may experience an issue where the right panel says scale 2x when opening a new image, but the file at the bottom has different settings. Changing any of the scaling settings on the right should fix this.

Hotfixes

v4.9.3.1

  • Fixed an issue where scaling wasn’t getting correctly applied across multiple images

v4.9.3.2

  • This update includes a very minor change as we prepare for a new beta build. It only affects those testing the beta, as some options in the beta would have affected the release version of the software.
3 Likes

4.9.3 is very bugus! In multiple pics, when I enter a size in px (for example 1080 px), each pic have a different size! Some times just the size of 1th pic is correct. Another times no one have had current size. Next times 1th to 3th pic have correct size, etc.

I backed to 4.9.2.

Searcher123 is correct - I set all these up to have a width of 1500 pixels, but the last two have a width of 1875. Note however that the scale is 1.46 in each case.

Hi searcher,

I’ve just released a hotfix to fix this issue - thank you for bringing it to my attention. If you find anything else please let me know!

Thanks for the detailed response Paul, just released a hotfix for this.

2 Likes

Seems to have fixed it - many thanks Taylor.

Where is this hotfix? https://topazlabs.com/downloads/ still displays v 4.9.3 but I guess this is not what was meant as hotfix… BTW, the change log still refers to v 4.9.2 …

Of course the …/downloads page should reflect the most current ‘hotfixed’ version…but do please update the PC & Mac full downloaders at the header of this thread!

You specifically reference the 4.9.3.1 version with the hotfix but have not updated the downloads above the changelog :wink:

Updated - sorry about that :slight_smile:

1 Like

v4.8.3.1: Tried a batch resize with 10 1x1 ratio images. The first image size (pixels)was 1070x1070, second was 1600x1600 and so on. Set the height to 2160, but all 10 rendered out to 2159 x 2159.

What settings did you use for the batch resize?

Why is it that even the latest build (4.9.3.1) still doesn’t correctly remember the set Resize Mode value. I never use 2x, 3x, 4x…, my preferred and mostly used is Height 2160 and I want to be always offered my last used value. Why is it, that this worked perfectly in v up to 4.4.6 but with the 4.5 update and up this just doesn’t work. If I overlook that the set height value has been changed by the program, I just may resize hundreds of files in vain…

2 Likes

Auto update preview On
Height resize mode
Max Height 2160px
Face refinement Off
Auto detect settings Checked
Save directory Source
Color profile Preserve source profile

Performance: discrete GPU enabled, graphics memory High, and OpenVINO enabled (hhis was set via a calibration).

I was able to reproduce this locally, should have a fix out for it with the next release. Thanks.

1 Like

Gigapixel AI seems completely broken to me. First of all, the update is a vicious circle. Whenever I start Gigapixel AI it tells me, that there is an updated version available. I let it do it’s thing with the update. Next time I start Gigapixel AI it tells me, that there is an update available. So endless circle. Secondly Gigapixel AI always hangs on saving, when I call the app from Capture One 20. It does seem to do the upscaling, but when I save it hangs. No progress information, no visual feedback at all.

Versions involved: MacOS 10.15.4; Capture One 20 (for Sony): 13.1.0.172; Gigapixel AI: 4.9.3

Hi Oliver,

Please go to /Applications/Topaz Labs LLC/Gigapixel AI/ and delete the components.ini file. Then try the update again. This should fix the update cycle issue.

Unfortunately at this time, Gigapixel doesn’t support launching as an external application from another program. I should have a fix out for that soon, but in the meantime you’ll need to launch it as a standalone application.

Thanks for reaching out and if you run into any more issues please reply here!

2 Likes

Well, I attached a pic of my interface to my first message, but the page told me you can not send a pic! so I deleted it compulsorily.

Wooow! What a quick man you are :star_struck: Thanks a million. I will check new fixed version now.

Topaz developers are so faster than Topaz page writers :grin: Always some days after a new version, now there is its page appeared.:sweat_smile:

Hi. Firstly, thank you for making this software. So many old images have been brought to life!! Secondly, thank you for listening to your customers (I confess I am still using the trial)

For me, it seems drag and drop is no longer functional

Kind regards