Gigapixel AI v4.7

Full installers: Windows, Mac

Released April 28, 2020.

New features

  • Previously-used settings are now saved

Improvements

  • More reliable performance benchmarking
  • Popup menus now support arrow-key selections

Fixes

  • Scaling by width or height now scales all images in batch correctly
  • Switching files with auto-preview on now updates preview correctly
  • Fix face refinement not correctly updating over multiple images
  • Fix a tiff metadata crash

Known issue

  • Windows: drag and drop won’t work if you open Gigapixel directly from the installer. Quit and relaunch and it will start working.

We found an issue with saving with this latest version; taking it down until we can fix it. Sorry about that!

My computer specs.
Windows 10 Pro 64-bit Version 1903
Alienware Aurora R8 9th Gen Intel® Core™ i9 9900K (8-Core/16-Thread, 16MB Cache, Overclocked up to 4.7GHz on all cores)
NVIDIA® GeForce RTX™ 2080 Ti GDDR6 (Over Clock Ready)
Installed Memory (RAM) 32GB Dual Channel HyperX™ DDR4 XMP at 3200MHz
850W EPA Bronze PSU Liquid Cooled Chassis
Photoshop CC Version 21.1.0 release
Internet provider Century Link fiber optic Gigabit

Testing for Gigapixel AI v4.7

I didn’t notice a benchmarking procedure action when I started it up, but will accept that it is now more reliable.

Popup menus are supported with arrow-key selections.

When I switch files with auto-preview on the updates are previewing correctly.

Face refinement feature updating correctly over multiple images.

Have not noticed any tiff metadata crashes, but not sure how to test for them.

1 Like

Hi Eric @eric2

Can I ask, were you also able (I did not note any specific reference to it in your various replies on the v4.6.0 thread) to confirm the crashing I mentioned still(?) happening in v4.6.0 that was cured in the 4.5.5 that said I had tested for Ashley??? As such or should I say if so, has that been cured in v4.7 ?

TIA :slight_smile:

What does that mean? Can you please clarify in a bit more detail the correct procedure? Thanks in advance.

It’s the fact that in most applications on Windows, drag and drop doesn"t work when you run it with admin rights. The installer needs admin rights to install the program and at the end if you launch it via the installer program you keep the admin rights. Just uncheck the box to launch it at the end of the installation and launch AI Gigapixel like you normally do : the desktop shortcut icon or with Windows start menu.

Maybe it’s not totally related, but I found, how to fix OpenCV issue for Skylake-X users on Windows 7 for older versions of your AI software lineup, for example Gigapixel 4.4.6.

Just add permanent environment variable OPENCV_IPP=AVX2

Thanks to that, waifu2x-caffe also started working again without crashing.

When I launch normally, GPAI crashes with Face refinement… with admin rights, it works but drag and drop fails.

Bug: When multiple pics are inserted and we select “Width” option, the width of output pics are not the same. For example, I inserted the width as 1080px for 4 pics. The width of First pic was correct (1080px), the second one was wrong (not 1080px). 3th pic and 4th pics were wrong too.

Bad feature: Why there is not any option that we can disable preview window?

I wasn’t able to replicate that bug on my pc. Are you sure that all 4 images were selected (Select All button ticked) when you entered the width value?

Yes. All of them were selected and output pics were labeled with 1080px too. Also in program window all of them were labeled with “Width” and the size of “1080px”

My system use Windows 7 (x64), if it is important.

I’ve been having the same issue but with “Height” instead of “Width”. The first picture of the batch is processed correctly, but the others have incorrect pixel heights even though the program lists them as having correct ones. I have have been having this issue since 4.50. I have been using 4.46 still because of this. I am on Windows 10 (x64).

1 Like

I downloaded the updated to 4.7 and expereienced the saving-problem. I re-installed 4.6, but had still problems with saving. Tried to uninstall gigapixel and re-install 4.6, but alas no luck. Is there something I’ve missed to do?

In version 4.6, the highest quality model, dealing with light blue or light black, has very strong noise

Another issue that deserves attention is the processing of lines in detail, which becomes very jagged, especially anime images

Yes exactly just as me. This problem was appeared in 4.5.0. No problem in 4.4.6

Should be fixed in 4.7.1.

Yes, the problem was solved :star_struck:. Thanks. Albeit I hope see an option to disabling preview window in next version.:rose::hibiscus:

1 Like

Just attempted to install 4.7.1 Installer gets near the end and hangs unpacking \tgrc\giga-ov.tc

Just before that it says that \tgrc already exists. It does not exist. I tried manually adding that folder, but it made no difference.

Never mind - downloaded again and it installed correctly. Apparently a corrupt download.

Please fix the update installer. I updated from 4.5.0 to 4.7.1 and when I launched the program the drag and drop functionality doesn’t work. I closed and launched the program again and drag and drop works, but shows that version is still 4.5.0.