Gigapixel AI v4.6

Download full installers: Windows, Mac

Released April 16, 2020.


  • Pressing “Enter” after modifying any text field will now accept the value and remove focus from the text field
  • Maximum scale multiplier is now based on max pixel count of 32k (instead of just 6x)


  • Color profiles now apply correctly
  • Colorspace conversion now correctly applies even if “convert file format” is false
  • Different height / width / scale settings now recalculate correctly in batch mode
  • Physical (in, cm) height and width now behave correctly when you toggle between them

Thanks Eric. I experienced updating issues. After update I still have the 4.5.0 version which again and again … offers me to update.

1 Like

Same situation on initial download…correct version when downloaded from forum link.

My computer specs.
Windows 10 Pro 64-bit Version 1903
Alienware Aurora R8 9th Gen Intel® Core™ i9 9900K (8-Core/16-Thread, 16MB Cache, Overclocked up to 4.7GHz on all cores)
NVIDIA® GeForce RTX™ 2080 Ti GDDR6 (Over Clock Ready)
Installed Memory (RAM) 32GB Dual Channel HyperX™ DDR4 XMP at 3200MHz
850W EPA Bronze PSU Liquid Cooled Chassis
Photoshop CC Version 21.1.0 release
Internet provider Century Link fiber optic Gigabit

Download, Install, and booting up were quick and smooth.
The two improvements mentioned operated as stated.


  1. Color profiles appear correctly.
  2. Sorry, I didn’t understand this at all, so will assume it correctly applies.
  3. Height, width, and scale recalculated correctly in the 10 images I tested.
  4. Physical height and width are behaving correctly when toggles.

It would be helpful if 2X was not the default resize scale, and instead make this option sticky. Let it stay at the last setting chosen.

It was always good at architectural items, and still is particularly good at well focused faces. Small faces in the distance are not going to look great when blown up and I don’t ever expect them to, because they are not that sharp and clear to begin with.

I’m also getting the updater leave me with the same version installed, which then continues to prompt to update. I assume I can down the installer as @ellemat2 suggests. However, I believe that the install which did occur (but left me with the same version) has taken up a decent amount of disk space. Can anyone confirm how to clear this unnecessary usage of space?


1 Like

I have the same problem with the update. The version stays at 4.5.0 and i get the update is available when running the program. I think an uninstall and new install is needed for 4.6.0

1 Like

same thing here

Sorry about this - auto-updater should be fixed now.

Thanks Eric. I used the standalone installer now. That worked for me.

I fear to ask, but when will these blurry output results of Gigapixel be fixed? In the current state Gigapixel is not a great help to me. The preview itself varies a lot only by slightly moving the view around. In the worst case the preview is as blurry as the original file and the final processed image saved too. :frowning:

1 Like

Very strange, I have not seen this behavior on mine. Does it happen with CPU processing also?

Please go to Help-> Graphics info and press copy then post the info here.

You have both GPU and CPU selected for processing. Choose only one please then test both the GPU with Medium Memory Model, then switch to OpenVINO but set GPU off.

NOTE: Do this after pressing the Use Recommended Settings button on the Preferences panel then it will Re-Calibrate when you next update a preview. Your Preferences will either choose GPU or OpenVINO like this:


Try to run it with Administrator rights.
Have same problem and with Admin rights it work.

Was the main subject of the photo (the car) enhanced in the final output?

I noticed in your video that the preview started to more significantly enhance the background once the car was completely removed from the preview area.

I just watched the video, and I think it’s just one of the rules that the AI is trying to follow. In the preview it doesn’t know anything about the image as a whole, and so it tries to make a best guess about what’s supposed to be in the plane of focus. When it processes the image as a whole it has more information to consider and makes a different decision about what’s in focus and what’s not.

If you have a properly composed image with the subject in focus and a background with plenty of lovely bokeh you probably wouldn’t be too happy if Gigapixel converted it to an image with everything in focus during the enlargement.

@ alanhusband Yes, GP often chooses certain areas of an image to work on and others to work less or not on at all. And it seems to make different decisions in the preview and in the final save which makes the preview useless.

@ in_94-43582 Using Administrator rights did not change the shown behavior

@ johnystar Yes, it happens the same when using CPU only.

@ andymagee I also tried to split the image into tiny 500 * 500 pieces where GP should not be affected by taking into account other areas of the image but again some pieces appeared blurry.

@ AiDon I did the experiments with the settings you described with no success. No matter what I try, the issue is always exactly the same. Here are my graphics infos:

Not fixed for me. I have the same problem. I installed the new update 4.6.0 a minute ago, but it still shows 4.5.0 when I run Gigapixel AI and it still asks to install the new update. Any help is greatly appreciated.

1 Like

There is an issue with your Preferences panel as I pointed out, please take a screenshot of the panel with all the preferences showing. It will NOT work correctly if you are using GPU & CPU and it should not be like that if your system has been calibrated successfully.

AiDon, I followed your instructions to test it with the GPU alone and with CPU alone after but the issues are still the same. Calibrating did not change anything. Of course I can make screenshots of any preferences I made a try with.

1 Like

You mean calibrating left both the GPU & OpenVINO active as in your video?

Yes AiDon. Look:

1 Like