Failed upscaling and BSOD with Topaz Video - 13th or 14th gen Core i9 and i7

I’ve had an issue with Topaz Video that could not be figured out for many months. Constant failures and often BSOD. So much that the software was pretty much unusable. However, I found out the issue, fixed it and wanted to share it. You can Google this issue (it wouldn’t let me post any links).

But basically, some processor and motherboard combos set the CPU power limit to 4096w and 4096a and it should be 275w and 350a.

After applying this fix, I’ve had zero issues with Topaz Video even after letting it run all night on a batch of 20+ videos. Before this fix, it would usually not even complete a single video.

I thought your support team should be aware of this, if you have experienced similar complaints.

I had these issues too even when setting the power limits right manually because the MSI bios set both limits to 4096 W when I suddenly noticed that the CPU was set to 512 A instead of 307 A according to Intel on my 13900K!

This is intriguing, as I have indeed had crashes since upgrading to an i9-13900k. I found the Tom’s article that I imagine you’re referring to, but my BIOS won’t let me change some of those settings. PL2, for instance, was stuck on Auto, and Auto was 4096w.

But one of the comments on that article talked about Asus Multi-Core Enhancement, and how changing it from Enable to Disabled-Enforce All Limits is what fixed this whole thing for him. THAT, I was able to do. Those settings are still stuck on Auto, but now the two wattages read 253w. I forget the amperage setting.

This change has not fixed the persistent Unity crashes I’ve seen since upgrading (I fixed those, or worked around them anyway, by turning off Hyperthreading for those processes), but I haven’t had a chance to test whether it’s fixed my intermittent Topaz crashes. I’m optimistic though, based on what I’ve read today.

The steps can be different depending on your Motherboard. They also can go by different names. For example, on a Gigabyte motherboard you have to turn Turbo Power Limits to enabled, then set Platform Power Limit 1 and 2 to 275, and Core Current Limit to 350 amps. Those options will not show up until you first set the Turbo Power Limits to enabled.

You should be able to leave Multi-Core Enhancement on. At least I could. Though, before fixing the other settings, turning Multi-Core Enhancement off can help.

Also note that if you have trouble updating motherboard settings, I was told that the “Intel Extreme Tuning Utility” can handle these power setting updates as well. Though it is probably still better if you can set them in the BIOS.

I’ll keep messing with it. Turning off MCE changed PL1 and PL2 to 253 and the amperage is set to 500. Topaz still crashed overnight (edit: that is, my job errored out; the program didn’t crash). I guess it’s hard to say if the things are related.

500 A is probably too much. For the 13900K IccMax should be 307 A according to Intel!

I’m still struggling with how to set these values manually in my BIOS. I got nothing but errored-out jobs in Topaz when I turned MCE off, so I turned it back on and now they get a lot further before they error out.

I have yet to have anything other than a preview finish successfully with 4.2.0, so I think I just have to wait for the next version and cross my fingers. I wish there was a way to roll back to 4.1.2, as that was pretty stable for me.

Here it is: Topaz Video AI v4.1.2

Thanks, I didn’t think to look there. In the download section, there’s a “previous releases” option, but it only gives one very old option. :grinning:

Try downloading the “Intel Extreme Tuning Utility” and set them with that. I’m not positive where to set the volts, but under “Advanced Tuning” you can set “Processor Core IccMax” to 350a, maybe that will be enough to help.

1 Like

IccMax is the setting you are looking for! Official Intel are 307 A for a 13900K. :slight_smile:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.