DeNoise 3.4

Still works great as usual. I notice that the CPU mode is faster than on version 3.3.x.

Not working in Photoshop 2022 either. Nor as a standalone application. What’s happening?

Have you ran the application as a standalone before using it in PS? What errors are you getting from PS?

We are looking at the white output issue. So far it seems to only affect M1 machines but we’re trying to narrow it down.

If you can reproduce it can you please try AI Clear and see if that also has white output? Also, can you confirm that the preview does or does not work? And when you do get white output, what model, settings, post-processing settings, and save settings? I’m trying to reproduce on my own M1 machine and I cannot get it to output white.

Hi, Edited after things moved on since my initial post.

DeNoise v3.4 initially installed and worked fine (through that session), but when I returned to editing this afternoon it crashed on opening whether standalone, or as a Lightroom/ Photoshop plug-in. I rebooted then download and reinstalled it, but the problem persisted so I rolled back to v3.3.4 (which worked OK).

Having done this I download and reinstalled v3.4 again - initially keeping v3.3.4 in place. Both worked fine. So it appears a glitch. I’ve uninstalled v3.3.4 (which v3.4 asked me if I wanted to). The original crash report and a screen dump are in the below Dropbox Folder.

Last update for now - I just returned to do some more editing after tea and - v3.4 crashes on opening from Lightroom, Photoshop via plug-ins and as a standalone. I reinstalled v3.3.4 and both versions work. It seems if I take v3.3.4 out (which v3.4 asks me if I want it to do) it somehow breaks v3.4 on my machine. There’s a pattern developing here. I think I’ll keep both installed for now and see if any updates come out,

Issues with 3.4 which may be of note are that when opened from Lightroom (a) ‘Close Panel’ is shown instead of returning to Lightroom when processing is complete, (b) the saved files (TIFFS) are not being loaded into Lightroom - I have to do a ‘synchronise folder’ to load/ see them and (c) after processing the screen redraw (comparison view) is skewed until I force a refresh - screen dump added to Dropbox.

[MacBook Pro M1 Max 16”, 32-core GPU, 32GB URAM, 1TB SSD. Monterey 12.1, Lightroom 11.1, Photoshop 23.1. Note Catalogue/ images held on external SanDisk Extreme PRO 2GB SSD].

Phil

Dropbox Link: Dropbox - Report - Simplify your life)

2 Likes
  • I try all AI model (excluding RAW) and nothing worked. All produced a white blank photo.
  • I did try different settings, post-processing set all to 0 and also different values, but nothing work.
    Using macbook air M1.

So even AI clear had this issue? That’s the important part as it uses a different engine. And again, do these work when previewing before saving?

Previewing work as normal. No problem. Only problem is when saving it produces blank image.

I am going to do a special build and I’ll post a link here once it’s done. I removed some code that was added to speed up some post-processing on export that potentially does not work nicely on M1 (although still a mystery why my M1 seems fine). If you could test it when it’s available I’d appreciate it.

Here is the special version to test a potential white output fix. Also sending this to some people who created support tickets. Please let me know if this works, although don’t feel obligated to test if you don’t want to.

https://downloads.topazlabs.com/deploy/TopazDeNoiseAI/3.4.1-rc1/TopazDeNoiseAI-3.4.1-rc1-osx-Full-Installer.dmg

I have de same problem and same Mac Pro M1

I just test 3.4.1-rc1 with different AI models and they all export correctly. :+1:

1 Like

I just tested two pics. It seems to save properly now. I guess it was a wrong multiplication factor somewhere and everything ended up to be saturated…

1 Like

Thank you @minh.luong and @roberto.avanzi for testing. I’m currently building actual 3.4.1 and will release it ASAP. This will also be the first real test of the new Mac update system, so if that breaks I guess let me know.

1 Like

Glorious It also seems to be Universal and it indeed seems to process faster than the previous version. I guess Sharpen and Gigapixel will follow soon?

That’s the plan! I don’t know which will be first but I think it should be sometime late January if all things go well.

I have been doing beta testing for Wolfram and DxO in the past, I am more than willing to play guinea pig for you guys.

Same problem on M1 max, however, launched DENOISE in Rosetta and it was okay.
The plugin also worked in PS 2022 but again running under Rosetta.

The update process worked here! I have updated to 3.4.1. release (from the RC1) and it loads and seems to process and save images properly.

Downnload new 3.4.1 - Everything work as normal. Thank you.

1 Like