Crash when image is re-imported back into Lightroom Classic | MacOS

Hello. I’m hoping this has been addressed but have recently updated to Photo AI 3.01. Since this update, when I am in LR Classic and I send an image to Photo AI it appears to run smoothly. It processes the image, but when finished and it returns the image to Lightroom, the entire system hangs. LR has a message in the upper corner that reads, “preparing the image for processing” (which it has apparently already done and sent off to Photo AI" and the spinning wheel of death is present on the LR screen with the entire system just locked up and hanging. It basically crashes my system and it has never done this before. I have just tried to edit 3 different images since the update and this has happened to my system each time.

Running a desktop iMac 3.8Ghz 8 core processor with the AMD Radeon Pro 5500 Driver. I have 64 GB of internal Ram and I have never had this sort of thing happen before. LR classic is up to date with version 13.2.

The nickel version is, I am in LR. I send an image to photo ai for a quick edit and on re-import back into LR it crashes LR and then my entire system forcing me to “force quit” LR and Topaz Photo aI. This has never happened with a previous version of the software.

Thanks if anyone has a clue what the cause might be.

Tom

I’d like to get some more information to help troubleshoot the problem you are having.

Could you send us your computer’s full system profile?

Also if you can, please try to recreate this crash in Topaz Photo AI, then go to Help > Open Log Folder, please send me all of the files within that folder. You should be able to attach them directly as a response to this thread.

If you would prefer you can securely submit your files(s) to my Dropbox using the link below. Make sure to send me a note to let me know you sent something. :slight_smile:

Dropbox File Request

John, thank you for replying to my bug issue. I really do appreciate that. Here is my system report as requested. I went into Photo AI to try and re-create the issue. It did in fact do it again but because it locked everything up when trying to return my image back into LR I was not able to go to Help> Open Log Folder because I had spinning wheels on both programs and no access to anything. I don’t know if this will help but I re-opened Photo AI after the most recent attempt as a stand alone, not a LR plugin and went in and these are the files that were in that Log Folder when I opened it up that way.

I hope this helps. Since this started happening with the most recent update I have reverted back to using Sharpen AI and while that has not been updated in some time, it works. That being said, I appreciate you trying to help figure out what is causing this most frustrating issue.

Tom Wagner
argolich@gmail.com
#513-266-5570

lastSessionFiles.txt (53 Bytes)

iMac sys report 050724.spx (6.16 MB)

2024-04-27-08-15-55.tzlog (87.4 KB)

2024-04-27-08-06-6.tzlog (81.9 KB)

2024-04-27-08-23-50.tzlog (26.6 KB)

2024-04-25-07-57-31.tzlog (81.8 KB)

2024-04-27-08-11-37.tzlog (81.8 KB)

2024-05-05-07-17-43.tzlog (75.4 KB)

2024-05-05-07-13-16.tzlog (125 KB)

2024-05-05-07-36-44.tzlog (89.4 KB)

2024-05-07-07-24-12.tzlog (79.4 KB)

2024-05-05-07-43-22.tzlog (25.1 KB)

2024-05-07-07-27-39.tzlog (22.4 KB)

Hello John:

I know you and the team are looking into the issue of why Photo AI locks up and crashes upon returning the edited photo to LR classic. I’m still experiencing this issue and this morning, I was able to get a new log file directly after the crash so I thought i would submit this to you as the most recent incident. Literally just happened within the last few minutes and here is the Photo AI Log. Thanks so much.

Tom

2024-05-09-08-03-50.tzlog (22.4 KB)

Thanks for sending in those files.

Our developers have a task that they are investigating that a few other users have reported with this instance. To help the devs, can you tell me if this issue is occurring with a particular file type or with all of your images? Also, which plugin option are you using for the Lightroom Classic plugin:

  • The RAW plugin, accessed through File > Plug-in Extras > Process with Topaz Photo
  • The External Editor Plugin, accessed through Photo > Edit in > Topaz Photo AI

While our developers are working on this if you would like to revert to the previous Topaz Photo AI version, you can find use the following link:

Topaz Photo AI | v2.4.2 | MacOS Installer

Thanks so much for following up! When it comes to using Photo AI from LR this is happening on all of my files. I use raw files from multiple Fuji cameras. I’m not sure which of the above options you submitted to me are the one I am using as I don’t do either of those options. In LR I right click on the image and go to edit in…and navigate to the plug in as indicated in this image. I suspect it is the external editor plugin but I’m not sure.

Tom

Please try using the option Edit In > Topaz Photo AI as seen in the screenshot below highlighted:

The plugin option you are currently using is from one of our previous External Editor options and should no longer be used. To remove that option you can go to Lightroom Classic > Preferences > External Editor menu.

Let me know if you are still having issues using the other plugin option and I will keep an eye out for how that goes for you.

Well that seems very much like what I have been doing but I tried it using the Topaz Photo AI that you have highlighted instead of the one up top I have been using. The program still hangs and does not close down when I process the image and send it back to Light room. Program just hangs. I had to force quit Topaz Photo AI. Went back in and here is the most recent log file. A screen shot showing that when I return to LR from Photo AI, LR is still showing the “preparing the file for editing” in the upper left corner of LR. My screen shot did not capture the “spinning wheel” unfortunately.

Tom

lastSessionFiles.txt (53 Bytes)

2024-05-09-18-45-49.tzlog (22.7 KB)

Let’s try updating you to the most recent version release to see if this resolves the issue.

Please make sure you’ve also turned off any firewall, VPN, or proxy that may be on your computer. These are known to block the installation. Also, make sure there are no settings or configurations in your OS system that could interfere.

Try using the link below to update:

Thank you for the update, John. I appreciate it. I had to go out of town for a few days for work but when I return this coming Saturday I will take a look at that. Please give me a couple of days before closing out this issue. I will give that a try and get back to you early next week.

Sincerest regards,

Tom

1 Like